summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-01-26 19:15:31 +0000
committerJohannes Huber <johu@gentoo.org>2015-01-26 19:15:31 +0000
commit724fcfa5d6d08f34c35c8b74295b903ff2ae3e76 (patch)
treea684958cee9b769c01a4c366656d513be933b182 /net-im/choqok
parentExpand package.use.mask for telepathy use flag. (diff)
downloadgentoo-2-724fcfa5d6d08f34c35c8b74295b903ff2ae3e76.tar.gz
gentoo-2-724fcfa5d6d08f34c35c8b74295b903ff2ae3e76.tar.bz2
gentoo-2-724fcfa5d6d08f34c35c8b74295b903ff2ae3e76.zip
Version bump, bug #537828.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'net-im/choqok')
-rw-r--r--net-im/choqok/ChangeLog10
-rw-r--r--net-im/choqok/choqok-1.5.ebuild48
-rw-r--r--net-im/choqok/metadata.xml3
3 files changed, 59 insertions, 2 deletions
diff --git a/net-im/choqok/ChangeLog b/net-im/choqok/ChangeLog
index 7e241c86c187..d11d438e706b 100644
--- a/net-im/choqok/ChangeLog
+++ b/net-im/choqok/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/choqok
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/choqok/ChangeLog,v 1.42 2014/08/05 18:34:12 mrueg Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/choqok/ChangeLog,v 1.43 2015/01/26 19:15:31 johu Exp $
+
+*choqok-1.5 (26 Jan 2015)
+
+ 26 Jan 2015; Johannes Huber <johu@gentoo.org> +choqok-1.5.ebuild,
+ metadata.xml:
+ Version bump, bug #537828.
05 Aug 2014; Manuel Rüger <mrueg@gentoo.org> choqok-1.4.ebuild:
Remove trailing '.' from DESCRIPTION.
diff --git a/net-im/choqok/choqok-1.5.ebuild b/net-im/choqok/choqok-1.5.ebuild
new file mode 100644
index 000000000000..c837afd1ab6b
--- /dev/null
+++ b/net-im/choqok/choqok-1.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/choqok/choqok-1.5.ebuild,v 1.1 2015/01/26 19:15:31 johu Exp $
+
+EAPI=5
+
+KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et fa fi fr ga gl
+hr hu is it ja km lt mr ms nb nds nl pa pl pt pt_BR ro ru sk sl sq sv tr ug
+uk zh_CN zh_TW"
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="Free/Open Source micro-blogging client for KDE"
+HOMEPAGE="http://choqok.gnufolks.org/"
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+else
+ KEYWORDS=""
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+IUSE="ayatana debug telepathy"
+
+RDEPEND="
+ dev-libs/libattica
+ dev-libs/qjson
+ >=dev-libs/qoauth-1.0.1
+ ayatana? ( dev-libs/libindicate-qt )
+ telepathy? ( net-libs/telepathy-qt[qt4] )
+"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/gettext
+"
+
+DOCS=( AUTHORS README TODO changelog )
+
+src_prepare(){
+ local mycmakeargs=(
+ $(cmake-utils_use !ayatana QTINDICATE_DISABLE)
+ $(cmake-utils_use_find_package telepathy TelepathyQt4)
+ )
+
+ kde4-base_src_prepare
+}
diff --git a/net-im/choqok/metadata.xml b/net-im/choqok/metadata.xml
index a23f444b67d6..cfaec22d09db 100644
--- a/net-im/choqok/metadata.xml
+++ b/net-im/choqok/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>kde</herd>
+ <use>
+ <flag name="telepathy">Enable support for the real-time communication framework telepathy</flag>
+ </use>
</pkgmetadata>