summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2006-10-23 18:59:25 +0000
committerMichael Januszewski <spock@gentoo.org>2006-10-23 18:59:25 +0000
commit772ef01eecf744b5dc7509522aed045931db393d (patch)
tree7924d5c43f8b5d1677cee203963a2878e674f40b /net-im/ekg
parentStable on hppa (diff)
downloadgentoo-2-772ef01eecf744b5dc7509522aed045931db393d.tar.gz
gentoo-2-772ef01eecf744b5dc7509522aed045931db393d.tar.bz2
gentoo-2-772ef01eecf744b5dc7509522aed045931db393d.zip
Version bump.
(Portage version: 2.1.2_pre3-r7)
Diffstat (limited to 'net-im/ekg')
-rw-r--r--net-im/ekg/ChangeLog8
-rw-r--r--net-im/ekg/ekg-1.7_rc2.ebuild64
-rw-r--r--net-im/ekg/files/digest-ekg-1.7_rc23
-rw-r--r--net-im/ekg/files/ekg-1.7_rc2-giflib.patch46
4 files changed, 120 insertions, 1 deletions
diff --git a/net-im/ekg/ChangeLog b/net-im/ekg/ChangeLog
index 8d9f5f280d20..a3277363e36e 100644
--- a/net-im/ekg/ChangeLog
+++ b/net-im/ekg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/ekg
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ChangeLog,v 1.30 2006/07/07 20:34:45 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ChangeLog,v 1.31 2006/10/23 18:59:25 spock Exp $
+
+*ekg-1.7_rc2 (23 Oct 2006)
+
+ 23 Oct 2006; Michał Januszewski <spock@gentoo.org>
+ +files/ekg-1.7_rc2-giflib.patch, +ekg-1.7_rc2.ebuild:
+ Version bump.
07 Jul 2006; Michał Januszewski <spock@gentoo.org> ekg-1.6_rc3.ebuild,
ekg-1.6.ebuild:
diff --git a/net-im/ekg/ekg-1.7_rc2.ebuild b/net-im/ekg/ekg-1.7_rc2.ebuild
new file mode 100644
index 000000000000..8bdd5965f652
--- /dev/null
+++ b/net-im/ekg/ekg-1.7_rc2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ekg-1.7_rc2.ebuild,v 1.1 2006/10/23 18:59:25 spock Exp $
+
+inherit eutils autotools
+
+IUSE="ssl ncurses readline zlib python spell threads gif jpeg"
+
+DESCRIPTION="EKG (Eksperymentalny Klient Gadu-Gadu) - a text client for Polish instant messaging system Gadu-Gadu"
+HOMEPAGE="http://ekg.chmurka.net/"
+SRC_URI="http://ekg.chmurka.net/${P/_/}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+
+S="${WORKDIR}/${P/_/}"
+
+RDEPEND="net-libs/libgadu
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ ncurses? ( sys-libs/ncurses )
+ readline? ( sys-libs/readline )
+ zlib? ( sys-libs/zlib )
+ python? ( dev-lang/python )
+ spell? ( >=app-text/aspell-0.50.3 )
+ gif? ( media-libs/giflib )
+ jpeg? ( media-libs/jpeg )"
+
+DEPEND=">=sys-devel/automake-1.7
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-1.6_rc3-libgadu.patch
+ epatch ${FILESDIR}/${PN}-1.7_rc2-giflib.patch
+ eautoreconf
+}
+
+src_compile() {
+ local myconf="--enable-ioctld --disable-static --enable-dynamic"
+ if use ncurses; then
+ myconf="$myconf --enable-force-ncurses"
+ else
+ myconf="$myconf --disable-ui-ncurses"
+ fi
+ use readline && myconf="$myconf --enable-ui-readline"
+
+ econf ${myconf} \
+ `use_with python` \
+ `use_with threads pthread` \
+ `use_with jpeg libjpeg` \
+ `use_with gif libgif` \
+ `use_enable zlib` \
+ `use_enable spell aspell` \
+ `use_enable ssl openssl` \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc docs/* docs/api/*
+}
diff --git a/net-im/ekg/files/digest-ekg-1.7_rc2 b/net-im/ekg/files/digest-ekg-1.7_rc2
new file mode 100644
index 000000000000..81f07c98d208
--- /dev/null
+++ b/net-im/ekg/files/digest-ekg-1.7_rc2
@@ -0,0 +1,3 @@
+MD5 b4ea482130e163af1456699e2e6983d9 ekg-1.7rc2.tar.gz 514073
+RMD160 bba2fa114e252aa088f86264eafd65d3e2bcca0a ekg-1.7rc2.tar.gz 514073
+SHA256 17b42147dfe4ef8b7d901e285d68c490f7c645240c6934c23f0db82e61ace915 ekg-1.7rc2.tar.gz 514073
diff --git a/net-im/ekg/files/ekg-1.7_rc2-giflib.patch b/net-im/ekg/files/ekg-1.7_rc2-giflib.patch
new file mode 100644
index 000000000000..a153f2d93fd5
--- /dev/null
+++ b/net-im/ekg/files/ekg-1.7_rc2-giflib.patch
@@ -0,0 +1,46 @@
+diff -Naurp ekg-1.7rc2-orig/configure.in ekg-1.7rc2/configure.in
+--- ekg-1.7rc2-orig/configure.in 2006-10-23 20:33:54.000000000 +0200
++++ ekg-1.7rc2/configure.in 2006-10-23 20:35:45.000000000 +0200
+@@ -454,20 +454,20 @@ if test "x$with_libgsm" != "xno"; then
+ fi
+
+ dnl
+-dnl Sprawdzamy libungif.so i <gif_lib.h>
++dnl Sprawdzamy libgif.so i <gif_lib.h>
+ dnl
+
+-AC_ARG_WITH(libungif,
+- [ --without-libungif Compile without GIF token support])
++AC_ARG_WITH(libgif,
++ [ --without-libgif Compile without GIF token support])
+
+-if test "x$with_libungif" != "xno"; then
+- AC_CHECK_LIB(ungif, DGifSlurp,
++if test "x$with_libgif" != "xno"; then
++ AC_CHECK_LIB(gif, DGifSlurp,
+ [
+ AC_CHECK_HEADERS(gif_lib.h,
+ [
+- AC_DEFINE(HAVE_LIBUNGIF, 1, [define if you have libungif])
+- LDFLAGS="-lungif $LDFLAGS"
+- have_libungif=yes
++ AC_DEFINE(HAVE_LIBUNGIF, 1, [define if you have libgif])
++ LDFLAGS="-lgif $LDFLAGS"
++ have_libgif=yes
+ ])
+ ])
+ fi
+@@ -686,10 +686,10 @@ else
+ echo " - pthread: disabled"
+ fi
+
+-if test "x$have_libungif" = "xyes"; then
+- echo " - libungif: enabled"
++if test "x$have_libgif" = "xyes"; then
++ echo " - libgif: enabled"
+ else
+- echo " - libungif: disabled"
++ echo " - libgif: disabled"
+ fi
+
+ if test "x$have_libjpeg" = "xyes"; then