summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2015-03-01 15:42:59 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2015-03-01 15:42:59 +0000
commit1fc88188b94e67d4af7c9c848bbefcfbad7abc8a (patch)
tree34698524585d3e6d74c4285dc1eee56153f82a9d /net-im/emesene/emesene-9999.ebuild
parentFix multilib build when dev-libs/qjson is missing wrt bug #541438. (diff)
downloadgentoo-2-1fc88188b94e67d4af7c9c848bbefcfbad7abc8a.tar.gz
gentoo-2-1fc88188b94e67d4af7c9c848bbefcfbad7abc8a.tar.bz2
gentoo-2-1fc88188b94e67d4af7c9c848bbefcfbad7abc8a.zip
net-im/{amsn,emesene} removal
Diffstat (limited to 'net-im/emesene/emesene-9999.ebuild')
-rw-r--r--net-im/emesene/emesene-9999.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/net-im/emesene/emesene-9999.ebuild b/net-im/emesene/emesene-9999.ebuild
deleted file mode 100644
index f99af7fb25fb..000000000000
--- a/net-im/emesene/emesene-9999.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/emesene/emesene-9999.ebuild,v 1.12 2014/08/05 18:34:06 mrueg Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-PYTHON_USE_WITH="sqlite"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-EGIT_REPO_URI="git://github.com/${PN}/${PN}.git
- http://github.com/${PN}/${PN}.git"
-
-inherit distutils eutils git-2
-
-DESCRIPTION="Platform independent IM client written in Python+GTK"
-HOMEPAGE="http://www.emesene.org"
-
-LICENSE="|| ( GPL-2 GPL-3 LGPL-3 )"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-RDEPEND="dev-python/pygtk:2
- dev-python/notify-python
- dev-python/pywebkitgtk
- dev-python/pyopenssl
- dev-python/xmpppy"
-
-src_prepare() {
- # do not import dummy session
- sed -i -e "/import e3dummy/d" ${PN}/${PN}.py || die
- # Use a better meny entry
- sed -i -e "/^Name/s:${PN}:Emesene:" \
- ${PN}/data/share/applications/${PN}.desktop || die
- python_convert_shebangs -r 2 .
- distutils_src_prepare
-}
-
-src_install() {
- mysymlink(){
- dosym $(python_get_sitedir)/${PN}/${PN} /usr/bin/${PN} || die
- }
- distutils_src_install
- python_execute_function -q mysymlink
-}
-
-pkg_postinst() {
- elog
- elog "${PN} is on early stages of development."
- elog "Please do not file bugs on Gentoo bugzilla"
- elog "unless you have problems with this ebuild."
- elog "Use the upstram bug tracker to report bugs:"
- elog
- elog "https://github.com/emesene/emesene/issues"
-}