summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlec Warner <antarus@gentoo.org>2007-01-06 03:16:23 +0000
committerAlec Warner <antarus@gentoo.org>2007-01-06 03:16:23 +0000
commit1cc54032363e9c3963ca7ee287f054a8e8780a89 (patch)
tree51202bb28bb4161c82dc7579902074d6fa317dc4 /net-im/gajim
parentQA: Removed unused versions. (diff)
downloadgentoo-2-1cc54032363e9c3963ca7ee287f054a8e8780a89.tar.gz
gentoo-2-1cc54032363e9c3963ca7ee287f054a8e8780a89.tar.bz2
gentoo-2-1cc54032363e9c3963ca7ee287f054a8e8780a89.zip
QA: fix bad usage of !use and !built_with_use, fix two instances of econf with ! use gnome, misc other fixes, must skin welps hide..
(Portage version: 5386-svn)
Diffstat (limited to 'net-im/gajim')
-rw-r--r--net-im/gajim/ChangeLog9
-rw-r--r--net-im/gajim/files/digest-gajim-0.11-r33
-rw-r--r--net-im/gajim/gajim-0.11-r3.ebuild86
3 files changed, 97 insertions, 1 deletions
diff --git a/net-im/gajim/ChangeLog b/net-im/gajim/ChangeLog
index 29af4e9b2eb6..961e5ee1ae2e 100644
--- a/net-im/gajim/ChangeLog
+++ b/net-im/gajim/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/gajim
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.27 2007/01/06 00:04:22 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.28 2007/01/06 03:16:23 antarus Exp $
+
+*gajim-0.11-r3 (06 Jan 2007)
+
+ 06 Jan 2007; Alec Warner <antarus@gentoo.org> -gajim-0.11-r1.ebuild,
+ -gajim-0.11-r2.ebuild, +gajim-0.11-r3.ebuild:
+ QA: fix bad usage of !use and !built_with_use, fix two instances of econf
+ with ! use gnome, misc other fixes, must skin welps hide..
06 Jan 2007; Peter Weller (welp) <welp@gentoo.org> gajim-0.10.1.ebuild:
Added pkgconfig dep to gajim-0.10.1 ebuild wrt bug #152529
diff --git a/net-im/gajim/files/digest-gajim-0.11-r3 b/net-im/gajim/files/digest-gajim-0.11-r3
new file mode 100644
index 000000000000..3d9955948df8
--- /dev/null
+++ b/net-im/gajim/files/digest-gajim-0.11-r3
@@ -0,0 +1,3 @@
+MD5 7ac7ac6fdfc515cb927adf21793856fa gajim-0.11.tar.bz2 2684957
+RMD160 ff92f3914eb14596f725a47efa04acb402053723 gajim-0.11.tar.bz2 2684957
+SHA256 1b660d2516b918fdba7533aab3dead8c222c98964ea459c5e4204c4949055422 gajim-0.11.tar.bz2 2684957
diff --git a/net-im/gajim/gajim-0.11-r3.ebuild b/net-im/gajim/gajim-0.11-r3.ebuild
new file mode 100644
index 000000000000..bdb0e66d5bfb
--- /dev/null
+++ b/net-im/gajim/gajim-0.11-r3.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.11-r3.ebuild,v 1.1 2007/01/06 03:16:23 antarus Exp $
+
+inherit multilib python eutils
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="http://www.gajim.org/"
+SRC_URI="http://www.gajim.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="dbus gnome idle libnotify nls spell srv trayicon X xhtml"
+
+DEPEND="dev-python/pysqlite
+ dev-python/pygtk
+ sys-devel/gettext
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+RDEPEND="gnome? ( dev-python/gnome-python-extras dev-python/gnome-python-desktop )
+ dbus? ( ||
+ ( <sys-apps/dbus-0.90 )
+ ( >=sys-apps/dbus-0.90 dev-python/dbus-python dev-libs/dbus-glib )
+ )
+ libnotify? ( x11-libs/libnotify )
+ xhtml? ( dev-python/docutils )
+ srv? ( net-dns/bind-tools )
+ idle? ( x11-libs/libXScrnSaver )
+ spell? ( app-text/gtkspell )
+ avahi? ( net-dns/avahi )"
+
+pkg_setup() {
+ if ! use dbus; then
+ if use libnotify; then
+ eerror "The dbus USE flag is required for libnotify support"
+ die "USE=\"dbus\" needed for libnotify support"
+ fi
+ if use avahi; then
+ eerror "The dbus USE flag is required for avahi support"
+ die "USE=\"dbus\" needed for avahi support"
+ fi
+ else
+ if has_version "<sys-apps/dbus-0.90" && ! built_with_use sys-apps/dbus python; then
+ eerror "Please rebuild dbus with USE=\"python\""
+ die "USE=\"python\" needed for dbus"
+ fi
+ fi
+
+ if use avahi; then
+ if ! built_with_use net-dns/avahi dbus gtk python; then
+ eerror "The following USE flags are required for correct avahi"
+ eerror "support: dbus gtk python"
+ die "Please rebuild avahi with these use flags enabled."
+ fi
+ fi
+}
+
+src_compile() {
+ local myconf
+ if ! use gnome; then
+ myconf="${myconf} $(use_enable trayicon)"
+ myconf="${myconf} $(use_enable idle)"
+ fi
+
+ econf $(use_enable nls) \
+ $(use_enable spell gtkspell) \
+ $(use_enable dbus remote) \
+ $(use_with X x) \
+ ${myconf} \
+ die || "econf failed"
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" install || \
+ die "emake install failed"
+ dodoc README NEWS AUTHORS ChangeLog THANKS
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/gajim/
+}
+pkg_postrm() {
+ python_mod_cleanup /usr/share/gajim/
+}