summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-09-15 05:28:20 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-09-15 05:28:20 +0000
commite6692c44c5a36da15b5839986ecd57bf8b655902 (patch)
tree92f56b2c11184e9aede76cb30a8db123232c18d4 /net-im/leechcraft-azoth
parentInitial import from the msp430 overlay. (diff)
downloadgentoo-2-e6692c44c5a36da15b5839986ecd57bf8b655902.tar.gz
gentoo-2-e6692c44c5a36da15b5839986ecd57bf8b655902.tar.bz2
gentoo-2-e6692c44c5a36da15b5839986ecd57bf8b655902.zip
Big leechcraft bump, 0.4.90
(Portage version: 2.1.10.16/cvs/Linux x86_64)
Diffstat (limited to 'net-im/leechcraft-azoth')
-rw-r--r--net-im/leechcraft-azoth/ChangeLog8
-rw-r--r--net-im/leechcraft-azoth/leechcraft-azoth-0.4.90.ebuild66
2 files changed, 73 insertions, 1 deletions
diff --git a/net-im/leechcraft-azoth/ChangeLog b/net-im/leechcraft-azoth/ChangeLog
index 0c0bfbe46c0a..0a1decc242c2 100644
--- a/net-im/leechcraft-azoth/ChangeLog
+++ b/net-im/leechcraft-azoth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/leechcraft-azoth
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/ChangeLog,v 1.2 2011/08/25 15:13:22 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/ChangeLog,v 1.3 2011/09/15 05:28:20 maksbotan Exp $
+
+*leechcraft-azoth-0.4.90 (14 Sep 2011)
+
+ 14 Sep 2011; Maxim Koltsov <maksbotan@gentoo.org>
+ +leechcraft-azoth-0.4.90.ebuild:
+ Bump net-im/leechcraft-azoth to 0.4.90, thanks to 0xd34df00d
25 Aug 2011; Maxim Koltsov <maksbotan@gentoo.org>
leechcraft-azoth-0.4.85.ebuild, leechcraft-azoth-9999.ebuild:
diff --git a/net-im/leechcraft-azoth/leechcraft-azoth-0.4.90.ebuild b/net-im/leechcraft-azoth/leechcraft-azoth-0.4.90.ebuild
new file mode 100644
index 000000000000..398d243bf06a
--- /dev/null
+++ b/net-im/leechcraft-azoth/leechcraft-azoth-0.4.90.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/leechcraft-azoth-0.4.90.ebuild,v 1.1 2011/09/15 05:28:20 maksbotan Exp $
+
+EAPI="2"
+
+inherit leechcraft
+
+DESCRIPTION="Azoth, the modular IM client for LeechCraft."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +acetamide +adiumstyles +autoidler +autopaste +chathistory +crypt
+ +depester +embedmedia +herbicide +hili +juick +lastseen +metacontacts
+ +modnok +nativeemoticons +p100q +rosenthal +standardstyles +xoox
+ +xtazy"
+
+DEPEND="=net-misc/leechcraft-core-${PV}
+ x11-libs/qt-webkit
+ x11-libs/qt-multimedia
+ xoox? ( net-libs/qxmpp[extras] media-libs/speex )
+ xtazy? ( x11-libs/qt-dbus )
+ crypt? ( app-crypt/qca app-crypt/qca-gnupg )"
+RDEPEND="${DEPEND}
+ modnok? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable crypt CRYPT)
+ $(cmake-utils_use_enable acetamide AZOTH_ACETAMIDE)
+ $(cmake-utils_use_enable adiumstyles AZOTH_ADIUMSTYLES)
+ $(cmake-utils_use_enable autoidler AZOTH_AUTOIDLER)
+ $(cmake-utils_use_enable autopaste AZOTH_AUTOPASTE)
+ $(cmake-utils_use_enable chathistory AZOTH_CHATHISTORY)
+ $(cmake-utils_use_enable depester AZOTH_DEPESTER)
+ $(cmake-utils_use_enable embedmedia AZOTH_EMBEDMEDIA)
+ $(cmake-utils_use_enable herbicide AZOTH_HERBICIDE)
+ $(cmake-utils_use_enable hili AZOTH_HILI)
+ $(cmake-utils_use_enable juick AZOTH_JUICK)
+ $(cmake-utils_use_enable lastseen AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable metacontacts AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable modnok AZOTH_MODNOK)
+ $(cmake-utils_use_enable nativeemoticons AZOTH_NATIVEEMOTICONS)
+ $(cmake-utils_use_enable p100q AZOTH_P100Q)
+ $(cmake-utils_use_enable rosenthal AZOTH_ROSENTHAL)
+ $(cmake-utils_use_enable standardstyles AZOTH_STANDARDSTYLES)
+ $(cmake-utils_use_enable xoox AZOTH_XOOX)
+ $(cmake-utils_use_enable xtazy AZOTH_XTAZY)"
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if use rosenthal; then
+ elog "You have enabled the Azoth Rosenthal plugin for"
+ elog "spellchecking. It uses Hunspell/Myspell dictionaries,"
+ elog "so install the ones for languages you use to enable"
+ elog "spellchecking."
+ fi
+}