summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-12-01 20:35:45 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-12-01 20:35:45 +0000
commit60abf341a657f57870cb49e10e86d9c9b169c623 (patch)
treedb522679cc9076ec51e911ada4f7e92e2d39049d /net-im/licq
parentStable on ppc wrt bug 200336 (diff)
downloadgentoo-2-60abf341a657f57870cb49e10e86d9c9b169c623.tar.gz
gentoo-2-60abf341a657f57870cb49e10e86d9c9b169c623.tar.bz2
gentoo-2-60abf341a657f57870cb49e10e86d9c9b169c623.zip
version bump, bug 197734
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'net-im/licq')
-rw-r--r--net-im/licq/ChangeLog7
-rw-r--r--net-im/licq/files/digest-licq-1.3.53
-rw-r--r--net-im/licq/licq-1.3.5.ebuild208
3 files changed, 217 insertions, 1 deletions
diff --git a/net-im/licq/ChangeLog b/net-im/licq/ChangeLog
index 6b720c4b1a76..358e8171c6c6 100644
--- a/net-im/licq/ChangeLog
+++ b/net-im/licq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/licq
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.89 2007/08/22 12:32:44 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.90 2007/12/01 20:35:44 genstef Exp $
+
+*licq-1.3.5 (01 Dec 2007)
+
+ 01 Dec 2007; Stefan Schweizer <genstef@gentoo.org> +licq-1.3.5.ebuild:
+ version bump, bug 197734
22 Aug 2007; Roy Marples <uberlord@gentoo.org> licq-1.3.4-r1.ebuild:
Keyworded ~x86-fbsd.
diff --git a/net-im/licq/files/digest-licq-1.3.5 b/net-im/licq/files/digest-licq-1.3.5
new file mode 100644
index 000000000000..38a0fc5ff180
--- /dev/null
+++ b/net-im/licq/files/digest-licq-1.3.5
@@ -0,0 +1,3 @@
+MD5 842a73c82980721961fe824f40377292 licq-1.3.5.tar.bz2 3260471
+RMD160 4442f6cb3630d8300e5f128617a522bd2cb863dc licq-1.3.5.tar.bz2 3260471
+SHA256 ca6692026e87459082b33ebb6480cc5c600001c93e1d9e2bbde65f3cf2238d3e licq-1.3.5.tar.bz2 3260471
diff --git a/net-im/licq/licq-1.3.5.ebuild b/net-im/licq/licq-1.3.5.ebuild
new file mode 100644
index 000000000000..c06200b3d337
--- /dev/null
+++ b/net-im/licq/licq-1.3.5.ebuild
@@ -0,0 +1,208 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.3.5.ebuild,v 1.1 2007/12/01 20:35:44 genstef Exp $
+
+inherit eutils kde-functions multilib
+
+DESCRIPTION="ICQ Client with v8 support"
+HOMEPAGE="http://www.licq.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl socks5 qt3 kde ncurses crypt msn debug"
+
+# we can't have conditional dependencies so "use kde && inherit kde"
+# won't work -- messes up dep caching.
+
+# need-kde and their eclass friends inject things into DEPEND. But we only
+# want them enabled if the kde USE flag is set. We get around this in the
+# following dep lines:
+RDEPEND="kde? ( >=kde-base/kdelibs-3.0 )"
+DEPEND="kde? ( >=kde-base/kdelibs-3.0 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ qt3? ( =x11-libs/qt-3* )
+ ncurses? ( sys-libs/ncurses >=dev-libs/cdk-4.9.11.20031210-r1 )
+ crypt? ( >=app-crypt/gpgme-1.0.0 )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ use ncurses && epatch ${FILESDIR}/1.3.0-suse_bool.patch
+
+ if use kde
+ then
+ # fix for #12436
+ ebegin "Setting kde plugin as default"
+ cp ${S}/src/licq.conf.h ${T}
+ sed "s:Plugin1 = qt-gui:Plugin1 = kde-gui:" \
+ ${T}/licq.conf.h > ${S}/src/licq.conf.h
+ eend $?
+ else
+ if ! use qt3
+ then
+ ebegin "Setting console plugin as default..."
+ cp ${S}/src/licq.conf.h ${T}
+ sed "s:Plugin1 = qt-gui:Plugin1 = console:" \
+ ${T}/licq.conf.h > ${S}/src/licq.conf.h
+ eend $?
+ fi
+ fi
+
+ # Install plugins in the correct libdir
+ sed -i -e "s:lib/licq/:$(get_libdir)/licq/:" \
+ ${S}/include/licq_constants.h || die "sed failed"
+ sed -i -e 's:$(prefix)/lib:@libdir@:' \
+ ${S}/plugins/*/src/Makefile.{in,am} || die "sed failed"
+}
+
+src_compile() {
+
+ use ssl || myconf="${myconf} --disable-openssl"
+ use socks5 && myconf="${myconf} --enable-socks5"
+ use debug && myconf="${myconf} --enable-debug"
+
+ if use crypt
+ then
+ myconf="${myconf} --enable-gpgme"
+ else
+ myconf="${myconf} --disable-gpgme"
+ fi
+
+ cd ${S}
+
+ # bug #21009
+ find . -name 'configure' -exec sed -e "s:sed 's/-g:sed 's/^-g:" -i {} \;
+
+ econf ${myconf} || die
+
+ use crypt && {
+ # workaround for gpgme's headers inclusion path
+ sed \
+ -e "s:FAULT_INCLUDES =:FAULT_INCLUDES = -I/usr/include/gpgme:" \
+ -i ${S}/src/Makefile
+ }
+
+ emake || die
+
+ # Create the various plug-ins
+
+ # First, the Qt plug-in
+ if use qt3
+ then
+ set-qtdir 3
+ set-kdedir 3
+
+ use kde && myconf="${myconf} --with-kde"
+
+ # Problems finding qt on multilib systems
+ myconf="${myconf} --with-qt-libraries=${QTDIR}/$(get_libdir)"
+
+ # note! watch the --prefix=/usr placement;
+ # licq itself installs into /usr, but the
+ # optional kde/qt interface (to which second_conf belogns)
+ # installs its files in $KDE3DIR/{lib,share}/licq
+
+ cd ${S}/plugins/qt-gui
+ einfo "Compiling Qt GUI plug-in"
+ econf ${myconf} || die
+ emake || die
+ fi
+
+ # Now the console plug-in
+ if use ncurses
+ then
+ cd ${S}/plugins/console
+ einfo "Compiling the Console plug-in"
+ econf || die
+ emake || die
+ fi
+
+ # The Auto-Responder plug-in
+ cd ${S}/plugins/auto-reply
+ einfo "Compiling the Auto-Reply plug-in"
+ econf || die
+ emake || die
+
+ # The Remote Management Service
+ cd ${S}/plugins/rms
+ einfo "Compiling Remote Management Services plug-in"
+ econf || die
+ emake || die
+
+ # MSN PLugin
+ if use msn
+ then
+ cd ${S}/plugins/msn
+ einfo "Compiling MSN plug-in"
+ econf || die
+ emake || die
+ fi
+
+ # Email PLugin
+ cd ${S}/plugins/email
+ einfo "Compiling Email plug-in"
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc ChangeLog INSTALL README* doc/*
+
+ # Install the plug-ins
+ if use qt3
+ then
+ cd ${S}/plugins/qt-gui
+ make DESTDIR=${D} install || die
+ docinto plugins/qt-gui
+ dodoc README*
+
+ fi
+
+ if use ncurses
+ then
+ cd ${S}/plugins/console
+ make DESTDIR=${D} install || die
+ docinto plugins/console
+ dodoc README
+ fi
+
+ if use msn
+ then
+ cd ${S}/plugins/msn
+ make DESTDIR=${D} install || die
+ docinto plugins/msn
+ dodoc README
+ fi
+
+ cd ${S}/plugins/auto-reply
+ make DESTDIR=${D} install || die
+ docinto plugins/auto-reply
+ dodoc README licq_autoreply.conf
+
+ cd ${S}/plugins/rms
+ make DESTDIR=${D} install || die
+ docinto plugins/rms
+ dodoc README licq_rms.conf
+
+ exeinto /usr/share/${PN}/upgrade
+ doexe ${S}/upgrade/*
+
+ # fixes bug #22136 and #149464
+ rm -fR ${D}/var
+}
+
+pkg_postinst() {
+ echo
+ ewarn
+ ewarn "If you're upgrading from <=licq-1.3.0 - you have to manually "
+ ewarn "upgrade your existing licq installation. Please backup your "
+ ewarn "settings and look into: /usr/share/licq/upgrade for scripts."
+ ewarn
+ echo
+}