summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-14 17:51:18 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-14 17:51:18 +0000
commit4f3ca7cb05c2d1b6c5e1d5a4bc4aa692c1076f98 (patch)
tree9469fcd114dc98dbc56d3c9693d6cfd2fe9f4ab9 /net-im/naim/naim-0.11.6.1.ebuild
parentVersion updated to 1.2.3 (diff)
downloadgentoo-2-4f3ca7cb05c2d1b6c5e1d5a4bc4aa692c1076f98.tar.gz
gentoo-2-4f3ca7cb05c2d1b6c5e1d5a4bc4aa692c1076f98.tar.bz2
gentoo-2-4f3ca7cb05c2d1b6c5e1d5a4bc4aa692c1076f98.zip
KEYWORD clean up
Diffstat (limited to 'net-im/naim/naim-0.11.6.1.ebuild')
-rw-r--r--net-im/naim/naim-0.11.6.1.ebuild31
1 files changed, 14 insertions, 17 deletions
diff --git a/net-im/naim/naim-0.11.6.1.ebuild b/net-im/naim/naim-0.11.6.1.ebuild
index 2ae84ae2ad84..6693e58ff5e2 100644
--- a/net-im/naim/naim-0.11.6.1.ebuild
+++ b/net-im/naim/naim-0.11.6.1.ebuild
@@ -1,37 +1,34 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/naim/naim-0.11.6.1.ebuild,v 1.1 2003/10/02 23:17:14 hillster Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/naim/naim-0.11.6.1.ebuild,v 1.2 2003/10/14 17:51:18 vapier Exp $
-IUSE="debug"
-DESCRIPTION="An ncurses based AOL Instant Messenger."
-SRC_URI="http://site.n.ml.org/download/20030923195458/naim/${P}.tar.bz2"
+DESCRIPTION="An ncurses based AOL Instant Messenger"
HOMEPAGE="http://site.n.ml.org/info/naim/"
+SRC_URI="http://site.n.ml.org/download/20030923195458/naim/${P}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa ~arm ~mips"
+SLOT="0"
+KEYWORDS="x86 ppc ~sparc ~mips ~alpha ~arm ~hppa ia64 ~amd64"
+IUSE="debug"
DEPEND=">=sys-libs/ncurses-5.2"
src_compile() {
- local myconf
- myconf="--with-gnu-ld --enable-detach"
+ local myconf=""
# --enable-profile
# --experimental-buddy-grouping
+ use debug && myconf="--enable-debug"
- # by default will install to /usr/share/doc/${P}
- myconf="${myconf} --with-pkgdocdir=/usr/share/doc/${PN}-${PVR}"
-
- use debug && myconf="${myconf} --enable-debug"
-
- econf ${myconf} || die "configure failed"
-
+ econf \
+ --with-pkgdocdir=/usr/share/doc/${PF} \
+ --enable-detach \
+ ${myconf} \
+ || die "configure failed"
emake || die "make failed"
}
src_install() {
make DESTDIR=${D} install || die "make install failed"
-
- dodoc AUTHORS COPYING FAQ BUGS README NEWS ChangeLog doc/*.hlp
+ dodoc AUTHORS FAQ BUGS README NEWS ChangeLog doc/*.hlp
}