summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-10-25 10:59:05 +0000
committerPeter Volkov <pva@gentoo.org>2010-10-25 10:59:05 +0000
commitbb93cf503f33e422491689819b6f50d4a108e2ff (patch)
treee43c8c6d561b8907d7a6a84567d14e2d90104cff /net-im/pidgin/files
parentFix parallell install. Bug #330705 (diff)
downloadgentoo-2-bb93cf503f33e422491689819b6f50d4a108e2ff.tar.gz
gentoo-2-bb93cf503f33e422491689819b6f50d4a108e2ff.tar.bz2
gentoo-2-bb93cf503f33e422491689819b6f50d4a108e2ff.zip
Version bump, bug #342017 by tman. Fixes remote crash, security bug #342059 by Tim Sammut. Respect LDFLAGS in perl bindings, bug #331851, thank Diego E. 'Flameeyes' Pettenò for report and Markos Chandras for initial patch. Should fix crash reported in bug #339938 by Wu, Shanliang. Force nls if gtk enabled to have desktop entry, bug #322717, thank Marcin Deranek for report. Remove .la files. Drop old.
(Portage version: 2.1.9.21/cvs/Linux x86_64)
Diffstat (limited to 'net-im/pidgin/files')
-rw-r--r--net-im/pidgin/files/pidgin-2.7.0-icq-fix.patch52
-rw-r--r--net-im/pidgin/files/pidgin-2.7.3-ldflags.patch24
2 files changed, 24 insertions, 52 deletions
diff --git a/net-im/pidgin/files/pidgin-2.7.0-icq-fix.patch b/net-im/pidgin/files/pidgin-2.7.0-icq-fix.patch
deleted file mode 100644
index b6cdc6f1dc3a..000000000000
--- a/net-im/pidgin/files/pidgin-2.7.0-icq-fix.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-#
-#
-# patch "libpurple/protocols/oscar/oscar.c"
-# from [ec79d8d9fcba376be091b363977e8f23c748eff2]
-# to [c8cc188e64cc6b466711a5b56454ce70615b0eea]
-#
-============================================================
---- libpurple/protocols/oscar/oscar.c ec79d8d9fcba376be091b363977e8f23c748eff2
-+++ libpurple/protocols/oscar/oscar.c c8cc188e64cc6b466711a5b56454ce70615b0eea
-@@ -2486,32 +2486,6 @@ static int incomingim_chan1(OscarData *o
- tmp = g_string_free(message, FALSE);
-
- /*
-- * If the message is from an ICQ user and to an ICQ user then escape any HTML,
-- * because HTML is not sent over ICQ as a means to format a message.
-- * So any HTML we receive is intended to be displayed. Also, \r\n must be
-- * replaced with <br>
-- *
-- * Note: There *may* be some clients which send messages as HTML formatted -
-- * they need to be special-cased somehow.
-- *
-- * Update: Newer ICQ clients have started sending IMs as HTML. We can
-- * distinguish HTML IMs from non-HTML IMs by looking at the features. If
-- * the features are "0x 01 06" then the message is plain text. If the
-- * features are "0x 01" then the message is HTML.
-- */
-- if (od->icq && oscar_util_valid_name_icq(userinfo->bn)
-- && (args->featureslen != 1 || args->features[0] != 0x01))
-- {
-- /* being recevied by ICQ from ICQ - escape HTML so it is displayed as sent */
-- gchar *tmp2 = g_markup_escape_text(tmp, -1);
-- g_free(tmp);
-- tmp = tmp2;
-- tmp2 = purple_strreplace(tmp, "\r\n", "<br>");
-- g_free(tmp);
-- tmp = tmp2;
-- }
--
-- /*
- * Convert iChat color tags to normal font tags.
- */
- if (purple_markup_find_tag("body", tmp, &start, &end, &attribs))
-@@ -4787,7 +4761,8 @@ oscar_send_im(PurpleConnection *gc, cons
- tmp2 = purple_markup_strip_html(tmp1);
- is_html = FALSE;
- } else {
-- tmp2 = g_strdup(tmp1);
-+ /* ICQ 6 wants its HTML wrapped in these tags. Oblige it. */
-+ tmp2 = g_strdup_printf("<HTML><BODY>%s</BODY></HTML>", tmp1);
- is_html = TRUE;
- }
- g_free(tmp1);
diff --git a/net-im/pidgin/files/pidgin-2.7.3-ldflags.patch b/net-im/pidgin/files/pidgin-2.7.3-ldflags.patch
new file mode 100644
index 000000000000..145858b187ba
--- /dev/null
+++ b/net-im/pidgin/files/pidgin-2.7.3-ldflags.patch
@@ -0,0 +1,24 @@
+http://developer.pidgin.im/ticket/12638
+
+--- libpurple/plugins/perl/common/Makefile.PL.in 2010-08-31 07:25:25 +0000
++++ libpurple/plugins/perl/common/Makefile.PL.in 2010-08-31 07:25:52 +0000
+@@ -10,6 +10,7 @@
+ (ABSTRACT_FROM => '@srcdir@/Purple.pm', # finds $ABSTRACT
+ AUTHOR => 'Purple <http://pidgin.im/>') : ()),
+ 'DEFINE' => '@DEBUG_CFLAGS@',
++ 'dynamic_lib' => { 'OTHERLDFLAGS' => '@LDFLAGS@' },
+ 'INC' => '-I. -I@srcdir@ -I@top_srcdir@ -I@top_srcdir@/libpurple @GLIB_CFLAGS@',
+ 'OBJECT' => '$(O_FILES)', # link all the C files too
+ # 'OPTIMIZE' => '-g', # For debugging
+
+--- pidgin/plugins/perl/common/Makefile.PL.in 2010-08-31 07:25:25 +0000
++++ pidgin/plugins/perl/common/Makefile.PL.in 2010-08-31 07:26:10 +0000
+@@ -9,6 +9,7 @@
+ ('ABSTRACT_FROM' => '@srcdir@/Pidgin.pm', # finds $ABSTRACT
+ 'AUTHOR' => 'Pidgin <http://pidgin.im/>') : ()),
+ 'DEFINE' => '@DEBUG_CFLAGS@',
++ 'dynamic_lib' => { 'OTHERLDFLAGS' => '@LDFLAGS@' },
+ 'INC' => '-I. -I@srcdir@ -I@top_srcdir@ -I@top_srcdir@/libpurple -I@top_srcdir@/pidgin @GTK_CFLAGS@',
+ 'OBJECT' => '$(O_FILES)', # link all the C files too
+ 'TYPEMAPS' => ["@top_srcdir@/libpurple/plugins/perl/common/typemap"],
+