summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhil Bordelon <sunflare@gentoo.org>2003-01-08 19:21:26 +0000
committerPhil Bordelon <sunflare@gentoo.org>2003-01-08 19:21:26 +0000
commit5e87671336111150fec67f9d12fac63200a136ae (patch)
tree2c57c08498c1b3e5b5085fb2e1e7240f3d183514 /net-im/silc-client/silc-client-0.9.11.ebuild
parentmark stable for x86 (diff)
downloadgentoo-2-5e87671336111150fec67f9d12fac63200a136ae.tar.gz
gentoo-2-5e87671336111150fec67f9d12fac63200a136ae.tar.bz2
gentoo-2-5e87671336111150fec67f9d12fac63200a136ae.zip
Finally, a version we can use. Fixed the still-extant man page problems.
Diffstat (limited to 'net-im/silc-client/silc-client-0.9.11.ebuild')
-rw-r--r--net-im/silc-client/silc-client-0.9.11.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-im/silc-client/silc-client-0.9.11.ebuild b/net-im/silc-client/silc-client-0.9.11.ebuild
new file mode 100644
index 000000000000..89542e2292a5
--- /dev/null
+++ b/net-im/silc-client/silc-client-0.9.11.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/silc-client-0.9.11.ebuild,v 1.1 2003/01/08 19:21:26 sunflare Exp $
+
+IUSE="socks5 ipv6 perl"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="silc-client is an IRSSI-based text client for Secure Internet Live Conferencing."
+SRC_URI="http://www.silcnet.org/download/client/sources/${P}.tar.bz2"
+HOMEPAGE="http://silcnet.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+
+DEPEND="=dev-libs/glib-1.2*
+ perl? ( sys-devel/perl )
+ sys-libs/ncurses"
+
+src_compile() {
+
+ myconf="--with-ncurses"
+
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ use socks5 && myconf="${myconf} --with-socks5"
+
+ econf \
+ --mandir=${D}/usr/share/man \
+ --with-helpdir=/usr/share/silc/help \
+ --with-docdir=/usr/share/doc/${P} \
+ --with-simdir=/usr/lib/silc/modules \
+ --with-logsdir=/var/log/silc \
+ ${myconf} || die "./configure failed"
+
+ make || die "make failed"
+}
+
+src_install () {
+ myflags=""
+ if [ "`use perl`" ]
+ then
+ R1="s/installsitearch='//"
+ R2="s/';//"
+ perl_sitearch="`perl -V:installsitearch | sed -e ${R1} -e ${R2}`"
+ myflags="${myflags} INSTALLPRIVLIB=${D}/usr"
+ myflags="${myflags} INSTALLARCHLIB=${D}/${perl_sitearch}"
+ myflags="${myflags} INSTALLSITELIB=${D}/${perl_sitearch}"
+ myflags="${myflags} INSTALLSITEARCH=${D}/${perl_sitearch}"
+ fi
+
+ make DESTDIR=${D} ${myflags} install || die "make install failed"
+ rmdir ${D}/usr/include
+}
+