summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-05-30 07:33:54 +0000
committerPeter Volkov <pva@gentoo.org>2008-05-30 07:33:54 +0000
commit5ac5f899633a488d9e0c9851d5c36de8a8d0d3be (patch)
treebe21a041d995ac6490005c273d2a966a8188d764 /net-im/sim
parentRemoving Andrej Kacian (Ticho) from metadata.xml (as per #59986). Assigning t... (diff)
downloadgentoo-2-5ac5f899633a488d9e0c9851d5c36de8a8d0d3be.tar.gz
gentoo-2-5ac5f899633a488d9e0c9851d5c36de8a8d0d3be.tar.bz2
gentoo-2-5ac5f899633a488d9e0c9851d5c36de8a8d0d3be.zip
Fix for ssl connection problems with newer openssl versions, bug #224095 thank Anton Bolshakov for report!
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-im/sim')
-rw-r--r--net-im/sim/ChangeLog10
-rw-r--r--net-im/sim/files/sim-0.9.4.3-sslv23.patch11
-rw-r--r--net-im/sim/sim-0.9.4.3-r1.ebuild4
-rw-r--r--net-im/sim/sim-0.9.4.3-r2.ebuild101
4 files changed, 123 insertions, 3 deletions
diff --git a/net-im/sim/ChangeLog b/net-im/sim/ChangeLog
index f52e8fb6be7d..8ab43cbc89e1 100644
--- a/net-im/sim/ChangeLog
+++ b/net-im/sim/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-im/sim
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/sim/ChangeLog,v 1.88 2008/05/11 13:24:42 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/sim/ChangeLog,v 1.89 2008/05/30 07:33:53 pva Exp $
+
+*sim-0.9.4.3-r2 (30 May 2008)
+
+ 30 May 2008; Peter Volkov <pva@gentoo.org>
+ +files/sim-0.9.4.3-sslv23.patch, sim-0.9.4.3-r1.ebuild,
+ +sim-0.9.4.3-r2.ebuild:
+ Fix for ssl connection problems with newer openssl versions, bug #224095
+ thank Anton Bolshakov for report!
11 May 2008; Peter Volkov <pva@gentoo.org> sim-9999.ebuild:
Fixed dependencies, e.g. flex should not be in RDEPEND, bug #221339 thank
diff --git a/net-im/sim/files/sim-0.9.4.3-sslv23.patch b/net-im/sim/files/sim-0.9.4.3-sslv23.patch
new file mode 100644
index 000000000000..d0207ce2fe7c
--- /dev/null
+++ b/net-im/sim/files/sim-0.9.4.3-sslv23.patch
@@ -0,0 +1,11 @@
+--- sim/sslclient.cpp.orig 2006-02-01 04:24:25.000000000 +0800
++++ sim/sslclient.cpp 2008-04-23 20:59:47.000000000 +0800
+@@ -406,7 +406,7 @@
+
+ bool SSLClient::initTLS1(bool bDH)
+ {
+- mpCTX = SSL_CTX_new(TLSv1_method());
++ mpCTX = SSL_CTX_new(SSLv23_client_method());
+ if (mpCTX == NULL)
+ return false;
+ if (bDH){
diff --git a/net-im/sim/sim-0.9.4.3-r1.ebuild b/net-im/sim/sim-0.9.4.3-r1.ebuild
index 4d69978e0c1a..a3f7b945acc4 100644
--- a/net-im/sim/sim-0.9.4.3-r1.ebuild
+++ b/net-im/sim/sim-0.9.4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/sim/sim-0.9.4.3-r1.ebuild,v 1.8 2008/05/04 11:51:10 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/sim/sim-0.9.4.3-r1.ebuild,v 1.9 2008/05/30 07:33:53 pva Exp $
inherit kde-functions eutils flag-o-matic
@@ -34,7 +34,7 @@ DEPEND="${RDEPEND}
pkg_nofetch() {
einfo "${CATEGORY}/${P} contains icons and sounds with unclear licensing and thus"
- einfo "you have to download and it put into ${DISTDIR} by yourself."
+ einfo "you have to download and it put into '${DISTDIR}' by yourself."
einfo "Download location:"
echo
einfo "${SRC_URI}"
diff --git a/net-im/sim/sim-0.9.4.3-r2.ebuild b/net-im/sim/sim-0.9.4.3-r2.ebuild
new file mode 100644
index 000000000000..78f9b6a4e921
--- /dev/null
+++ b/net-im/sim/sim-0.9.4.3-r2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/sim/sim-0.9.4.3-r2.ebuild,v 1.1 2008/05/30 07:33:53 pva Exp $
+
+inherit kde-functions eutils flag-o-matic
+
+DESCRIPTION="Simple Instant Messenger (with KDE support). ICQ/AIM/Jabber/MSN/Yahoo."
+HOMEPAGE="http://sim-im.org/"
+SRC_URI="mirror://berlios/sim-im/${P}.tar.bz2
+ http://dev.gentoo.org/~pva/${P}-r1919_1924.patch.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug kde spell ssl"
+
+RESTRICT="fetch"
+
+# kdebase-data provides the icon "licq.png"
+RDEPEND="kde? ( =kde-base/kdelibs-3.5*
+ || ( =kde-base/kdebase-data-3.5* =kde-base/kdebase-3.5* ) )
+ !kde? ( $(qt_min_version 3)
+ spell? ( app-text/aspell ) )
+ ssl? ( dev-libs/openssl )
+ dev-libs/libxml2
+ dev-libs/libxslt
+ sys-libs/zlib
+ x11-libs/libXScrnSaver"
+
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ app-arch/zip
+ x11-proto/scrnsaverproto"
+
+pkg_nofetch() {
+ einfo "${CATEGORY}/${P} contains icons and sounds with unclear licensing and thus"
+ einfo "you have to download and it put into '${DISTDIR}' by yourself."
+ einfo "Download location:"
+ echo
+ einfo "${SRC_URI}"
+ echo
+ einfo "See http://archives.gentoo.org/gentoo-dev/msg_144003.xml for further"
+ einfo "information."
+}
+
+pkg_setup() {
+ if use kde; then
+ if use spell; then
+ if ! built_with_use "=kde-base/kdelibs-3.5*" spell; then
+ ewarn "kde-base/kdelibs were merged without spell in USE."
+ ewarn "Thus spelling will not work in sim. Please, either"
+ ewarn "reemerge kde-base/kdelibs with spell in USE or emerge"
+ ewarn 'sim with USE="-spell" to avoid this message.'
+ ebeep
+ fi
+ else
+ if built_with_use "=kde-base/kdelibs-3.5*" spell; then
+ ewarn 'kde-base/kdelibs were merged with spell in USE.'
+ ewarn 'Thus spelling will work in sim. Please, either'
+ ewarn 'reemerge kde-base/kdelibs without spell in USE or emerge'
+ ewarn 'sim with USE="spell" to avoid this message.'
+ ebeep
+ fi
+ fi
+ if ! built_with_use "=kde-base/kdelibs-3.5*" arts; then
+ myconf="--without-arts"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-double-message-fix.patch
+ epatch "${FILESDIR}"/${P}-sslv23.patch
+ epatch ../${P}-r1919_1924.patch
+ if use kde; then
+ set-kdedir 3
+ fi
+}
+
+src_compile() {
+ filter-flags -fstack-protector -fstack-protector-all
+
+ # Workaround for bug #119906
+ append-flags -fno-stack-protector
+
+ use kde || use spell || export DO_NOT_COMPILE="$DO_NOT_COMPILE plugins/spell"
+
+ econf ${myconf} $(use_enable kde) \
+ $(use_with ssl) \
+ $(use_enable debug) || die "econf failed"
+
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed."
+ dodoc TODO README AUTHORS.sim jisp-resources.txt ChangeLog
+}