summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2004-12-27 18:41:13 +0000
committerGustavo Felisberto <humpback@gentoo.org>2004-12-27 18:41:13 +0000
commit788b1a1028072fc8a05871dd8baf713f7cc2dbae (patch)
tree3855c3662b35031cd7c55c2de83f383d7c4d234a /net-im/skype
parentHOMEPAGE and SRC_URI fix thanks to: Adam Chodorowski <adam@chodorowski.com> i... (diff)
downloadgentoo-2-788b1a1028072fc8a05871dd8baf713f7cc2dbae.tar.gz
gentoo-2-788b1a1028072fc8a05871dd8baf713f7cc2dbae.tar.bz2
gentoo-2-788b1a1028072fc8a05871dd8baf713f7cc2dbae.zip
*** empty log message ***
Diffstat (limited to 'net-im/skype')
-rw-r--r--net-im/skype/skype-0.91.0.12.ebuild93
-rw-r--r--net-im/skype/skype-0.91.0.3.ebuild88
-rw-r--r--net-im/skype/skype-0.92.0.12.ebuild88
-rw-r--r--net-im/skype/skype-0.92.0.2.ebuild94
4 files changed, 0 insertions, 363 deletions
diff --git a/net-im/skype/skype-0.91.0.12.ebuild b/net-im/skype/skype-0.91.0.12.ebuild
deleted file mode 100644
index 7013e3d4c81a..000000000000
--- a/net-im/skype/skype-0.91.0.12.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/skype/skype-0.91.0.12.ebuild,v 1.4 2004/09/19 20:47:56 humpback Exp $
-
-inherit eutils
-
-
-#If you want to know when this package will be marked stable please see the Changelog
-SVER=${PV//./_}
-RESTRICT="nomirror"
-DESCRIPTION="${PN} is a P2P-VoiceIP client."
-HOMEPAGE="http://www.${PN}.com/"
-SRC_URI="
- qt? ( http://download.skype.com/linux/${PN}_ver-${SVER}.tar.bz2 )
- !qt? ( http://download.skype.com/linux/${PN}_ver-${SVER}-staticQT.tar.bz2 )"
-LICENSE="skype-eula"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="qt arts esd"
-DEPEND="amd64? ( app-emulation/emul-linux-x86-glibc
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-compat
- app-emulation/emul-linux-x86-baselibs
- qt? ( app-emulation/emul-linux-x86-qtlibs )
- )
- x86? ( qt? ( >=x11-libs/qt-3.2 )
- >=sys-libs/glibc-2.2.5
- )"
-
-S="${WORKDIR}/${PN}_ver-${SVER}"
-
-src_unpack() {
- if use !qt;
- then
- unpack ${PN}_ver-${SVER}-staticQT.tar.bz2
- cd ${WORKDIR}
- mv ${S}-staticQT ${S}
- cd ${S}
- else
- unpack ${PN}_ver-${SVER}.tar.bz2
- cd ${S}
- fi
-}
-
-src_install() {
- ## Install the wrapper script
- if ( use arts || use esd );
- then
- mv skype skype.bin
- cp ${FILESDIR}/sDaemonWrapper skype
- fi
-
- dodir /opt/skype
- exeopts -m0755
- exeinto /opt/skype
- doexe skype
- ( use arts || use esd ) && doexe skype.bin
- #It seems skype wants the wave in /usr/share/skype
- #http://forum.skype.com/bb/viewtopic.php?t=4145
- insinto /usr/share/skype
- doins call_in.wav
- insinto /usr/share/skype/lang
- doins *.qm
- insinto /opt/skype
- make_desktop_entry skype "Skype VoIP" ../icons/hicolor/48x48/apps/skype.png
- for SIZE in 16 24 32 48
- do
- mkdir ${S}/icons/${SIZE}
- cp ${S}/icons/${PN}_${SIZE}_32.png ${S}/icons/${SIZE}/${PN}.png
- dodir /usr/share/icons/hicolor/${SIZE}x${SIZE}/apps
- insinto /usr/share/icons/hicolor/${SIZE}x${SIZE}/apps
- doins ${S}/icons/${SIZE}/${PN}.png
- done
- ( use arts || use esd ) && fowners root:audio /opt/skype/skype.bin
- fowners root:audio /opt/skype/skype
- dodir /usr/bin/
- dosym /opt/skype/skype /usr/bin/skype
-}
-
-pkg_postinst() {
- einfo "Have a look at ${PORTDIR}/licenses/${LICENSE} before running this software"
- einfo "If you have sound problems please visit: "
- einfo "http://forum.skype.com/bb/viewtopic.php?t=4489"
- if ( use arts );
- then
- ewarn "Dont forget to configure your arts to work in Full-Duplex mode"
- ewarn "Open controlcenter, go to \"Sound & Multimedia\"->\"Sound System\""
- ewarn "On the \"Hardware\" tab, check the box next to \"Full duplex\"."
- fi
- ewarn "There are some problems with this version of skype when upgrading"
- ewarn "If you have problems please go to:"
- ewarn "http://forum.skype.com/bb/viewtopic.php?t=7187"
-}
diff --git a/net-im/skype/skype-0.91.0.3.ebuild b/net-im/skype/skype-0.91.0.3.ebuild
deleted file mode 100644
index 22765a93169e..000000000000
--- a/net-im/skype/skype-0.91.0.3.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/skype/skype-0.91.0.3.ebuild,v 1.4 2004/09/05 23:00:16 mr_bones_ Exp $
-
-inherit eutils
-
-SVER=${PV//./_}
-RESTRICT="nomirror"
-DESCRIPTION="${PN} is a P2P-VoiceIP client."
-HOMEPAGE="http://www.${PN}.com/"
-SRC_URI="
- qt? ( http://download.skype.com/linux/${PN}_ver-${SVER}.tar.bz2 )
- !qt? ( http://download.skype.com/linux/${PN}_ver-${SVER}-staticQT.tar.bz2 )"
-LICENSE="skype-eula"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="qt arts esd"
-DEPEND="amd64? ( app-emulation/emul-linux-x86-glibc
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-compat
- app-emulation/emul-linux-x86-baselibs
- qt? ( app-emulation/emul-linux-x86-qtlibs )
- )
- x86? ( qt? ( >=x11-libs/qt-3.2 )
- >=sys-libs/glibc-2.2.5
- )"
-
-S="${WORKDIR}/${PN}_ver_${SVER}"
-
-src_unpack() {
- if use !qt;
- then
- unpack ${PN}_ver-${SVER}-staticQT.tar.bz2
- cd ${WORKDIR}
- mv ${PN}_ver_${SVER}-staticQT ${PN}_ver_${SVER}
- cd ${S}
- else
- unpack ${PN}_ver-${SVER}.tar.bz2
- cd ${S}
- fi
-}
-
-src_install() {
- ## Install the wrapper script
- if ( use arts || use esd );
- then
- mv skype skype.bin
- cp ${FILESDIR}/sDaemonWrapper skype
- fi
-
- dodir /opt/skype
- exeopts -m0755
- exeinto /opt/skype
- doexe skype
- ( use arts || use esd ) && doexe skype.bin
- #It seems skype wants the wave in /usr/share/skype
- #http://forum.skype.com/bb/viewtopic.php?t=4145
- insinto /usr/share/skype
- doins call_in.wav
- insinto /usr/share/skype/lang
- doins *.qm
- insinto /opt/skype
- make_desktop_entry skype "Skype VoIP" ../icons/hicolor/48x48/apps/skype.png
- for SIZE in 16 24 32 48
- do
- mkdir ${S}/icons/${SIZE}
- cp ${S}/icons/${PN}_${SIZE}_32.png ${S}/icons/${SIZE}/${PN}.png
- dodir /usr/share/icons/hicolor/${SIZE}x${SIZE}/apps
- insinto /usr/share/icons/hicolor/${SIZE}x${SIZE}/apps
- doins ${S}/icons/${SIZE}/${PN}.png
- done
- ( use arts || use esd ) && fowners root:audio /opt/skype/skype.bin
- fowners root:audio /opt/skype/skype
- dodir /usr/bin/
- dosym /opt/skype/skype /usr/bin/skype
-}
-
-pkg_postinst() {
- einfo "Have a look at ${PORTDIR}/licenses/${LICENSE} before running this software"
- einfo "If you have sound problems please visit: "
- einfo "http://forum.skype.com/bb/viewtopic.php?t=4489"
- if ( use arts );
- then
- ewarn "Dont forget to configure your arts to work in Full-Duplex mode"
- ewarn "Open controlcenter, go to \"Sound & Multimedia\"->\"Sound System\""
- ewarn "On the \"Hardware\" tab, check the box next to \"Full duplex\"."
- fi
-}
diff --git a/net-im/skype/skype-0.92.0.12.ebuild b/net-im/skype/skype-0.92.0.12.ebuild
deleted file mode 100644
index 05ccde67b8ad..000000000000
--- a/net-im/skype/skype-0.92.0.12.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/skype/skype-0.92.0.12.ebuild,v 1.1 2004/11/19 17:02:45 humpback Exp $
-
-inherit eutils
-
-
-#If you want to know when this package will be marked stable please see the Changelog
-RESTRICT="nomirror"
-DESCRIPTION="${PN} is a P2P-VoiceIP client."
-HOMEPAGE="http://www.${PN}.com/"
-SRC_URI="
- qt? ( http://download.skype.com/linux/${P}.tar.bz2 )
- !qt? ( http://download.skype.com/linux/${PN}_staticQT-${PV}.tar.bz2 )"
-LICENSE="skype-eula"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="qt arts esd"
-DEPEND="amd64? ( app-emulation/emul-linux-x86-glibc
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-compat
- app-emulation/emul-linux-x86-baselibs
- qt? ( app-emulation/emul-linux-x86-qtlibs )
- )
- x86? ( qt? ( >=x11-libs/qt-3.2 )
- >=sys-libs/glibc-2.2.5
- )"
-
-src_unpack() {
- if use !qt;
- then
- unpack ${PN}_staticQT-${PV}.tar.bz2
- mv ${PN}_staticQT-${PV} ${S}
- else
- unpack ${P}.tar.bz2
- fi
-}
-
-src_install() {
- ## Install the wrapper script
- if ( use arts || use esd );
- then
- mv skype skype.bin
- cp ${FILESDIR}/sDaemonWrapper skype
- fi
-
- dodir /opt/skype
- exeopts -m0755
- exeinto /opt/skype
- doexe skype
- ( use arts || use esd ) && doexe skype.bin
- #It seems skype wants the wave in /usr/share/skype
- #http://forum.skype.com/bb/viewtopic.php?t=4145
- insinto /usr/share/skype
- doins call_in.wav
- insinto /usr/share/skype/lang
- doins *.qm
- insinto /opt/skype
- make_desktop_entry skype "Skype VoIP" ../icons/hicolor/48x48/apps/skype.png
- for SIZE in 16 32 48
- do
- mkdir ${S}/icons/${SIZE}
- cp ${S}/icons/${PN}_${SIZE}_32.png ${S}/icons/${SIZE}/${PN}.png
- dodir /usr/share/icons/hicolor/${SIZE}x${SIZE}/apps
- insinto /usr/share/icons/hicolor/${SIZE}x${SIZE}/apps
- doins ${S}/icons/${SIZE}/${PN}.png
- done
- ( use arts || use esd ) && fowners root:audio /opt/skype/skype.bin
- fowners root:audio /opt/skype/skype
- dodir /usr/bin/
- dosym /opt/skype/skype /usr/bin/skype
-}
-
-pkg_postinst() {
- einfo "Have a look at ${PORTDIR}/licenses/${LICENSE} before running this software"
- einfo "If you have sound problems please visit: "
- einfo "http://forum.skype.com/bb/viewtopic.php?t=4489"
- if ( use arts );
- then
- ewarn "Dont forget to configure your arts to work in Full-Duplex mode"
- ewarn "Open controlcenter, go to \"Sound & Multimedia\"->\"Sound System\""
- ewarn "On the \"Hardware\" tab, check the box next to \"Full duplex\"."
- fi
- ##I do not know if this is true for this version. But will leave the note here
- ewarn "There are some problems with this version of skype when upgrading"
- ewarn "If you have problems please go to:"
- ewarn "http://forum.skype.com/bb/viewtopic.php?t=7187"
-}
diff --git a/net-im/skype/skype-0.92.0.2.ebuild b/net-im/skype/skype-0.92.0.2.ebuild
deleted file mode 100644
index 6527e95a0fa4..000000000000
--- a/net-im/skype/skype-0.92.0.2.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/skype/skype-0.92.0.2.ebuild,v 1.1 2004/09/22 12:06:35 humpback Exp $
-
-inherit eutils
-
-
-#If you want to know when this package will be marked stable please see the Changelog
-SVER=${PV//./_}
-RESTRICT="nomirror"
-DESCRIPTION="${PN} is a P2P-VoiceIP client."
-HOMEPAGE="http://www.${PN}.com/"
-SRC_URI="
- qt? ( http://download.skype.com/linux/${PN}_ver-${SVER}.tar.bz2 )
- !qt? ( http://download.skype.com/linux/${PN}_ver-${SVER}-staticQT.tar.bz2 )"
-LICENSE="skype-eula"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="qt arts esd"
-DEPEND="amd64? ( app-emulation/emul-linux-x86-glibc
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-compat
- app-emulation/emul-linux-x86-baselibs
- qt? ( app-emulation/emul-linux-x86-qtlibs )
- )
- x86? ( qt? ( >=x11-libs/qt-3.2 )
- >=sys-libs/glibc-2.2.5
- )"
-
-S="${WORKDIR}/${PN}_ver-${SVER}"
-
-src_unpack() {
- if use !qt;
- then
- unpack ${PN}_ver-${SVER}-staticQT.tar.bz2
- cd ${WORKDIR}
- mv ${S}-staticQT ${S}
- cd ${S}
- else
- unpack ${PN}_ver-${SVER}.tar.bz2
- cd ${S}
- fi
-}
-
-src_install() {
- ## Install the wrapper script
- if ( use arts || use esd );
- then
- mv skype skype.bin
- cp ${FILESDIR}/sDaemonWrapper skype
- fi
-
- dodir /opt/skype
- exeopts -m0755
- exeinto /opt/skype
- doexe skype
- ( use arts || use esd ) && doexe skype.bin
- #It seems skype wants the wave in /usr/share/skype
- #http://forum.skype.com/bb/viewtopic.php?t=4145
- insinto /usr/share/skype
- doins call_in.wav
- insinto /usr/share/skype/lang
- doins *.qm
- insinto /opt/skype
- make_desktop_entry skype "Skype VoIP" ../icons/hicolor/48x48/apps/skype.png
- for SIZE in 16 32 48
- do
- mkdir ${S}/icons/${SIZE}
- cp ${S}/icons/${PN}_${SIZE}_32.png ${S}/icons/${SIZE}/${PN}.png
- dodir /usr/share/icons/hicolor/${SIZE}x${SIZE}/apps
- insinto /usr/share/icons/hicolor/${SIZE}x${SIZE}/apps
- doins ${S}/icons/${SIZE}/${PN}.png
- done
- ( use arts || use esd ) && fowners root:audio /opt/skype/skype.bin
- fowners root:audio /opt/skype/skype
- dodir /usr/bin/
- dosym /opt/skype/skype /usr/bin/skype
-}
-
-pkg_postinst() {
- einfo "Have a look at ${PORTDIR}/licenses/${LICENSE} before running this software"
- einfo "If you have sound problems please visit: "
- einfo "http://forum.skype.com/bb/viewtopic.php?t=4489"
- if ( use arts );
- then
- ewarn "Dont forget to configure your arts to work in Full-Duplex mode"
- ewarn "Open controlcenter, go to \"Sound & Multimedia\"->\"Sound System\""
- ewarn "On the \"Hardware\" tab, check the box next to \"Full duplex\"."
- fi
- ##I do not know if this is true for this version. But will leave the note here
- ewarn "There are some problems with this version of skype when upgrading"
- ewarn "If you have problems please go to:"
- ewarn "http://forum.skype.com/bb/viewtopic.php?t=7187"
-}