summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-13 14:05:42 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-13 14:05:42 +0000
commit168d479c2ba294f9ca326da47ff5737893f83806 (patch)
tree802733252a7bb501e92a1af8113508e479a43d26 /net-im
parentCherrypick upstream patch to fix gcc-4.6 build failure wrt #363463 by Diego E... (diff)
downloadgentoo-2-168d479c2ba294f9ca326da47ff5737893f83806.tar.gz
gentoo-2-168d479c2ba294f9ca326da47ff5737893f83806.tar.bz2
gentoo-2-168d479c2ba294f9ca326da47ff5737893f83806.zip
Removed uneeded dep on sexy-python, backport clickable link in status message patch, #363289
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gajim/ChangeLog9
-rw-r--r--net-im/gajim/files/0.14.1-link.patch16
-rw-r--r--net-im/gajim/gajim-0.14.1-r2.ebuild3
-rw-r--r--net-im/gajim/gajim-0.14.1-r3.ebuild105
4 files changed, 130 insertions, 3 deletions
diff --git a/net-im/gajim/ChangeLog b/net-im/gajim/ChangeLog
index e6bfacfed42c..cbdb91a61d61 100644
--- a/net-im/gajim/ChangeLog
+++ b/net-im/gajim/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/gajim
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.115 2011/03/29 12:43:44 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.116 2011/04/13 14:05:41 jlec Exp $
+
+*gajim-0.14.1-r3 (13 Apr 2011)
+
+ 13 Apr 2011; Justin Lecher <jlec@gentoo.org> +files/0.14.1-link.patch,
+ gajim-0.14.1-r2.ebuild, +gajim-0.14.1-r3.ebuild:
+ Removed uneeded dep on sexy-python, backport clickable link in status message
+ patch, #363289
29 Mar 2011; Jeroen Roovers <jer@gentoo.org> gajim-0.14.1-r2.ebuild:
Stable for HPPA (bug #357765).
diff --git a/net-im/gajim/files/0.14.1-link.patch b/net-im/gajim/files/0.14.1-link.patch
new file mode 100644
index 000000000000..9f4bb6ee5936
--- /dev/null
+++ b/net-im/gajim/files/0.14.1-link.patch
@@ -0,0 +1,16 @@
+ src/chat_control.py | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/chat_control.py b/src/chat_control.py
+index e59a871..c34f86a 100644
+--- a/src/chat_control.py
++++ b/src/chat_control.py
+@@ -1912,7 +1912,7 @@ class ChatControl(ChatControlBase):
+
+ if status_escaped:
+ status_text = self.urlfinder.sub(self.make_href, status_escaped)
+- status_text = '<span %s>%s</span>' % (font_attrs_small, status_escaped)
++ status_text = '<span %s>%s</span>' % (font_attrs_small, status_text)
+ self.banner_status_label.set_tooltip_text(status)
+ self.banner_status_label.set_no_show_all(False)
+ self.banner_status_label.show()
diff --git a/net-im/gajim/gajim-0.14.1-r2.ebuild b/net-im/gajim/gajim-0.14.1-r2.ebuild
index d5c4a777cc47..192c938f234b 100644
--- a/net-im/gajim/gajim-0.14.1-r2.ebuild
+++ b/net-im/gajim/gajim-0.14.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.14.1-r2.ebuild,v 1.8 2011/03/29 12:43:44 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.14.1-r2.ebuild,v 1.9 2011/04/13 14:05:41 jlec Exp $
EAPI="2"
@@ -27,7 +27,6 @@ DEPEND="${COMMON_DEPEND}
dev-util/pkgconfig"
RDEPEND="${COMMON_DEPEND}
dev-python/pyopenssl
- dev-python/sexy-python
crypt? (
app-crypt/gnupg
dev-python/pycrypto
diff --git a/net-im/gajim/gajim-0.14.1-r3.ebuild b/net-im/gajim/gajim-0.14.1-r3.ebuild
new file mode 100644
index 000000000000..554cad91a243
--- /dev/null
+++ b/net-im/gajim/gajim-0.14.1-r3.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.14.1-r3.ebuild,v 1.1 2011/04/13 14:05:41 jlec Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="sqlite xml"
+
+inherit eutils python versionator
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="http://www.gajim.org/"
+SRC_URI="http://www.gajim.org/downloads/$(get_version_component_range 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi crypt dbus gmail gnome idle jingle libnotify networkmanager nls spell srv X xhtml"
+
+COMMON_DEPEND="
+ x11-libs/gtk+:2
+ dev-python/pygtk:2"
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.17-r1
+ >=dev-util/intltool-0.40.1
+ dev-util/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ dev-python/pyopenssl
+ crypt? (
+ app-crypt/gnupg
+ dev-python/pycrypto
+ )
+ dbus? (
+ dev-python/dbus-python
+ dev-libs/dbus-glib
+ libnotify? ( dev-python/notify-python )
+ avahi? ( net-dns/avahi[dbus,gtk,python] )
+ )
+ gmail? ( net-dns/bind-tools )
+ gnome? (
+ dev-python/libgnome-python
+ dev-python/gnome-keyring-python
+ dev-python/egg-python
+ )
+ idle? ( x11-libs/libXScrnSaver )
+ jingle? ( net-libs/farsight2[python] )
+ networkmanager? (
+ dev-python/dbus-python
+ || ( >=net-misc/networkmanager-0.7.1 net-misc/networkmanager[gnome] )
+ )
+ srv? (
+ || (
+ dev-python/libasyncns-python
+ net-dns/bind-tools )
+ )
+ spell? ( app-text/gtkspell )
+ xhtml? ( dev-python/docutils )"
+
+pkg_setup() {
+ if ! use dbus; then
+ if use libnotify; then
+ eerror "The dbus USE flag is required for libnotify support"
+ die "USE=\"dbus\" needed for libnotify support"
+ fi
+ if use avahi; then
+ eerror "The dbus USE flag is required for avahi support"
+ die "USE=\"dbus\" needed for avahi support"
+ fi
+ fi
+ python_pkg_setup
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/0.14-python-version.patch \
+ "${FILESDIR}"/0.14.1-testing.patch \
+ "${FILESDIR}"/0.14.1-link.patch
+ echo '#!/bin/sh' > config/py-compile
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with X x) \
+ --docdir="/usr/share/doc/${PF}" \
+ --libdir="$(python_get_sitedir)" \
+ --enable-site-packages
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ rm "${D}/usr/share/doc/${PF}/"{README.html,COPYING} || die
+ dohtml README.html || die
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup $(python_get_sitedir)/${PN}
+}