summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-12-26 14:50:31 +0000
committerPeter Volkov <pva@gentoo.org>2009-12-26 14:50:31 +0000
commit2d4e6ed35b15181f59273874c83bddd08fcc3370 (patch)
treef934fd839d651f4ba6c0310ea39bd6aa266e61ed /net-im
parentVersion bump wrt #298435, thanks to Peter Volkov for reporting. (diff)
downloadgentoo-2-2d4e6ed35b15181f59273874c83bddd08fcc3370.tar.gz
gentoo-2-2d4e6ed35b15181f59273874c83bddd08fcc3370.tar.bz2
gentoo-2-2d4e6ed35b15181f59273874c83bddd08fcc3370.zip
Version bump, bug 270336, thank Andreas Weber for report. Fixes build issue with recent gnutls, bug #297323, thank Markus Meier for report.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/climm/ChangeLog9
-rw-r--r--net-im/climm/climm-0.7.ebuild72
-rw-r--r--net-im/climm/files/climm-0.7-gnutls.patch13
3 files changed, 93 insertions, 1 deletions
diff --git a/net-im/climm/ChangeLog b/net-im/climm/ChangeLog
index 1a12689cf23e..f389ebff15d1 100644
--- a/net-im/climm/ChangeLog
+++ b/net-im/climm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/climm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/climm/ChangeLog,v 1.12 2009/02/23 19:36:59 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/climm/ChangeLog,v 1.13 2009/12/26 14:50:31 pva Exp $
+
+*climm-0.7 (26 Dec 2009)
+
+ 26 Dec 2009; Peter Volkov <pva@gentoo.org> +climm-0.7.ebuild,
+ +files/climm-0.7-gnutls.patch:
+ Version bump, bug 270336, thank Andreas Weber for report. Fixes build
+ issue with recent gnutls, bug #297323, thank Markus Meier for report.
*climm-0.6.4 (23 Feb 2009)
diff --git a/net-im/climm/climm-0.7.ebuild b/net-im/climm/climm-0.7.ebuild
new file mode 100644
index 000000000000..84a4595cb5df
--- /dev/null
+++ b/net-im/climm/climm-0.7.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/climm/climm-0.7.ebuild,v 1.1 2009/12/26 14:50:31 pva Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="ICQ text-mode client with many features"
+HOMEPAGE="http://www.climm.org/"
+SRC_URI="http://www.climm.org/source/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="jabber gnutls otr tcl ssl"
+
+# In case user don't need jabber there is a choice gnutls/openssl. Since jabber
+# requires gnutls then without explicit request to use gnutls (USE=gnutls)
+# for ssl we fall back on gnutls instead of openssl.
+RDEPEND="jabber? ( || ( >=dev-libs/iksemel-1.4[ssl] >=dev-libs/iksemel-1.3[gnutls] ) )
+ ssl? ( gnutls? ( >=net-libs/gnutls-0.8.10
+ dev-libs/libgcrypt )
+ !gnutls? ( !jabber? ( dev-libs/openssl )
+ jabber? ( >=net-libs/gnutls-0.8.10 ) ) )
+ tcl? ( dev-lang/tcl )
+ otr? ( >=net-libs/libotr-3.0.0 )"
+DEPEND="${RDEPEND}
+ ssl? ( gnutls? ( dev-util/pkgconfig )
+ !gnutls? ( jabber? ( dev-util/pkgconfig ) ) )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gnutls.patch"
+ eautoconf
+}
+
+src_configure() {
+ local myconf
+ if use ssl; then
+ myconf="--enable-ssl"
+ if use gnutls; then
+ einfo "Using gnutls"
+ myconf="--enable-ssl=gnutls"
+ else
+ if use jabber; then
+ einfo "Using gnutls (required for jabber/XMPP)"
+ myconf="--enable-ssl=gnutls"
+ else
+ einfo "Using openSSL"
+ myconf="--enable-ssl=openssl"
+ fi
+ fi
+ else
+ if use jabber; then
+ einfo "Using gnutls (required for jabber/XMPP)"
+ myconf="--enable-ssl=gnutls"
+ else
+ myconf="--disable-ssl"
+ fi
+ fi
+
+ econf \
+ $(use_enable jabber xmpp) \
+ $(use_enable otr) \
+ $(use_enable tcl) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog FAQ INSTALL NEWS README TODO
+}
diff --git a/net-im/climm/files/climm-0.7-gnutls.patch b/net-im/climm/files/climm-0.7-gnutls.patch
new file mode 100644
index 000000000000..469a75636404
--- /dev/null
+++ b/net-im/climm/files/climm-0.7-gnutls.patch
@@ -0,0 +1,13 @@
+=== modified file 'configure.ac'
+--- configure.ac 2009-12-26 14:00:17 +0000
++++ configure.ac 2009-12-26 14:02:41 +0000
+@@ -97,7 +97,7 @@
+ if test "x$ac_arg_use_ssl" != "xno"; then
+ ac_use_ssl=no
+ if test "x$ac_arg_use_ssl" != "xopenssl"; then
+- AM_PATH_LIBGNUTLS(0.8.8, ac_use_ssl=gnutls)
++ PKG_CHECK_MODULES(LIBGNUTLS, gnutls, ac_use_ssl=gnutls)
+ AM_PATH_LIBGCRYPT(, , ac_use_ssl=no)
+ AC_CHECK_HEADERS([gcrypt.h], , ac_use_ssl=no)
+ if test "x$ac_use_ssl" = "xgnutls"; then
+