summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-01 23:08:38 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-01 23:08:38 +0000
commit43e4c04d730e5b192f6b70b81581ba1e7e33c78c (patch)
treed9cbb041ae54f94c6ef006e475aca4fdc031b9d0 /net-im
parentbugfix release (diff)
downloadgentoo-2-43e4c04d730e5b192f6b70b81581ba1e7e33c78c.tar.gz
gentoo-2-43e4c04d730e5b192f6b70b81581ba1e7e33c78c.tar.bz2
gentoo-2-43e4c04d730e5b192f6b70b81581ba1e7e33c78c.zip
New version ... old ones didnt work
Diffstat (limited to 'net-im')
-rw-r--r--net-im/naim/ChangeLog8
-rw-r--r--net-im/naim/files/digest-naim-0.11.4_p11
-rw-r--r--net-im/naim/naim-0.11.4_p1.ebuild51
3 files changed, 59 insertions, 1 deletions
diff --git a/net-im/naim/ChangeLog b/net-im/naim/ChangeLog
index ad7dcab0c227..44025080b052 100644
--- a/net-im/naim/ChangeLog
+++ b/net-im/naim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/naim
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/naim/ChangeLog,v 1.1 2002/07/17 09:08:09 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/naim/ChangeLog,v 1.2 2002/10/01 23:08:38 vapier Exp $
+
+*naim-0.11.4p1 (01 Oct 2002)
+
+ 01 Oct 2002; Mike Frysinger <vapier@gentoo.org> naim-0.11.4_p1.ebuild :
+ Updated version since older versions were unable to connect to aol servers
+ Also redid the compile/install process since the old one was weak :x
*naim-0.11.2 (08 Feb 2002)
diff --git a/net-im/naim/files/digest-naim-0.11.4_p1 b/net-im/naim/files/digest-naim-0.11.4_p1
new file mode 100644
index 000000000000..ef740fa62fad
--- /dev/null
+++ b/net-im/naim/files/digest-naim-0.11.4_p1
@@ -0,0 +1 @@
+MD5 5253a39fe594440478dc4f3fb8538ca4 naim-0.11.4p1.tar.gz 348341
diff --git a/net-im/naim/naim-0.11.4_p1.ebuild b/net-im/naim/naim-0.11.4_p1.ebuild
new file mode 100644
index 000000000000..0c8ec22ff982
--- /dev/null
+++ b/net-im/naim/naim-0.11.4_p1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/naim/naim-0.11.4_p1.ebuild,v 1.1 2002/10/01 23:08:38 vapier Exp $
+
+MY_P="${P/_p1/}"
+SRC_URI="http://www.acm.cs.rpi.edu/%7En/${P/_/}.tar.gz"
+DESCRIPTION="An ncurses AOL Instant Messenger."
+HOMEPAGE="http://site.rpi-acm.org/info/naim/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ virtual/glibc"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ local myconf
+ myconf="--with-gnu-ld --enable-detach"
+ use pic && myconf="${myconf} --with-pic"
+ use static && myconf="${myconf} --enable-static=yes"
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin src/naim
+
+ doman naim.1
+
+ dodoc AUTHORS BUGS ChangeLog FAQ NEWS README doc/*
+
+ insinto /usr/share/${P}
+ newins contrib/README.aimconvert README.aimconvert
+ newins contrib/aimconvert.tcl aimconvert.tcl
+ newins contrib/extractbuddy.sh extractbuddy.sh
+ newins contrib/sendim.sh sendim.sh
+ newins src/cmplhlp2.sh cmplhlp2.sh
+ newins src/cmplhelp.sh cmplhelp.sh
+ newins src/cmplsample.sh cmplsample.sh
+ newins src/genkeys.sh genkeys.sh
+
+ insinto /usr/include/${PN}
+ newins include/modutil.h modutil.h
+ newins include/naim.h naim.h
+ newins include/config.h config.h
+}