summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorKathryn Kulick <gothgirl@gentoo.org>2006-07-01 19:16:17 +0000
committerKathryn Kulick <gothgirl@gentoo.org>2006-07-01 19:16:17 +0000
commit52e7a747cd1470c9a01eff826d9115a9225918c2 (patch)
tree73d107dce6df73c9585aaab0750abdf9d1939a17 /net-im
parentUpdate version. Add patches from fedora and fix catalog path (based on (diff)
downloadgentoo-2-52e7a747cd1470c9a01eff826d9115a9225918c2.tar.gz
gentoo-2-52e7a747cd1470c9a01eff826d9115a9225918c2.tar.bz2
gentoo-2-52e7a747cd1470c9a01eff826d9115a9225918c2.zip
Added avahi howl and meanwhile support.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/ChangeLog6
-rw-r--r--net-im/gaim/files/gaim-2.0.0_beta3-avahi-compat.patch30
-rw-r--r--net-im/gaim/gaim-2.0.0_beta3-r1.ebuild21
3 files changed, 52 insertions, 5 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index 0f40cf24e4de..14e76a421ff8 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/gaim
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.394 2006/06/30 15:51:09 gothgirl Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.395 2006/07/01 19:16:17 gothgirl Exp $
+
+ 01 Jul 2006; gothgirl <gothgirl@gentoo.org>
+ +files/gaim-2.0.0_beta3-avahi-compat.patch, gaim-2.0.0_beta3-r1.ebuild:
+ Added avahi-howl and meanwhile support.
30 Jun 2006; gothgirl <gothgirl@gentoo.org> gaim-2.0.0_beta3-r1.ebuild:
added gadu gadu protocol support
diff --git a/net-im/gaim/files/gaim-2.0.0_beta3-avahi-compat.patch b/net-im/gaim/files/gaim-2.0.0_beta3-avahi-compat.patch
new file mode 100644
index 000000000000..2520e7233d7e
--- /dev/null
+++ b/net-im/gaim/files/gaim-2.0.0_beta3-avahi-compat.patch
@@ -0,0 +1,30 @@
+diff -ur gaim-2.0.0beta3/configure.ac gaim-2.0.0beta3-patched/configure.ac
+--- gaim-2.0.0beta3/configure.ac 2006-03-26 07:45:35.000000000 +0000
++++ gaim-2.0.0beta3-patched/configure.ac 2006-05-07 23:13:46.000000000 +0000
+@@ -183,15 +183,17 @@
+ HOWL_CFLAGS=""
+ HOWL_LIBS=""
+
+-dnl Attempt to autodetect Howl
+-PKG_CHECK_MODULES(HOWL, howl, [
+- howlincludes="yes"
+- howllibs="yes"
+- ], [
+- AC_MSG_RESULT(no)
+- howlincludes="no"
+- howllibs="no"
+- ])
++dnl First we attempt to use avahi-compat-howl
++PKG_CHECK_MODULES(HOWL, avahi-compat-howl,
++ [howlincludes="yes" howllibs="yes"],
++ [howlincludes="no" howllibs="no"])
++
++dnl If that fails, autodetect the "real" howl
++if test "$howlincludes" = "no" ; then
++ PKG_CHECK_MODULES(HOWL, howl,
++ [howlincludes="yes" howllibs="yes"],
++ [howlincludes="no" howllibs="no"])
++fi
+
+ dnl Override HOWL_CFLAGS if the user specified an include dir
+ if test "$ac_howl_includes" != "no"; then
diff --git a/net-im/gaim/gaim-2.0.0_beta3-r1.ebuild b/net-im/gaim/gaim-2.0.0_beta3-r1.ebuild
index 52e129244a54..26df2930f033 100644
--- a/net-im/gaim/gaim-2.0.0_beta3-r1.ebuild
+++ b/net-im/gaim/gaim-2.0.0_beta3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-2.0.0_beta3-r1.ebuild,v 1.3 2006/06/30 15:51:09 gothgirl Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-2.0.0_beta3-r1.ebuild,v 1.4 2006/07/01 19:16:17 gothgirl Exp $
inherit flag-o-matic eutils toolchain-funcs debug multilib mono autotools perl-module
@@ -14,12 +14,13 @@ SRC_URI="mirror://sourceforge/gaim/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="audiofile bonjour cjk dbus debug eds gadu gnutls krb4 mono nas nls perl silc spell startup-notification tcltk xscreensaver custom-flags"
+IUSE="avahi audiofile bonjour cjk dbus debug eds gadu gnutls krb4 meanwhile mono nas nls perl silc spell startup-notification tcltk xscreensaver custom-flags"
RDEPEND="
audiofile? ( media-libs/libao
media-libs/audiofile )
- bonjour? ( net-misc/howl )
+ bonjour? ( !avahi? ( net-misc/howl )
+ avahi? ( net-dns/avahi ) )
dbus? ( >=sys-apps/dbus-0.35
>=dev-lang/python-2.4 )
>=x11-libs/gtk+-2.0
@@ -31,6 +32,7 @@ RDEPEND="
gnutls? ( net-libs/gnutls )
!gnutls? ( >=dev-libs/nss-3.11
>=dev-libs/nspr-4.6.1 )
+ meanwhile? ( net-libs/meanwhile )
silc? ( >=net-im/silc-toolkit-0.9.12-r3 )
eds? ( gnome-extra/evolution-data-server )
krb4? ( >=app-crypt/mit-krb5-1.3.6-r1 )
@@ -93,7 +95,7 @@ print_gaim_warning() {
ewarn
einfo
if use custom-flags; then
- einfo "Note that you have shown NOT TO FILTER UNSTABLE C[XX]FLAGS."
+ einfo "Note that you have chosen NOT TO FILTER UNSTABLE C[XX]FLAGS."
einfo "DO NOT file bugs with GENTOO or UPSTREAM while using custom-flags"
einfo
else
@@ -114,6 +116,7 @@ print_gaim_warning() {
pkg_setup() {
print_gaim_warning
+
if use krb4 && ! built_with_use app-crypt/mit-krb5 krb4 ; then
eerror
eerror You need to rebuild app-crypt/mit-krb5 with USE=krb4 in order to
@@ -122,6 +125,14 @@ pkg_setup() {
die "Configure failed"
fi
+ if use avahi && ! built_with_use net-dns/avahi howl-compat ; then
+ eerror
+ eerror You need to rebuild net-dns/avavhi with USE=howl-compat in order
+ eerror to enable howl support for the bonjour protocol in gaim.
+ eerror
+ die "Configure failed"
+ fi
+
if use gadu && built_with_use net-libs/libgadu ssl ; then
eerror
eerror You need to rebuild net-libs/libgadu with USE=-ssl in order
@@ -136,6 +147,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${P}-as-needed.patch
+ epatch ${FILESDIR}/${P}-avahi-compat.patch
eautomake || die "Failed running eautomake"
}
@@ -190,6 +202,7 @@ src_compile() {
$(use_enable krb4) \
$(use_enable debug) \
$(use_enable dbus) \
+ $(use_enable meanwhile) \
$(use_enable nas) \
$(use_enable eds gevolution) \
$(use_enable audiofile audio) \