summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-25 07:50:19 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-25 07:50:19 +0000
commit54b8f505bc253dfbc4120bfd5e080db8d59d0a2e (patch)
treea24a946cc2ed0c646be51a3c38d26e93f8041e48 /net-im
parentbug fix release of naim (diff)
downloadgentoo-2-54b8f505bc253dfbc4120bfd5e080db8d59d0a2e.tar.gz
gentoo-2-54b8f505bc253dfbc4120bfd5e080db8d59d0a2e.tar.bz2
gentoo-2-54b8f505bc253dfbc4120bfd5e080db8d59d0a2e.zip
Added ebuild from #9227
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim-cvs/ChangeLog8
-rw-r--r--net-im/gaim-cvs/files/digest-gaim-cvs-0.60-r10
-rw-r--r--net-im/gaim-cvs/gaim-cvs-0.60-r1.ebuild59
3 files changed, 65 insertions, 2 deletions
diff --git a/net-im/gaim-cvs/ChangeLog b/net-im/gaim-cvs/ChangeLog
index 7ee80b5a7949..855915da4ce5 100644
--- a/net-im/gaim-cvs/ChangeLog
+++ b/net-im/gaim-cvs/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for net-im/gaim-cvs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-cvs/ChangeLog,v 1.1 2002/10/19 17:18:30 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-cvs/ChangeLog,v 1.2 2002/10/25 07:50:19 vapier Exp $
+
+*gaim-cvs-0.60-r1 (25 Oct 2002)
+
+ 25 Oct 2002; Mike Frysinger <vapier@gentoo.org> gaim-cvs-0.60-r1.ebuild:
+ Added the ebuild from #9227 by Seth Chandler <sethbc1980@hotmail.com>.
*gaim-cvs-0.60 (19 Oct 2002)
19 Oct 2002; phoen][x <phoenix@gentoo.org> gaim-cvs-0.60.ebuild:
-
Initial import. This is the gaim CVS ebuild.
diff --git a/net-im/gaim-cvs/files/digest-gaim-cvs-0.60-r1 b/net-im/gaim-cvs/files/digest-gaim-cvs-0.60-r1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/net-im/gaim-cvs/files/digest-gaim-cvs-0.60-r1
diff --git a/net-im/gaim-cvs/gaim-cvs-0.60-r1.ebuild b/net-im/gaim-cvs/gaim-cvs-0.60-r1.ebuild
new file mode 100644
index 000000000000..4f8c6a5b20a4
--- /dev/null
+++ b/net-im/gaim-cvs/gaim-cvs-0.60-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-cvs/gaim-cvs-0.60-r1.ebuild,v 1.1 2002/10/25 07:50:19 vapier Exp $
+
+IUSE="nas nls esd gnome arts gtk2 perl"
+
+DESCRIPTION="GTK Instant Messenger client"
+#SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2"
+HOMEPAGE="http://gaim.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+inherit cvs
+
+ECVS_SERVER="cvs.gaim.sourceforge.net:/cvsroot/gaim"
+ECVS_MODULE="gaim"
+ECVS_TOP_DIR="${DISTDIR}/cvs-src/${PN}"
+S=${WORKDIR}/${ECVS_MODULE}
+
+DEPEND="=sys-libs/db-1*
+ !net-im/gaim
+ =x11-libs/gtk+-2.0*
+ =dev-libs/glib-2.0*
+ esd? ( >=media-sound/esound-0.2.22-r2 )
+ nls? ( sys-devel/gettext )
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ arts? ( >=kde-base/arts-0.9.5 )
+ perl? ( >=sys-devel/perl-5.6.1 )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local myconf gnomeopts
+
+ use esd || myconf="--disable-esd"
+ use perl || myconf="${myconf} --disable-perl"
+ use nas && myconf="${myconf} --enable-nas" \
+ || myconf="${myconf} --disable-nas"
+
+ if [ "` use arts`" ]; then
+ inherit kde-functions
+ set-kdedir 3
+ # $KDEDIR now points to arts location
+ else
+ myconf="${myconf} --disable-artsc"
+ fi
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./autogen.sh ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc ABOUT-NLS AUTHORS HACKING INSTALL NEWS README TODO
+}