summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-06-21 12:00:19 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-06-21 12:00:19 +0000
commit575343e1dcce19e6c63d90052ff1cdf431c3daff (patch)
treea02998476d84401fe3b1ca032d51ec3fb49cdf2b /net-im
parentRestrict media-libs/lcms depend to old version. (diff)
downloadgentoo-2-575343e1dcce19e6c63d90052ff1cdf431c3daff.tar.gz
gentoo-2-575343e1dcce19e6c63d90052ff1cdf431c3daff.tar.bz2
gentoo-2-575343e1dcce19e6c63d90052ff1cdf431c3daff.zip
New snapshot. Fixes bug #324317
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qutecom/ChangeLog8
-rw-r--r--net-im/qutecom/qutecom-2.2_p20100620.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/net-im/qutecom/ChangeLog b/net-im/qutecom/ChangeLog
index 663701cc6f05..09e8decf6e6f 100644
--- a/net-im/qutecom/ChangeLog
+++ b/net-im/qutecom/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/qutecom
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/qutecom/ChangeLog,v 1.2 2010/04/13 22:44:46 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/qutecom/ChangeLog,v 1.3 2010/06/21 12:00:19 chithanh Exp $
+
+*qutecom-2.2_p20100620 (21 Jun 2010)
+
+ 21 Jun 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +qutecom-2.2_p20100620.ebuild:
+ New snapshot. Fixes bug #324317
13 Apr 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
qutecom-2.2_p20100309.ebuild:
diff --git a/net-im/qutecom/qutecom-2.2_p20100620.ebuild b/net-im/qutecom/qutecom-2.2_p20100620.ebuild
new file mode 100644
index 000000000000..00ac04045d8d
--- /dev/null
+++ b/net-im/qutecom/qutecom-2.2_p20100620.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/qutecom/qutecom-2.2_p20100620.ebuild,v 1.1 2010/06/21 12:00:19 chithanh Exp $
+
+EAPI="3"
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Multi-protocol instant messenger and VoIP client"
+HOMEPAGE="http://www.qutecom.org/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug oss portaudio xv"
+
+RDEPEND="dev-libs/boost
+ dev-libs/glib
+ dev-libs/openssl
+ alsa? ( media-libs/alsa-lib )
+ media-libs/libsamplerate
+ media-libs/libsndfile
+ portaudio? ( media-libs/portaudio )
+ media-libs/speex
+ media-video/ffmpeg
+ net-im/pidgin[gnutls]
+ net-libs/gnutls
+ >=net-libs/libosip-3
+ >=net-libs/libeXosip-3
+ net-misc/curl
+ x11-libs/libX11
+ x11-libs/qt-gui
+ x11-libs/qt-svg
+ x11-libs/qt-webkit
+ xv? ( x11-libs/libXv )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+pkg_setup() {
+ if has_version "<dev-libs/boost-1.41" && has_version ">=dev-libs/boost-1.41"; then
+ ewarn "QuteCom build system may mix up headers and libraries if versions of"
+ ewarn "dev-libs/boost both before and after 1.41 are installed. If the build"
+ ewarn "fails due to undefined boost symbols, remove older boost."
+ fi
+}
+src_configure() {
+ local mycmakeargs="$(cmake-utils_use_enable portaudio PORTAUDIO_SUPPORT)
+ $(cmake-utils_use_enable alsa PHAPI_AUDIO_ALSA_SUPPORT)
+ $(cmake-utils_use_enable oss PHAPI_AUDIO_OSS_SUPPORT)
+ $(cmake-utils_use_enable xv WENGOPHONE_XV_SUPPORT)
+ -DLIBPURPLE_INTERNAL=OFF
+ -DPORTAUDIO_INTERNAL=OFF
+ -DCMAKE_VERBOSE_MAKEFILE=ON "
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ domenu wengophone/res/${PN}.desktop || die "domenu failed"
+ doicon wengophone/res/${PN}_64x64.png || die "doicon failed"
+
+}