summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-10-19 13:28:51 +0000
committerPeter Volkov <pva@gentoo.org>2011-10-19 13:28:51 +0000
commit6f65d404599871fe9db4c19b1f5421701ae9ab2b (patch)
treee9f0c4ce794c277434d3dec5b10683d576e1ae8a /net-im
parentAdd new ebuild for openxcom game, only live ebuild as releases do not use aut... (diff)
downloadgentoo-2-6f65d404599871fe9db4c19b1f5421701ae9ab2b.tar.gz
gentoo-2-6f65d404599871fe9db4c19b1f5421701ae9ab2b.tar.bz2
gentoo-2-6f65d404599871fe9db4c19b1f5421701ae9ab2b.zip
Don't pass -g to C.*FLAGS and bump EAPI, thank Agostino Sarubbo for this job.
(Portage version: 2.1.10.27/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/psi/ChangeLog10
-rw-r--r--net-im/psi/files/psi-0.14-drop-debug-cflags.patch35
-rw-r--r--net-im/psi/psi-0.14-r4.ebuild41
3 files changed, 65 insertions, 21 deletions
diff --git a/net-im/psi/ChangeLog b/net-im/psi/ChangeLog
index 14802e3d8b48..7a3a640c4a12 100644
--- a/net-im/psi/ChangeLog
+++ b/net-im/psi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-im/psi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.215 2011/10/19 11:34:51 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.216 2011/10/19 13:28:51 pva Exp $
+
+ 19 Oct 2011; Peter Volkov <pva@gentoo.org> psi-0.14-r4.ebuild,
+ +files/psi-0.14-drop-debug-cflags.patch:
+ Don't pass -g to C.*FLAGS and bump EAPI, thank Agostino Sarubbo for this job.
+
+ 19 Oct 2011; Peter Volkov <pva@gentoo.org> psi-0.14-r4.ebuild,
+ +files/psi-0.14-drop-debug-cflags.patch:
+ Don't pass -g to C.*FLAGS, thank Agostino Sarubbo for the fix.
*psi-0.14-r4 (19 Oct 2011)
diff --git a/net-im/psi/files/psi-0.14-drop-debug-cflags.patch b/net-im/psi/files/psi-0.14-drop-debug-cflags.patch
new file mode 100644
index 000000000000..227265696ae6
--- /dev/null
+++ b/net-im/psi/files/psi-0.14-drop-debug-cflags.patch
@@ -0,0 +1,35 @@
+Drop -g from CFLAGS
+
+--- qcm/buildmodeapp.qcm 2011-10-19 14:38:55.621699641 +0200
++++ qcm/buildmodeapp.qcm 2011-10-19 14:39:11.868700486 +0200
+@@ -130,8 +130,6 @@
+ if(qc_buildmode_separate_debug_info)
+ {
+ opts += "separate_debug_info";
+- other += "*-g++*:QMAKE_CFLAGS += -g\n";
+- other += "*-g++*:QMAKE_CXXFLAGS += -g\n";
+ }
+
+ QString str = QString("CONFIG += ") + opts.join(" ") + '\n';
+--- iris/qcm/extra.qcm.old 2011-10-19 14:39:40.268701738 +0200
++++ iris/qcm/extra.qcm 2011-10-19 14:40:01.904699887 +0200
+@@ -55,8 +55,6 @@
+ if(debug_info)
+ {
+ str += QString("CONFIG += separate_debug_info\n");
+- str += "QMAKE_CFLAGS += -g\n";
+- str += "QMAKE_CXXFLAGS += -g\n";
+ }
+ if(universal)
+ {
+--- iris/qcm/buildmode.qcm.old 2011-10-19 14:40:23.794701147 +0200
++++ iris/qcm/buildmode.qcm 2011-10-19 14:40:42.157701302 +0200
+@@ -186,8 +186,6 @@
+ if(qc_buildmode_separate_debug_info)
+ {
+ opts += "separate_debug_info";
+- other += "QMAKE_CFLAGS += -g\n";
+- other += "QMAKE_CXXFLAGS += -g\n";
+ }
+
+ QString str = QString("CONFIG += ") + opts.join(" ") + '\n';
diff --git a/net-im/psi/psi-0.14-r4.ebuild b/net-im/psi/psi-0.14-r4.ebuild
index 908dc5ff18df..74e5132c20ce 100644
--- a/net-im/psi/psi-0.14-r4.ebuild
+++ b/net-im/psi/psi-0.14-r4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.14-r4.ebuild,v 1.1 2011/10/19 11:34:51 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.14-r4.ebuild,v 1.2 2011/10/19 13:28:51 pva Exp $
-EAPI="2"
+EAPI=4
inherit eutils qt4-r2 multilib
@@ -53,6 +53,7 @@ src_prepare() {
epatch "${FILESDIR}/psi-0.14-qt-compat.patch"
epatch "${FILESDIR}/psi-0.14-minizip-detection.patch"
epatch "${FILESDIR}/psi-0.14-input-validation.patch"
+ epatch "${FILESDIR}/psi-0.14-drop-debug-cflags.patch"
if use extras; then
# some patches from psi+ project http://code.google.com/p/psi-dev
@@ -84,7 +85,7 @@ src_prepare() {
fi
fi
- rm -rf third-party/qca # We use system libraries.
+ rm -rf third-party/qca || die # We use system libraries.
}
src_configure() {
@@ -111,38 +112,38 @@ src_configure() {
src_compile() {
eqmake4
- emake || die "emake failed"
+ emake
if use doc; then
- cd doc
- mkdir -p api # 259632
- make api_public || die "make api_public failed"
+ cd doc || die
+ mkdir -p api || die # 259632
+ emake api_public
fi
}
src_install() {
- emake INSTALL_ROOT="${D}" install || die "emake install failed"
- rm "${D}"/usr/share/psi/{COPYING,README}
+ emake INSTALL_ROOT="${D}" install
+ rm "${D}"/usr/share/psi/{COPYING,README} || die
# this way the docs will be installed in the standard gentoo dir
- newdoc iconsets/roster/README README.roster || die
- newdoc iconsets/system/README README.system || die
- newdoc certs/README README.certs || die
- dodoc README || die
+ newdoc iconsets/roster/README README.roster
+ newdoc iconsets/system/README README.system
+ newdoc certs/README README.certs
+ dodoc README
if use doc; then
- cd doc
- dohtml -r api || die "dohtml failed"
+ cd doc || die
+ dohtml -r api
fi
# install translations
- cd "${WORKDIR}"
+ cd "${WORKDIR}" || die
insinto /usr/share/${PN}/
local nolangs=true
for LNG in ${LANGS}; do
if use linguas_${LNG}; then
- doins ${LNG}/${PN}_${LNG}.qm || die
- newins ${LNG}/INFO INFO.${LNG} || die
+ doins ${LNG}/${PN}_${LNG}.qm
+ newins ${LNG}/INFO INFO.${LNG}
nolangs=false
fi
done
@@ -150,8 +151,8 @@ src_install() {
# if linguas is empty install all translations
if ${nolangs}; then
for LNG in ${LANGS}; do
- doins ${LNG}/${PN}_${LNG}.qm || die
- newins ${LNG}/INFO INFO.${LNG} || die
+ doins ${LNG}/${PN}_${LNG}.qm
+ newins ${LNG}/INFO INFO.${LNG}
done
fi