summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-01-16 09:58:18 +0000
committerPeter Volkov <pva@gentoo.org>2006-01-16 09:58:18 +0000
commit7ccee0d6ea5f99b9624703ada88cfab1310caadf (patch)
tree2896b812a37869fc1c2bbcb82f74f882036307f9 /net-im
parentarm/ia64/s390 love (diff)
downloadgentoo-2-7ccee0d6ea5f99b9624703ada88cfab1310caadf.tar.gz
gentoo-2-7ccee0d6ea5f99b9624703ada88cfab1310caadf.tar.bz2
gentoo-2-7ccee0d6ea5f99b9624703ada88cfab1310caadf.zip
Backticks are not necessary in "if" statements... removed. Thanks Thomas Fischer for pointing my attention on this abc-fact.
(Portage version: 2.0.53)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/sim/ChangeLog6
-rw-r--r--net-im/sim/sim-0.9.4_pre060114.ebuild54
2 files changed, 32 insertions, 28 deletions
diff --git a/net-im/sim/ChangeLog b/net-im/sim/ChangeLog
index efc72eb1ddcc..18013ef94edb 100644
--- a/net-im/sim/ChangeLog
+++ b/net-im/sim/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/sim
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/sim/ChangeLog,v 1.48 2006/01/15 19:05:42 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/sim/ChangeLog,v 1.49 2006/01/16 09:58:18 pva Exp $
+
+ 16 Jan 2006; Peter Volkov <pva@gentoo.org> sim-0.9.4_pre060114.ebuild:
+ Backticks are not necessary in "if" statements... removed. Thanks Thomas
+ Fischer for pointing my attention on this abc-fact.
*sim-0.9.4_pre060114 (15 Jan 2006)
diff --git a/net-im/sim/sim-0.9.4_pre060114.ebuild b/net-im/sim/sim-0.9.4_pre060114.ebuild
index eb4bed84760f..2a4fa4cd3e16 100644
--- a/net-im/sim/sim-0.9.4_pre060114.ebuild
+++ b/net-im/sim/sim-0.9.4_pre060114.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/sim/sim-0.9.4_pre060114.ebuild,v 1.1 2006/01/15 19:05:42 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/sim/sim-0.9.4_pre060114.ebuild,v 1.2 2006/01/16 09:58:18 pva Exp $
inherit kde-functions eutils debug
@@ -35,45 +35,45 @@ pkg_setup() {
if [ -z ${myver} ] ; then
ewarn "Building svn version exported on ${myver}."
fi
- if `use kde` ; then
- if `has_version net-im/sim`; then
- if ! `built_with_use net-im/sim kde`; then
- ewarn "Your system already has sim emerged with USE=\"-kde\"."
- ewarn "Now you are trying to emerge it with kde support."
- ewarn "Sim has problem that leads to compilation failure in such case."
- ewarn "To emerge sim with kde support, first clean out previous"
- ewarn "installation with \`emerge -C sim\` and then try again."
+ if use kde ; then
+ if has_version net-im/sim ; then
+ if ! built_with_use net-im/sim kde ; then
+ ewarn 'Your system already has sim emerged with USE="-kde".'
+ ewarn 'Now you are trying to emerge it with kde support.'
+ ewarn 'Sim has problem that leads to compilation failure in such case.'
+ ewarn 'To emerge sim with kde support, first clean out previous'
+ ewarn 'installation with `emerge -C sim` and then try again.'
die "Previous installation found. Unmerge it first."
fi
fi
- if `use spell`; then
- if ! `built_with_use kde-base/kdelibs spell`; then
+ if use spell; then
+ if ! built_with_use kde-base/kdelibs spell ; then
ewarn "kde-base/kdelibs were merged without spell in USE."
ewarn "Thus spelling will not work in sim. Please, either"
ewarn "reemerge kde-base/kdelibs with spell in USE or emerge"
- ewarn "sim with USE=\"-spell\" to avoid this message."
+ ewarn 'sim with USE="-spell" to avoid this message.'
ebeep
fi
else
- if `built_with_use kde-base/kdelibs spell`; then
- ewarn "kde-base/kdelibs were merged with spell in USE."
- ewarn "Thus spelling will work in sim. Please, either"
- ewarn "reemerge kde-base/kdelibs without spell in USE or emerge"
- ewarn "sim with USE=\"spell\" to avoid this message."
+ if built_with_use kde-base/kdelibs spell ; then
+ ewarn 'kde-base/kdelibs were merged with spell in USE.'
+ ewarn 'Thus spelling will work in sim. Please, either'
+ ewarn 'reemerge kde-base/kdelibs without spell in USE or emerge'
+ ewarn 'sim with USE="spell" to avoid this message.'
ebeep
fi
fi
- if ! `built_with_use kde-base/kdelibs arts`; then
+ if ! built_with_use kde-base/kdelibs arts ; then
myconf="--without-arts"
fi
else
- if `has_version net-im/sim`; then
- if `built_with_use net-im/sim kde`; then
- ewarn "Your system already has sim emerged with USE=\"kde\"."
- ewarn "Now you are trying to emerge it without kde support."
- ewarn "Sim has problem that leads to compilation failure in such case."
- ewarn "To emerge sim without kde support, first clean out previous"
- ewarn "installation with \`emerge -C sim\` and then try again."
+ if has_version net-im/sim ; then
+ if built_with_use net-im/sim kde ; then
+ ewarn 'Your system already has sim emerged with USE="kde".'
+ ewarn 'Now you are trying to emerge it without kde support.'
+ ewarn 'Sim has problem that leads to compilation failure in such case.'
+ ewarn 'To emerge sim without kde support, first clean out previous'
+ ewarn 'installation with `emerge -C sim` and then try again.'
die "Previous installation found. Unmerge it first."
fi
fi
@@ -84,13 +84,13 @@ src_compile() {
need-autoconf 2.5
need-automake 1.7
- if `use kde` ; then
+ if use kde ; then
set-kdedir 3
fi
make -f admin/Makefile.common || die "Failed to create Makefiles..."
- if ! `use kde` ; then
+ if ! use kde ; then
use spell || export DO_NOT_COMPILE="$DO_NOT_COMPILE plugins/spell"
fi