summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-13 17:12:09 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-13 17:12:09 +0000
commit9608b1054c1aec597fedd22832934f17b149e255 (patch)
tree148ca4c308a6d68d68f20a921cc97d4a55564a5f /net-im
parentStable on sparc wrt #136452 (diff)
downloadgentoo-2-9608b1054c1aec597fedd22832934f17b149e255.tar.gz
gentoo-2-9608b1054c1aec597fedd22832934f17b149e255.tar.bz2
gentoo-2-9608b1054c1aec597fedd22832934f17b149e255.zip
Add patch to fix KDE BUG #129366. Thanks to Roman Jarosz for reporting.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/kopete/ChangeLog9
-rw-r--r--net-im/kopete/files/digest-kopete-0.12.0-r33
-rw-r--r--net-im/kopete/files/kopete-0.12-icqfix2.patch13
-rw-r--r--net-im/kopete/kopete-0.12.0-r3.ebuild127
4 files changed, 151 insertions, 1 deletions
diff --git a/net-im/kopete/ChangeLog b/net-im/kopete/ChangeLog
index 8c16f9d8f4d7..c0f07f055585 100644
--- a/net-im/kopete/ChangeLog
+++ b/net-im/kopete/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/kopete
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/ChangeLog,v 1.69 2006/07/12 21:06:35 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/ChangeLog,v 1.70 2006/07/13 17:12:09 flameeyes Exp $
+
+*kopete-0.12.0-r3 (13 Jul 2006)
+
+ 13 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kopete-0.12-icqfix2.patch, -kopete-0.12.0-r1.ebuild,
+ -kopete-0.12.0-r2.ebuild, +kopete-0.12.0-r3.ebuild:
+ Add patch to fix KDE BUG #129366. Thanks to Roman Jarosz for reporting.
12 Jul 2006; Markus Rothe <corsair@gentoo.org> kopete-0.12.0-r2.ebuild:
Added ~ppc64
diff --git a/net-im/kopete/files/digest-kopete-0.12.0-r3 b/net-im/kopete/files/digest-kopete-0.12.0-r3
new file mode 100644
index 000000000000..488e78a604c5
--- /dev/null
+++ b/net-im/kopete/files/digest-kopete-0.12.0-r3
@@ -0,0 +1,3 @@
+MD5 392c5af64177ae29b3eebc10b91ad782 kopete-0.12.tar.bz2 5303165
+RMD160 f69576edb740dc80b74e69455b3302e7345d71b6 kopete-0.12.tar.bz2 5303165
+SHA256 1fc32f9729dcf29ae5cad344858ec7d4b3bbb0f94f13edbbbe72462e89cdfa58 kopete-0.12.tar.bz2 5303165
diff --git a/net-im/kopete/files/kopete-0.12-icqfix2.patch b/net-im/kopete/files/kopete-0.12-icqfix2.patch
new file mode 100644
index 000000000000..8a1716badaa3
--- /dev/null
+++ b/net-im/kopete/files/kopete-0.12-icqfix2.patch
@@ -0,0 +1,13 @@
+Index: kopete/protocols/oscar/liboscar/client.cpp
+===================================================================
+--- kopete/protocols/oscar/liboscar/client.cpp (revision 560657)
++++ kopete/protocols/oscar/liboscar/client.cpp (revision 560658)
+@@ -1212,7 +1212,7 @@
+ return;
+
+ if ( c->isSupported( 0x0002 ) ||
+- c->supportedFamilies().count() == 0 ) //emit on login
++ d->stage == ClientPrivate::StageOne ) //emit on login
+ {
+ emit socketError( code, string );
+ }
diff --git a/net-im/kopete/kopete-0.12.0-r3.ebuild b/net-im/kopete/kopete-0.12.0-r3.ebuild
new file mode 100644
index 000000000000..8681ab63bac9
--- /dev/null
+++ b/net-im/kopete/kopete-0.12.0-r3.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/kopete-0.12.0-r3.ebuild,v 1.1 2006/07/13 17:12:09 flameeyes Exp $
+
+inherit kde eutils
+
+MY_P="${P/_/-}"
+MY_P="${MY_P/.0/}"
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="http://kopete.kde.org/"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="jingle sametime ssl xmms xscreensaver slp kernel_linux latex crypt
+ winpopup sms irc yahoo gadu groupwise netmeeting statistics autoreplace
+ connectionstatus contactnotes translator webpresence texteffect highlight
+ alias autoreplace history nowlistening addbookmarks"
+
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+# The kernel_linux? ( ) conditional dependencies are for webcams, not supported
+# on other kernels AFAIK
+BOTH_DEPEND="dev-libs/libxslt
+ dev-libs/libxml2
+ net-dns/libidn
+ >=dev-libs/glib-2
+ app-crypt/qca
+ slp? ( net-libs/openslp )
+ jingle? (
+ >=media-libs/speex-1.1.6
+ dev-libs/expat
+ ~net-libs/ortp-0.7.1 )
+ sametime? ( =net-libs/meanwhile-0.4* )
+ xmms? ( media-sound/xmms )
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ ) <virtual/x11-7 )
+ kernel_linux? ( virtual/opengl )
+ sms? ( app-mobilephone/gsmlib )"
+
+RDEPEND="${BOTH_DEPEND}
+ ssl? ( app-crypt/qca-tls )
+ !kde-base/kopete
+ !kde-base/kdenetwork
+ !net-libs/libjingle
+ latex? ( app-text/tetex )
+ crypt? ( app-crypt/gnupg )
+ netmeeting? ( net-im/gnomemeeting )"
+
+DEPEND="${BOTH_DEPEND}
+ kernel_linux? ( virtual/os-headers )
+ || ( (
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xproto
+ kernel_linux? ( x11-libs/libXv )
+ xscreensaver? ( x11-proto/scrnsaverproto )
+ ) <virtual/x11-7 )"
+
+need-kde 3.4
+
+#dev-libs/ilbc-rfc3951: could not see any benifit in it
+#sed -i 's:ilbc_found="no":ilbc_found="yes":' ${S}/kopete/protocols/jabber/jingle/configure.in.in
+
+pkg_setup() {
+ if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then
+ eerror "To support Video4Linux webcams in this package is required to have"
+ eerror "=x11-libs/qt-3* compiled with OpenGL support."
+ eerror "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ die "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ fi
+}
+
+kopete_disable() {
+ einfo "Disabling $2 $1"
+ sed -i -e "s/$2//" "${S}/kopete/$1s/Makefile.am"
+}
+
+src_unpack() {
+ kde_src_unpack
+ epatch "${FILESDIR}/${PN}-0.12_alpha1-xscreensaver.patch"
+ epatch "${FILESDIR}/${PN}-0.12-away.diff"
+ epatch "${FILESDIR}/${PN}-0.12-jabber-muc-chat.patch"
+ epatch "${FILESDIR}/${PN}-0.12-icqfix.patch"
+ epatch "${FILESDIR}/${PN}-0.12-icqfix2.patch"
+
+ use latex || kopete_disable plugin latex
+ use crypt || kopete_disable plugin cryptography
+ use netmeeting || kopete_disable plugin netmeeting
+ use statistics || kopete_disable plugin statistics
+ use autoreplace || kopete_disable plugin autoreplace
+ use connectionstatus || kopete_disable plugin connectionstatus
+ use contactnotes || kopete_disable plugin contactnotes
+ use translator || kopete_disable plugin translator
+ use webpresence || kopete_disable plugin webpresence
+ use texteffect || kopete_disable plugin texteffect
+ use highlight || kopete_disable plugin highlight
+ use alias || kopete_disable plugin alias
+ use addbookmarks || kopete_disable plugin addbookmarks
+ use history || kopete_disable plugin history
+ use nowlistening || kopete_disable plugin nowlistening
+
+ use winpopup || kopete_disable protocol winpopup
+ use gadu || kopete_disable protocol '\$(GADU)'
+ use irc || kopete_disable protocol irc
+ use groupwise || kopete_disable protocol groupwise
+ use yahoo || kopete_disable protocol yahoo
+
+ rm -f "${S}/configure"
+}
+
+src_compile() {
+ # External libgadu support - doesn't work, kopete requires a specific development snapshot of libgadu.
+ # Maybe we can enable it in the future.
+ # The nowlistening plugin has xmms support.
+ local myconf="$(use_enable jingle)
+ $(use_enable sametime sametime-plugin)
+ $(use_with xmms) --without-external-libgadu
+ $(use_with xscreensaver) $(use_enable sms smsgsm)
+ $(use_enable debug testbed)"
+
+ kde_src_compile
+}