summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-06-13 16:35:45 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-06-13 16:35:45 +0000
commit9ed15d35cdb533dd808cbc0043ec313807a4c574 (patch)
treeacc0c1752c782c27d85a4ff0cfa09039f3f274fa /net-im
parentRemove sys-cluster/mpich from virtual/mpi. (#266565) (diff)
downloadgentoo-2-9ed15d35cdb533dd808cbc0043ec313807a4c574.tar.gz
gentoo-2-9ed15d35cdb533dd808cbc0043ec313807a4c574.tar.bz2
gentoo-2-9ed15d35cdb533dd808cbc0043ec313807a4c574.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qtwitter/ChangeLog7
-rw-r--r--net-im/qtwitter/qtwitter-0.7.1.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/net-im/qtwitter/ChangeLog b/net-im/qtwitter/ChangeLog
index 813abc0d36be..32367ce6f408 100644
--- a/net-im/qtwitter/ChangeLog
+++ b/net-im/qtwitter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/qtwitter
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/ChangeLog,v 1.4 2009/06/09 22:56:57 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/ChangeLog,v 1.5 2009/06/13 16:35:45 hwoarang Exp $
+
+*qtwitter-0.7.1 (13 Jun 2009)
+
+ 13 Jun 2009; Markos Chandras <hwoarang@gentoo.org> +qtwitter-0.7.1.ebuild:
+ Version bump
09 Jun 2009; Markos Chandras <hwoarang@gentoo.org>
-qtwitter-0.6.0-r1.ebuild, -qtwitter-0.6.0-r2.ebuild:
diff --git a/net-im/qtwitter/qtwitter-0.7.1.ebuild b/net-im/qtwitter/qtwitter-0.7.1.ebuild
new file mode 100644
index 000000000000..132c7a6c0fae
--- /dev/null
+++ b/net-im/qtwitter/qtwitter-0.7.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/qtwitter/qtwitter-0.7.1.ebuild,v 1.1 2009/06/13 16:35:45 hwoarang Exp $
+
+EAPI="2"
+
+inherit qt4 multilib
+
+DESCRIPTION="A Qt-based client for Twitter and Identi.ca"
+HOMEPAGE="http://www.qt-apps.org/content/show.php/qTwitter?content=99087"
+SRC_URI="http://files.ayoy.net/qtwitter/release/${PV}/src/${P}-src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}"
+
+QTWITTER_LANGS="pt_BR"
+QTWITTER_NOLONGLANGS="ca_ES de_DE es_ES fr_FR ja_JP pl_PL"
+
+for L in $QTWITTER_LANGS; do
+ IUSE="$IUSE linguas_$L"
+done
+for L in $QTWITTER_NOLONGLANGS; do
+ IUSE="$IUSE linguas_${L%_*}"
+done
+
+src_prepare() {
+ echo "CONFIG += nostrip" >> "${S}"/${PN}.pro
+
+ # translations
+ local langs=
+ for lingua in $LINGUAS; do
+ if has $lingua $QTWITTER_LANGS; then
+ langs="$langs loc/${PN}_${lingua}.ts"
+ else
+ for a in $QTWITTER_NOLONGLANGS; do
+ if [[ $lingua == ${a%_*} ]]; then
+ langs="$langs loc/${PN}_${a}.ts"
+ fi
+ done
+ fi
+ done
+
+ # remove translations and add only the selected ones
+ sed -i -e '/^ *loc.*\.ts/d' \
+ -e "/^TRANSLATIONS/s:loc.*:${langs}:" \
+ qtwitter-app/qtwitter-app.pro || die "sed failed"
+ # first line fixes bug about unsecure runpaths
+ # second disables docs installation by make (done by dodoc in install)
+ sed -i -e '/-Wl,-rpath,\$\${TOP}/d' \
+ -e '/doc \\/d' \
+ qtwitter-app/qtwitter-app.pro || die "sed failed"
+
+ sed -i "s/\$\${INSTALL_PREFIX}\/lib/\$\${INSTALL_PREFIX}\/$(get_libdir)/" \
+ twitterapi/twitterapi.pro urlshortener/urlshortener.pro || die "sed failed"
+}
+
+src_configure() {
+ eqmake4 ${PN}.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc README CHANGELOG || die "dodoc failed"
+}