summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-29 15:21:16 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-29 15:21:16 +0000
commitad6fae6e97ef46ba17c2e5e21a2d374a8bf71f59 (patch)
tree1fb45bb39a654815cc43848dd2e7b94f7b95b2f4 /net-im
parentStable for HPPA (bug #330565). (diff)
downloadgentoo-2-ad6fae6e97ef46ba17c2e5e21a2d374a8bf71f59.tar.gz
gentoo-2-ad6fae6e97ef46ba17c2e5e21a2d374a8bf71f59.tar.bz2
gentoo-2-ad6fae6e97ef46ba17c2e5e21a2d374a8bf71f59.zip
Remove multi ABI support again as it sucks
(Portage version: 2.2.0_alpha2/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gajim/ChangeLog8
-rw-r--r--net-im/gajim/gajim-0.14.1-r2.ebuild (renamed from net-im/gajim/gajim-0.14.1-r1.ebuild)36
2 files changed, 19 insertions, 25 deletions
diff --git a/net-im/gajim/ChangeLog b/net-im/gajim/ChangeLog
index 7754c494c856..35d65a473e87 100644
--- a/net-im/gajim/ChangeLog
+++ b/net-im/gajim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/gajim
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.107 2010/10/29 14:32:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.108 2010/10/29 15:21:16 jlec Exp $
+
+*gajim-0.14.1-r2 (29 Oct 2010)
+
+ 29 Oct 2010; Justin Lecher <jlec@gentoo.org> -gajim-0.14.1-r1.ebuild,
+ +gajim-0.14.1-r2.ebuild:
+ Remove multi ABI support again as it doesn't work for this package
*gajim-0.14.1-r1 (29 Oct 2010)
diff --git a/net-im/gajim/gajim-0.14.1-r1.ebuild b/net-im/gajim/gajim-0.14.1-r2.ebuild
index fa19e6247c47..8c3b6c6b9c5b 100644
--- a/net-im/gajim/gajim-0.14.1-r1.ebuild
+++ b/net-im/gajim/gajim-0.14.1-r2.ebuild
@@ -1,13 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.14.1-r1.ebuild,v 1.1 2010/10/29 14:32:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.14.1-r2.ebuild,v 1.1 2010/10/29 15:21:16 jlec Exp $
EAPI="2"
PYTHON_DEPEND="2"
PYTHON_USE_WITH="sqlite xml"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
inherit eutils python versionator
@@ -73,6 +71,7 @@ pkg_setup() {
fi
fi
python_pkg_setup
+ python_set_active_version 2
}
src_prepare() {
@@ -80,7 +79,6 @@ src_prepare() {
"${FILESDIR}"/0.14-python-version.patch \
"${FILESDIR}"/0.14.1-testing.patch
echo '#!/bin/sh' > config/py-compile
-
}
src_configure() {
@@ -88,31 +86,21 @@ src_configure() {
$(use_enable nls) \
$(use_with X x) \
--docdir="/usr/share/doc/${PF}" \
+ --libdir="$(python_get_sitedir)" \
--enable-site-packages
}
-src_test() {
- testing() {
- emake \
- GENTOOPY="$(PYTHON)" \
- test || die
- }
-# not implemented
-# python_execute_function testing
-}
-
src_install() {
- installation() {
- emake \
- GAJIM_SRCDIR="$(python_get_sitedir)"/${PN} \
- pythondir="$(python_get_sitedir)" \
- pyexecdir="$(python_get_sitedir)" \
- DESTDIR="${D}" \
- install || die
- }
-
- python_execute_function installation
+ emake DESTDIR="${D}" install || die "emake install failed"
rm "${D}/usr/share/doc/${PF}/"{README.html,COPYING} || die
dohtml README.html || die
}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup $(python_get_sitedir)/${PN}
+}