summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-12-10 06:22:39 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-12-10 06:22:39 +0000
commitc65cca02dc41108b1941ec2dee1eb81d13100443 (patch)
tree6b1323b7c9b2ae605acc6ddcb7b7781b57a6cfac /net-im
parentchase latest XFS utils (diff)
downloadgentoo-2-c65cca02dc41108b1941ec2dee1eb81d13100443.tar.gz
gentoo-2-c65cca02dc41108b1941ec2dee1eb81d13100443.tar.bz2
gentoo-2-c65cca02dc41108b1941ec2dee1eb81d13100443.zip
bump
Diffstat (limited to 'net-im')
-rw-r--r--net-im/naim/ChangeLog9
-rw-r--r--net-im/naim/files/digest-naim-0.11.5_rc31
-rw-r--r--net-im/naim/naim-0.11.5_rc1.ebuild4
-rw-r--r--net-im/naim/naim-0.11.5_rc3.ebuild57
4 files changed, 68 insertions, 3 deletions
diff --git a/net-im/naim/ChangeLog b/net-im/naim/ChangeLog
index 411516da9e50..60a7c198c42d 100644
--- a/net-im/naim/ChangeLog
+++ b/net-im/naim/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/naim
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/naim/ChangeLog,v 1.8 2002/12/09 01:45:37 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/naim/ChangeLog,v 1.9 2002/12/10 06:18:27 lostlogic Exp $
+
+*naim-0.11.5_rc3 (10 Dec 2002)
+
+ 10 Dec 2002; Brandon Low <lostlogic@gentoo.org> naim-0.11.5_rc1.ebuild :
+ Looks like this should be the last _rc release before final. Has some
+ new features this time like better window resize. Check his
+ changelogs for more info.
*naim-0.11.5_rc1 (08 Dec 2002)
diff --git a/net-im/naim/files/digest-naim-0.11.5_rc3 b/net-im/naim/files/digest-naim-0.11.5_rc3
new file mode 100644
index 000000000000..b65089b832d2
--- /dev/null
+++ b/net-im/naim/files/digest-naim-0.11.5_rc3
@@ -0,0 +1 @@
+MD5 7d1e1200e9b06d229f168d9a6497026a naim-0.11.5rc3.tar.gz 369434
diff --git a/net-im/naim/naim-0.11.5_rc1.ebuild b/net-im/naim/naim-0.11.5_rc1.ebuild
index 52a03333ad41..9d8c581fdcba 100644
--- a/net-im/naim/naim-0.11.5_rc1.ebuild
+++ b/net-im/naim/naim-0.11.5_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/naim/naim-0.11.5_rc1.ebuild,v 1.1 2002/12/09 01:45:37 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/naim/naim-0.11.5_rc1.ebuild,v 1.2 2002/12/10 06:18:27 lostlogic Exp $
VA="`echo ${PV}|sed -e 's:^\([0-9]*\)\..*$:\1:'`"
VB="`echo ${PV}|sed -e 's:^[0-9]*\.\([0-9]*\)\..*$:\1:'`"
@@ -24,7 +24,7 @@ src_compile() {
einfo "${P}"
local myconf
- myconf="--with-gnu-ld --enable-detach"
+ myconf="--with-gnu-ld --enable-detach" # --enable-debug"
use pic && myconf="${myconf} --with-pic"
use static && myconf="${myconf} --enable-static=yes"
diff --git a/net-im/naim/naim-0.11.5_rc3.ebuild b/net-im/naim/naim-0.11.5_rc3.ebuild
new file mode 100644
index 000000000000..f95088ca0e37
--- /dev/null
+++ b/net-im/naim/naim-0.11.5_rc3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/naim/naim-0.11.5_rc3.ebuild,v 1.1 2002/12/10 06:18:27 lostlogic Exp $
+
+VA="`echo ${PV}|sed -e 's:^\([0-9]*\)\..*$:\1:'`"
+VB="`echo ${PV}|sed -e 's:^[0-9]*\.\([0-9]*\)\..*$:\1:'`"
+FOLDER="naim-0.11.5"
+SNAP="rc3"
+SRC_URI="http://128.113.139.111/~n/.${PN}_archive/${VA}/${VB}/${FOLDER}-snap/${FOLDER}${SNAP}.tar.gz"
+DESCRIPTION="An ncurses AOL Instant Messenger."
+HOMEPAGE="http://site.rpi-acm.org/info/naim/"
+#P="`echo ${P}|sed -e 's:_.*$::'`"
+P="${P/_/}"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ virtual/glibc"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ einfo "${P}"
+
+ local myconf
+ myconf="--with-gnu-ld --enable-detach" # --enable-debug"
+ use pic && myconf="${myconf} --with-pic"
+ use static && myconf="${myconf} --enable-static=yes"
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin src/naim
+
+ doman naim.1
+
+ dodoc AUTHORS BUGS ChangeLog FAQ NEWS README doc/*
+
+ insinto /usr/share/${P}
+ newins contrib/README.aimconvert README.aimconvert
+ newins contrib/aimconvert.tcl aimconvert.tcl
+ newins contrib/extractbuddy.sh extractbuddy.sh
+ newins contrib/sendim.sh sendim.sh
+ newins src/cmplhlp2.sh cmplhlp2.sh
+ newins src/cmplhelp.sh cmplhelp.sh
+ newins src/cmplsample.sh cmplsample.sh
+ newins src/genkeys.sh genkeys.sh
+
+ insinto /usr/include/${PN}
+ newins include/modutil.h modutil.h
+ newins include/naim.h naim.h
+ newins include/config.h config.h
+}