summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-11-10 10:37:48 +0000
committerJeroen Roovers <jer@gentoo.org>2014-11-10 10:37:48 +0000
commitcc7d91d16d2d856d3bebc4f388cb367e55b3f532 (patch)
tree57865fe7922aefa06f0ce27713beb01083b427da /net-im
parentNeeds newer grilo (upstream bug #739159) (diff)
downloadgentoo-2-cc7d91d16d2d856d3bebc4f388cb367e55b3f532.tar.gz
gentoo-2-cc7d91d16d2d856d3bebc4f388cb367e55b3f532.tar.bz2
gentoo-2-cc7d91d16d2d856d3bebc4f388cb367e55b3f532.zip
Fix building against sys-libs/ncurses[tinfo] (bug #527592).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/pork/ChangeLog6
-rw-r--r--net-im/pork/files/pork-0.99.8.1-tinfo.patch11
-rw-r--r--net-im/pork/pork-0.99.8.1.ebuild37
3 files changed, 36 insertions, 18 deletions
diff --git a/net-im/pork/ChangeLog b/net-im/pork/ChangeLog
index 46bcddf3bee2..73791ba0b8b3 100644
--- a/net-im/pork/ChangeLog
+++ b/net-im/pork/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/pork
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pork/ChangeLog,v 1.45 2014/08/30 12:29:14 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pork/ChangeLog,v 1.46 2014/11/10 10:37:48 jer Exp $
+
+ 10 Nov 2014; Jeroen Roovers <jer@gentoo.org> pork-0.99.8.1.ebuild,
+ +files/pork-0.99.8.1-tinfo.patch:
+ Fix building against sys-libs/ncurses[tinfo] (bug #527592).
30 Aug 2014; Michał Górny <mgorny@gentoo.org> pork-0.99.8.1.ebuild:
Replace einstall with emake install, bug #521436.
diff --git a/net-im/pork/files/pork-0.99.8.1-tinfo.patch b/net-im/pork/files/pork-0.99.8.1-tinfo.patch
new file mode 100644
index 000000000000..c1f9e6bbb945
--- /dev/null
+++ b/net-im/pork/files/pork-0.99.8.1-tinfo.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -114,6 +114,8 @@
+
+ AC_CHECK_LIB(ncurses, resizeterm, AC_DEFINE(HAVE_RESIZETERM, 1, [Define to 1 if you have the 'resizeterm' function in -lncurses.]))
+
++AC_SEARCH_LIBS(stdscr, tinfo)
++
+ AC_CHECK_TYPE(u_int32_t, uint32_t)
+ if test "$ac_cv_type_u_int32_t" = "no"; then
+ AC_CHECK_TYPE(uint32_t, unsigned int)
diff --git a/net-im/pork/pork-0.99.8.1.ebuild b/net-im/pork/pork-0.99.8.1.ebuild
index 862aee0a626b..306aa98fbcdf 100644
--- a/net-im/pork/pork-0.99.8.1.ebuild
+++ b/net-im/pork/pork-0.99.8.1.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pork/pork-0.99.8.1.ebuild,v 1.17 2014/08/30 12:29:14 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pork/pork-0.99.8.1.ebuild,v 1.18 2014/11/10 10:37:48 jer Exp $
+
+EAPI=5
+inherit autotools eutils
DESCRIPTION="Console based AIM client that looks like ircII"
HOMEPAGE="http://dev.ojnk.net/"
@@ -11,27 +14,27 @@ SLOT="0"
KEYWORDS="alpha amd64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="perl"
-DEPEND="perl? ( dev-lang/perl )
- sys-libs/ncurses"
+RDEPEND="
+ perl? ( dev-lang/perl )
+ sys-libs/ncurses
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ eautoreconf
+}
-src_compile() {
- local myconf=""
- econf $(use_enable perl) || die "econf failed"
- emake || die "emake failed"
+src_configure() {
+ econf $(use_enable perl)
}
src_install() {
- emake DESTDIR="${D}" install || die
+ default
- doman doc/pork.1 || die
+ doman doc/pork.1
insinto /usr/share/pork/examples
- doins examples/blist.txt || die
-
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README STYLE TODO QUICK_START || die
-}
+ doins examples/blist.txt
-pkg_postinst() {
- elog "Be aware that the syntax for IRC connections has"
- elog "changed. Read ${HOMEPAGE}/stuff/pork.news"
- elog "for details."
+ dodoc AUTHORS ChangeLog INSTALL NEWS README STYLE TODO QUICK_START
}