summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2007-01-27 00:47:05 +0000
committerOlivier Crête <tester@gentoo.org>2007-01-27 00:47:05 +0000
commitd6c6d0bfff6b14fc0116cdd99754cf7e43505022 (patch)
tree57c7cf4f963be49a3c8f55db3e0344f73cd35e8c /net-im
parentwhitespace (diff)
downloadgentoo-2-d6c6d0bfff6b14fc0116cdd99754cf7e43505022.tar.gz
gentoo-2-d6c6d0bfff6b14fc0116cdd99754cf7e43505022.tar.bz2
gentoo-2-d6c6d0bfff6b14fc0116cdd99754cf7e43505022.zip
Add patch to fix mono from SF.net bug #1639901 and gentoo bug #162930
(Portage version: 2.1.1-r2)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/ChangeLog7
-rw-r--r--net-im/gaim/files/gaim-2.0.0_beta6-mono-api-change-update.patch58
-rw-r--r--net-im/gaim/gaim-2.0.0_beta6.ebuild15
3 files changed, 72 insertions, 8 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index 00e2f1f7f77f..c0dd7a92a2e4 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gaim
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.431 2007/01/21 23:32:32 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.432 2007/01/27 00:47:05 tester Exp $
+
+ 27 Jan 2007; Olivier Crête <tester@gentoo.org>
+ +files/gaim-2.0.0_beta6-mono-api-change-update.patch,
+ gaim-2.0.0_beta6.ebuild:
+ Add patch to fix mono from SF.net bug #1639901 and gentoo bug #162930
*gaim-2.0.0_beta6 (21 Jan 2007)
diff --git a/net-im/gaim/files/gaim-2.0.0_beta6-mono-api-change-update.patch b/net-im/gaim/files/gaim-2.0.0_beta6-mono-api-change-update.patch
new file mode 100644
index 000000000000..22866bad6537
--- /dev/null
+++ b/net-im/gaim/files/gaim-2.0.0_beta6-mono-api-change-update.patch
@@ -0,0 +1,58 @@
+--- libgaim/plugins/mono/MPlugin.cs.orig 2007-01-19 15:23:33.000000000 -0600
++++ libgaim/plugins/mono/MPlugin.cs 2007-01-19 15:36:15.000000000 -0600
+@@ -1,7 +1,14 @@
+ using Gaim;
+
+-public class MPlugin : GaimPlugin
++public class MPlugin : Plugin
+ {
++ private static PluginInfo info = new PluginInfo("C# Plugin", "0.1", "Test C# Plugin", "Longer Description", "Eoin Coffey", "urled");
++
++ public MPlugin()
++ : base(info)
++ {
++ }
++
+ public void HandleSig(object[] args)
+ {
+ Buddy buddy = (Buddy)args[0];
+@@ -28,9 +35,4 @@
+ {
+ Debug.debug(Debug.INFO, "mplug", "destroying...\n");
+ }
+-
+- public override GaimPluginInfo Info()
+- {
+- return new GaimPluginInfo("C# Plugin", "0.1", "Test C# Plugin", "Longer Description", "Eoin Coffey", "urled");
+- }
+ }
+--- libgaim/plugins/mono/GetBuddyBack.cs.orig 2007-01-19 15:36:33.000000000 -0600
++++ libgaim/plugins/mono/GetBuddyBack.cs 2007-01-19 15:37:58.000000000 -0600
+@@ -1,7 +1,14 @@
+ using Gaim;
+
+-public class GetBuddyBack : GaimPlugin
++public class GetBuddyBack : Plugin
+ {
++ private static PluginInfo info = new PluginInfo("C# Get Buddy Back", "0.1", "Prints when a Buddy returns", "Longer Description", "Eoin Coffey", "urled");
++
++ public GetBuddyBack()
++ : base (info)
++ {
++ }
++
+ public void HandleSig(object[] args)
+ {
+ Buddy buddy = (Buddy)args[0];
+@@ -24,9 +31,4 @@
+ public override void Destroy()
+ {
+ }
+-
+- public override GaimPluginInfo Info()
+- {
+- return new GaimPluginInfo("C# Get Buddy Back", "0.1", "Prints when a Buddy returns", "Longer Description", "Eoin Coffey", "urled");
+- }
+ }
+
+
diff --git a/net-im/gaim/gaim-2.0.0_beta6.ebuild b/net-im/gaim/gaim-2.0.0_beta6.ebuild
index eb02839bf4e6..3153ddd1e2bf 100644
--- a/net-im/gaim/gaim-2.0.0_beta6.ebuild
+++ b/net-im/gaim/gaim-2.0.0_beta6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-2.0.0_beta6.ebuild,v 1.1 2007/01/21 23:32:32 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-2.0.0_beta6.ebuild,v 1.2 2007/01/27 00:47:05 tester Exp $
inherit flag-o-matic eutils toolchain-funcs multilib mono autotools perl-app gnome2
@@ -14,8 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="avahi bonjour cjk crypt dbus debug doc eds gadu gnutls gstreamer meanwhile nls perl silc startup-notification tcl tk xscreensaver custom-cflags spell ssl qq msn gadu"
-IUSE="${IUSE} gtk sasl console groupwise"
-# removed IUSE mono because it doesnt build
+IUSE="${IUSE} gtk sasl console groupwise mono"
RDEPEND="
bonjour? ( !avahi? ( net-misc/howl )
@@ -50,8 +49,8 @@ RDEPEND="
gstreamer? ( >=media-libs/gstreamer-0.10 )
sasl? ( >=dev-libs/cyrus-sasl-2 )
doc? ( app-doc/doxygen )
- dev-libs/libxml2"
-# mono? ( dev-lang/mono )
+ dev-libs/libxml2
+ mono? ( dev-lang/mono )"
DEPEND="$RDEPEND
dev-util/pkgconfig
@@ -150,6 +149,9 @@ pkg_setup() {
src_unpack() {
gnome2_src_unpack
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-mono-api-change-update.patch
}
src_compile() {
@@ -235,10 +237,9 @@ src_compile() {
$(use_enable gstreamer) \
$(use_enable sasl cyrus-sasl ) \
$(use_enable doc doxygen) \
- --disable-mono \
+ $(use_enable mono) \
"--with-dynamic-prpls=${DYNAMIC_PRPLS}" \
${myconf} || die "Configuration failed"
-# $(use_enable mono) \
# This is a tempory fix until Makefile is fixed!!
if use mono; then