summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2011-09-30 21:41:27 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2011-09-30 21:41:27 +0000
commitfd2861ff0f29d2e7ee53d8cd9352cb5eca3b721d (patch)
tree39e14d8ec0518102a8285e7f963618655fa13894 /net-im
parentFix LaTeX error in documentation, bug 383051 (diff)
downloadgentoo-2-fd2861ff0f29d2e7ee53d8cd9352cb5eca3b721d.tar.gz
gentoo-2-fd2861ff0f29d2e7ee53d8cd9352cb5eca3b721d.tar.bz2
gentoo-2-fd2861ff0f29d2e7ee53d8cd9352cb5eca3b721d.zip
Update deps, bug 385009, by Bartosz Brachaczek. Favor media-libs/phonon over outdated x11-libs/qt-phonon. Add sdk USE flag.
(Portage version: 2.2.0_alpha60/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/kadu/ChangeLog9
-rw-r--r--net-im/kadu/files/kadu-0.10.0-sdk-cmake.patch46
-rw-r--r--net-im/kadu/kadu-0.10.0-r1.ebuild109
-rw-r--r--net-im/kadu/metadata.xml2
4 files changed, 164 insertions, 2 deletions
diff --git a/net-im/kadu/ChangeLog b/net-im/kadu/ChangeLog
index e55c279f2207..b0636f72f16b 100644
--- a/net-im/kadu/ChangeLog
+++ b/net-im/kadu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/kadu
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/ChangeLog,v 1.109 2011/09/29 20:37:27 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/ChangeLog,v 1.110 2011/09/30 21:41:27 reavertm Exp $
+
+*kadu-0.10.0-r1 (30 Sep 2011)
+
+ 30 Sep 2011; Maciej Mrozowski <reavertm@gentoo.org> +kadu-0.10.0-r1.ebuild,
+ +files/kadu-0.10.0-sdk-cmake.patch, metadata.xml:
+ Update deps, bug 385009, by Bartosz Brachaczek. Favor media-libs/phonon over
+ outdated x11-libs/qt-phonon. Add sdk USE flag.
*kadu-0.10.0 (29 Sep 2011)
diff --git a/net-im/kadu/files/kadu-0.10.0-sdk-cmake.patch b/net-im/kadu/files/kadu-0.10.0-sdk-cmake.patch
new file mode 100644
index 000000000000..64855367b5ad
--- /dev/null
+++ b/net-im/kadu/files/kadu-0.10.0-sdk-cmake.patch
@@ -0,0 +1,46 @@
+diff -ruN kadu-0.10.0/cmake/FindKadu.cmake new/cmake/FindKadu.cmake
+--- kadu-0.10.0/cmake/FindKadu.cmake 2011-08-24 08:43:41.000000000 +0200
++++ new/cmake/FindKadu.cmake 2011-09-30 23:26:39.043004993 +0200
+@@ -133,10 +133,12 @@
+ set (KADU_PLUGINS_DIR ${KADU_DATA_DIR}/plugins)
+
+ macro (kadu_api_directories INCLUDE_DIR)
+- foreach (ARG ${ARGN})
+- file (GLOB API_HEADERS ${CMAKE_CURRENT_SOURCE_DIR}/${ARG}/*.h)
+- install (FILES ${API_HEADERS} DESTINATION ${KADU_INSTALL_INCLUDE_DIR}/kadu/${INCLUDE_DIR}/${ARG})
+- endforeach (ARG)
++ if (INSTALL_SDK)
++ foreach (ARG ${ARGN})
++ file (GLOB API_HEADERS ${CMAKE_CURRENT_SOURCE_DIR}/${ARG}/*.h)
++ install (FILES ${API_HEADERS} DESTINATION ${KADU_INSTALL_INCLUDE_DIR}/kadu/${INCLUDE_DIR}/${ARG})
++ endforeach (ARG)
++ endif (INSTALL_SDK)
+ endmacro (kadu_api_directories)
+
+ macro (kadu_configuration)
+diff -ruN kadu-0.10.0/CMakeLists.txt new/CMakeLists.txt
+--- kadu-0.10.0/CMakeLists.txt 2011-08-24 08:43:41.000000000 +0200
++++ new/CMakeLists.txt 2011-09-30 23:28:24.979005031 +0200
+@@ -7,7 +7,7 @@
+ option (BUILD_PLUGINS "Switch to Off if you do not want to build plugins" ON)
+
+ # configuration
+-option (INSTALL_CMAKE_MODULE "Install cmake modules" ON)
++option (INSTALL_SDK "Install SDK (API headers, cmake modules)" ON)
+ if (UNIX)
+ option (SIG_HANDLING_ENABLED "Define if you want system signals handling" ON)
+ if (UNIX AND NOT APPLE)
+@@ -105,11 +105,11 @@
+ include (cmake/FindKadu.cmake)
+ include_directories (${CMAKE_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_SOURCE_DIR}/kadu-core ${QT_INCLUDES})
+
+-if (INSTALL_CMAKE_MODULE)
++if (INSTALL_SDK)
+ install (FILES cmake/FindKadu.cmake DESTINATION ${KADU_CMAKE_MODULES_DIR})
+ install (PROGRAMS translations/plugintsupdate.sh DESTINATION ${KADU_PLUGINS_DIR}/sdk)
+ install (FILES translations/configuration-ui.xsl DESTINATION ${KADU_PLUGINS_DIR}/sdk)
+-endif (INSTALL_CMAKE_MODULE)
++endif (INSTALL_SDK)
+
+ # build
+ configure_file (${CMAKE_SOURCE_DIR}/kadu-config.h.cmake ${CMAKE_BINARY_DIR}/kadu-config.h)
diff --git a/net-im/kadu/kadu-0.10.0-r1.ebuild b/net-im/kadu/kadu-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..ab926f2bc157
--- /dev/null
+++ b/net-im/kadu/kadu-0.10.0-r1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/kadu-0.10.0-r1.ebuild,v 1.1 2011/09/30 21:41:27 reavertm Exp $
+
+EAPI="4"
+
+inherit base cmake-utils flag-o-matic
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="An open source Gadu-Gadu and Jabber/XMPP protocol Instant Messenger client."
+HOMEPAGE="http://www.kadu.net"
+SRC_URI="http://download.kadu.im/stable/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="+gadu phonon sdk speech spell +ssl xmpp"
+REQUIRED_USE="
+ || (
+ gadu
+ xmpp
+ )
+"
+COMMON_DEPEND="
+ >=app-crypt/qca-2.0.0-r2
+ >=media-libs/libsndfile-1.0
+ >=net-libs/libgadu-1.11.0[threads]
+ x11-libs/libXfixes
+ x11-libs/libXScrnSaver
+ >=x11-libs/qt-dbus-4.7.0:4
+ >=x11-libs/qt-gui-4.7.0:4
+ >=x11-libs/qt-script-4.7.0:4
+ >=x11-libs/qt-sql-4.7.0:4[sqlite]
+ >=x11-libs/qt-svg-4.7.0:4
+ >=x11-libs/qt-webkit-4.7.0:4
+ gadu? ( >=x11-libs/qt-xmlpatterns-4.7.0:4 )
+ phonon? (
+ media-libs/phonon
+ >=x11-libs/qt-phonon-4.7.0:4
+ )
+ spell? ( app-text/enchant )
+ xmpp? (
+ net-dns/libidn
+ sys-libs/zlib
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ x11-proto/fixesproto
+ x11-proto/scrnsaverproto
+"
+RDEPEND="${COMMON_DEPEND}
+ speech? ( app-accessibility/powiedz )
+ ssl? ( app-crypt/qca-ossl:2 )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-cmake.patch"
+ "${FILESDIR}/${P}-sdk-cmake.patch"
+)
+
+PLUGINS='amarok1_mediaplayer antistring auto_hide autoaway autoresponder
+autostatus cenzor chat_notify config_wizard desktop_docking docking exec_notify
+ext_sound falf_mediaplayer filedesc firewall freedesktop_notify hints history
+idle imagelink last_seen mediaplayer mprisplayer_mediaplayer pcspeaker qt4_docking
+qt4_docking_notify screenshot simpleview single_window sms sound sql_history tabs
+word_fix'
+
+src_configure() {
+ # Filter out dangerous flags
+ filter-flags -fno-rtti
+ strip-unsupported-flags
+
+ # Ensure -DQT_NO_DEBUG is added
+ append-cppflags -DQT_NO_DEBUG
+
+ # Plugin selection
+ if use gadu; then
+ PLUGINS+=' gadu_protocol history_migration profiles_import'
+ fi
+
+ use xmpp && PLUGINS+=' jabber_protocol'
+ use phonon && PLUGINS+=' phonon_sound'
+ use speech && PLUGINS+=' speech'
+ use spell && PLUGINS+=' spellchecker'
+
+ if use ssl; then
+ PLUGINS+=' encryption_ng encryption_ng_simlite'
+ fi
+
+ # COMPILE_PLUGINS isn't the most flexible..
+ local compile_plugins=
+ for plugin in ${PLUGINS}; do
+ [[ -n ${compile_plugins} ]] && compile_plugins+=','
+ compile_plugins+="${plugin}"
+ done
+ unset PLUGINS
+
+ # Configure package
+ local mycmakeargs=(
+ -DBUILD_DESCRIPTION='Gentoo Linux'
+ -DCOMPILE_PLUGINS="${compile_plugins}"
+ $(cmake-utils_use sdk INSTALL_SDK)
+ $(cmake-utils_use_with spell ENCHANT)
+ )
+ unset compile_plugins
+
+ cmake-utils_src_configure
+}
diff --git a/net-im/kadu/metadata.xml b/net-im/kadu/metadata.xml
index a3fa976cd08c..bbeb09ed84fc 100644
--- a/net-im/kadu/metadata.xml
+++ b/net-im/kadu/metadata.xml
@@ -14,7 +14,7 @@
<use>
<flag name="gadu">Enables Gadu communication protocol</flag>
<flag name="phonon">Enables phonon audio plugin</flag>
+ <flag name="sdk">Install Kadu SDK (cmake module, API headers)</flag>
<flag name="speech">Enables speech module</flag>
- <!-- <flag name="tlen">Enables Tlen.pl communication protocol</flag> -->
</use>
</pkgmetadata>