summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-07-13 22:58:15 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-07-13 22:58:15 +0000
commitc23ede6424735fd0dadb0ceb67f194f236f05ee5 (patch)
tree10044c42bec1286b0bbbfa43e88dccd945861881 /net-irc/conspire
parentStable on x86 wrt bug #231422 (diff)
downloadgentoo-2-c23ede6424735fd0dadb0ceb67f194f236f05ee5.tar.gz
gentoo-2-c23ede6424735fd0dadb0ceb67f194f236f05ee5.tar.bz2
gentoo-2-c23ede6424735fd0dadb0ceb67f194f236f05ee5.zip
Version bump, fixes bug #229277 filed by Daniel Pielmeier <daniel.pielmeier@googlemail.com>.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc9-00134-g3b5c6b8-dirty x86_64)
Diffstat (limited to 'net-irc/conspire')
-rw-r--r--net-irc/conspire/ChangeLog8
-rw-r--r--net-irc/conspire/conspire-0.20_beta4.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/net-irc/conspire/ChangeLog b/net-irc/conspire/ChangeLog
index 650e7daffb96..f213d135ff32 100644
--- a/net-irc/conspire/ChangeLog
+++ b/net-irc/conspire/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/conspire
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/ChangeLog,v 1.6 2008/06/22 20:30:22 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/ChangeLog,v 1.7 2008/07/13 22:58:15 chainsaw Exp $
+
+*conspire-0.20_beta4 (13 Jul 2008)
+
+ 13 Jul 2008; <chainsaw@gentoo.org> +conspire-0.20_beta4.ebuild:
+ Version bump, fixes bug #229277 filed by Daniel Pielmeier
+ <daniel.pielmeier@googlemail.com>.
*conspire-0.20_beta2 (22 Jun 2008)
diff --git a/net-irc/conspire/conspire-0.20_beta4.ebuild b/net-irc/conspire/conspire-0.20_beta4.ebuild
new file mode 100644
index 000000000000..42523a88742f
--- /dev/null
+++ b/net-irc/conspire/conspire-0.20_beta4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/conspire-0.20_beta4.ebuild,v 1.1 2008/07/13 22:58:15 chainsaw Exp $
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="A high quality IRC client which uses a multitude of interfaces"
+HOMEPAGE="http://www.nenolod.net/conspire/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
+IUSE="python gnutls ipv6 nls mmx socks5 dbus"
+DEPEND="nls? ( dev-util/intltool )"
+RDEPEND=">=dev-libs/libmowgli-0.6.0
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.14
+ x11-libs/libnotify
+ x11-libs/libsexy
+ dbus? ( >=dev-libs/dbus-glib-0.60 )
+ python? ( >=dev-lang/python-2.2 )"
+
+src_compile() {
+ econf \
+ $(use_enable socks5 socks) \
+ $(use_enable ipv6) \
+ $(use_enable gnutls) \
+ $(use_enable python) \
+ $(use_enable mmx) \
+ $(use_enable nls) \
+ $(use_enable dbus) \
+ --enable-spell=libsexy \
+ --enable-regex \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS TODO
+}