summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-05 17:38:40 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-05 17:38:40 +0000
commitef6ad4c99bc671ebaf3cccf8f8485fdf40aa5f9b (patch)
treeadb4fced9648c698fcb72037fdee098da0be302a /net-irc/conspire
parentx86 stable wrt bug #353373 (diff)
downloadgentoo-2-ef6ad4c99bc671ebaf3cccf8f8485fdf40aa5f9b.tar.gz
gentoo-2-ef6ad4c99bc671ebaf3cccf8f8485fdf40aa5f9b.tar.bz2
gentoo-2-ef6ad4c99bc671ebaf3cccf8f8485fdf40aa5f9b.zip
Fix building with x11-libs/libnotify >= 0.7. Enable USE="gnutls" by default until #339204 is solved.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/conspire')
-rw-r--r--net-irc/conspire/ChangeLog9
-rw-r--r--net-irc/conspire/conspire-1.0.1.ebuild36
-rw-r--r--net-irc/conspire/files/conspire-1.0.1-libnotify-0.7.patch27
3 files changed, 56 insertions, 16 deletions
diff --git a/net-irc/conspire/ChangeLog b/net-irc/conspire/ChangeLog
index 303c18ec0aeb..5453c6bfc86e 100644
--- a/net-irc/conspire/ChangeLog
+++ b/net-irc/conspire/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/conspire
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/ChangeLog,v 1.15 2010/09/26 21:50:45 chainsaw Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/ChangeLog,v 1.16 2011/02/05 17:38:40 ssuominen Exp $
+
+ 05 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> conspire-1.0.1.ebuild,
+ +files/conspire-1.0.1-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7. Enable USE="gnutls" by default
+ until #339204 is solved.
26 Sep 2010; <chainsaw@gentoo.org> -conspire-0.12.0.ebuild,
-conspire-0.13.1.ebuild, -conspire-1.0_beta1.ebuild:
diff --git a/net-irc/conspire/conspire-1.0.1.ebuild b/net-irc/conspire/conspire-1.0.1.ebuild
index 5a5b0ffa02e4..4c860e767bea 100644
--- a/net-irc/conspire/conspire-1.0.1.ebuild
+++ b/net-irc/conspire/conspire-1.0.1.ebuild
@@ -1,29 +1,39 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/conspire-1.0.1.ebuild,v 1.1 2010/09/26 21:39:10 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/conspire-1.0.1.ebuild,v 1.2 2011/02/05 17:38:40 ssuominen Exp $
+EAPI=2
inherit eutils
-MY_P="${P/_/-}"
-S="${WORKDIR}/${MY_P}"
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+
DESCRIPTION="A high quality IRC client which uses a multitude of interfaces"
HOMEPAGE="http://www.nenolod.net/conspire/"
SRC_URI="http://distfiles.atheme.org/${MY_P}.tbz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
-IUSE="python gnutls ipv6 nls mmx socks5 dbus"
-DEPEND="nls? ( dev-util/intltool )
- dev-util/pkgconfig"
+# Enable gnutls by default until bug 339204 is solved.
+IUSE="python +gnutls ipv6 nls mmx socks5 dbus"
+
RDEPEND=">=dev-libs/libmowgli-0.6.0
- >=x11-libs/gtk+-2.10
+ >=x11-libs/gtk+-2.10:2
>=dev-libs/glib-2.14
x11-libs/libnotify
x11-libs/libsexy
- dbus? ( >=dev-libs/dbus-glib-0.60 )
+ dbus? ( >=dev-libs/dbus-glib-0.88 )
python? ( >=dev-lang/python-2.2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( dev-util/intltool )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+}
-src_compile() {
+src_configure() {
econf \
$(use_enable socks5 socks) \
$(use_enable ipv6) \
@@ -33,12 +43,10 @@ src_compile() {
$(use_enable nls) \
$(use_enable dbus) \
--enable-spell=libsexy \
- --enable-regex \
- || die
- emake || die "emake failed"
+ --enable-regex
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install || die
dodoc NEWS TODO
}
diff --git a/net-irc/conspire/files/conspire-1.0.1-libnotify-0.7.patch b/net-irc/conspire/files/conspire-1.0.1-libnotify-0.7.patch
new file mode 100644
index 000000000000..ba1bc72e48bd
--- /dev/null
+++ b/net-irc/conspire/files/conspire-1.0.1-libnotify-0.7.patch
@@ -0,0 +1,27 @@
+--- src/fe-gtk/tray.c
++++ src/fe-gtk/tray.c
+@@ -16,6 +16,9 @@
+ #include <gtk/gtk.h>
+ #ifndef _WIN32
+ # include <libnotify/notify.h>
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
+ #endif
+
+ typedef enum /* current icon status */
+@@ -134,8 +137,13 @@
+ return;
+
+ stext = strip_color(text, -1, STRIP_ALL);
+- n = notify_notification_new(title, stext, NULL, NULL);
++ n = notify_notification_new(title, stext, NULL
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , NULL);
+ notify_notification_attach_to_status_icon(n, sticon);
++#endif
+ notify_notification_set_timeout(n, 20000);
+ notify_notification_show(n, NULL);
+