summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjarke Istrup Pedersen <gurligebis@gentoo.org>2010-10-10 18:30:09 +0000
committerBjarke Istrup Pedersen <gurligebis@gentoo.org>2010-10-10 18:30:09 +0000
commit32a7b0c266ed4890820442ca3573e57ab3f4b072 (patch)
tree1a3c134af7975d41661f27e575963ca9d91c3ff4 /net-irc/psybnc
parentUpdate EAPI. Fix dependencies. (diff)
downloadgentoo-2-32a7b0c266ed4890820442ca3573e57ab3f4b072.tar.gz
gentoo-2-32a7b0c266ed4890820442ca3573e57ab3f4b072.tar.bz2
gentoo-2-32a7b0c266ed4890820442ca3573e57ab3f4b072.zip
Fixing LDFLAGS problem
(Portage version: 2.2_rc91/cvs/Linux i686)
Diffstat (limited to 'net-irc/psybnc')
-rw-r--r--net-irc/psybnc/ChangeLog6
-rw-r--r--net-irc/psybnc/files/ldflags-fix.patch12
-rw-r--r--net-irc/psybnc/psybnc-2.3.2.9-r2.ebuild33
3 files changed, 36 insertions, 15 deletions
diff --git a/net-irc/psybnc/ChangeLog b/net-irc/psybnc/ChangeLog
index 0aa6a293872d..29c3bfdc827d 100644
--- a/net-irc/psybnc/ChangeLog
+++ b/net-irc/psybnc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/psybnc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/psybnc/ChangeLog,v 1.15 2010/09/26 17:28:39 gurligebis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/psybnc/ChangeLog,v 1.16 2010/10/10 18:30:09 gurligebis Exp $
+
+ 10 Oct 2010; <gurligebis@gentoo.org> psybnc-2.3.2.9-r2.ebuild,
+ +files/ldflags-fix.patch:
+ Really fixing LDFLAGS problem this time.
26 Sep 2010; <gurligebis@gentoo.org> -psybnc-2.3.2.7-r2.ebuild:
Removing old version
diff --git a/net-irc/psybnc/files/ldflags-fix.patch b/net-irc/psybnc/files/ldflags-fix.patch
new file mode 100644
index 000000000000..c06f3e48b32f
--- /dev/null
+++ b/net-irc/psybnc/files/ldflags-fix.patch
@@ -0,0 +1,12 @@
+diff -aurp a/tools/autoconf.c b/tools/autoconf.c
+--- a/tools/autoconf.c 2010-10-10 20:25:29.295001235 +0000
++++ b/tools/autoconf.c 2010-10-10 20:26:02.738999569 +0000
+@@ -449,7 +449,7 @@ int main()
+ fprintf(makefile,"TARGET = psybnc\n");
+ fprintf(makefile,"\n");
+ fprintf(makefile,"all: $(OBJS)\n");
+- fprintf(makefile," $(CC) -o $(TARGET) $(CFLAGS) $(OBJS) $(LIBS)\n");
++ fprintf(makefile," $(CC) -o $(TARGET) $(CFLAGS) $(LDFLAGS) $(OBJS) $(LIBS)\n");
+ if(ssl==0)
+ {
+ if(!fexists("key/psybnc.cert.pem")) /* only create, if not exist */
diff --git a/net-irc/psybnc/psybnc-2.3.2.9-r2.ebuild b/net-irc/psybnc/psybnc-2.3.2.9-r2.ebuild
index ce92c88c1129..b6e87e920c2a 100644
--- a/net-irc/psybnc/psybnc-2.3.2.9-r2.ebuild
+++ b/net-irc/psybnc/psybnc-2.3.2.9-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/psybnc/psybnc-2.3.2.9-r2.ebuild,v 1.4 2010/09/26 17:26:42 gurligebis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/psybnc/psybnc-2.3.2.9-r2.ebuild,v 1.5 2010/10/10 18:30:09 gurligebis Exp $
+
+EAPI="2"
inherit eutils versionator toolchain-funcs flag-o-matic
MY_PV="$(replace_version_separator 3 -)"
@@ -29,7 +31,23 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ # Useless files
+ rm -f */INFO
+
+ # Pretend we already have a certificate, we generate it in pkg_config
+ mkdir key
+ touch key/psybnc.cert.pem
+
+ if [[ -f ${ROOT}/usr/share/psybnc/salt.h ]]
+ then
+ einfo "Using existing salt.h for password encryption"
+ cp "${ROOT}"/usr/share/psybnc/salt.h salt.h
+ fi
+}
+
+src_prepare() {
epatch "${FILESDIR}/compile.diff"
+ epatch "${FILESDIR}/ldflags-fix.patch"
# add oidentd
use oidentd && epatch "${FILESDIR}/${P}-oidentd.patch"
@@ -40,21 +58,8 @@ src_unpack() {
# add multinetwork support
use multinetwork && epatch "${FILESDIR}/${P}-multinetwork.patch"
- # Useless files
- rm -f */INFO
-
# Prevent stripping the binary
sed -i -e "/@strip/ d" tools/autoconf.c
-
- # Pretend we already have a certificate, we generate it in pkg_config
- mkdir key
- touch key/psybnc.cert.pem
-
- if [[ -f ${ROOT}/usr/share/psybnc/salt.h ]]
- then
- einfo "Using existing salt.h for password encryption"
- cp "${ROOT}"/usr/share/psybnc/salt.h salt.h
- fi
}
src_compile() {