summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-08-26 18:06:01 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-08-26 18:06:01 +0000
commit5333cc5950bb213693f0f6b8333ec276de532b28 (patch)
tree581f5e347760eaca389bd652ae68a492e60fa9f4 /net-irc/quassel
parentFix mozilla-weave mask (diff)
downloadgentoo-2-5333cc5950bb213693f0f6b8333ec276de532b28.tar.gz
gentoo-2-5333cc5950bb213693f0f6b8333ec276de532b28.tar.bz2
gentoo-2-5333cc5950bb213693f0f6b8333ec276de532b28.zip
Add first rc version of upcoming 0.5 series.
Add 0.4.3-r50 which has kde4 optional support and adjust 0.4.3 to not depend on kde4 so it could be stabilised. (Portage version: 2.2_rc38/cvs/Linux i686)
Diffstat (limited to 'net-irc/quassel')
-rw-r--r--net-irc/quassel/ChangeLog15
-rw-r--r--net-irc/quassel/quassel-0.4.3-r50.ebuild122
-rw-r--r--net-irc/quassel/quassel-0.4.3.ebuild8
-rw-r--r--net-irc/quassel/quassel-0.5_rc1.ebuild114
4 files changed, 253 insertions, 6 deletions
diff --git a/net-irc/quassel/ChangeLog b/net-irc/quassel/ChangeLog
index b1ae4c7ab6b2..7deaa97cd1a8 100644
--- a/net-irc/quassel/ChangeLog
+++ b/net-irc/quassel/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for net-irc/quassel
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.53 2009/08/26 14:35:21 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.54 2009/08/26 18:06:01 scarabeus Exp $
+
+*quassel-0.4.3-r50 (26 Aug 2009)
+
+ 26 Aug 2009; Tomáš Chvátal <scarabeus@gentoo.org> quassel-0.4.3.ebuild,
+ +quassel-0.4.3-r50.ebuild:
+ Add 0.4.3-r50 which has kde4 optional support and adjust 0.4.3 to not
+ depend on kde4 so it could be stabilised.
+
+*quassel-0.5_rc1 (26 Aug 2009)
+
+ 26 Aug 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ +quassel-0.5_rc1.ebuild:
+ Add first rc version of upcoming 0.5 series.
*quassel-0.4.3 (26 Aug 2009)
diff --git a/net-irc/quassel/quassel-0.4.3-r50.ebuild b/net-irc/quassel/quassel-0.4.3-r50.ebuild
new file mode 100644
index 000000000000..699dc4359e1c
--- /dev/null
+++ b/net-irc/quassel/quassel-0.4.3-r50.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.4.3-r50.ebuild,v 1.1 2009/08/26 18:06:01 scarabeus Exp $
+
+EAPI="2"
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Qt4/KDE4 IRC client suppporting a remote daemon for 24/7 connectivity."
+HOMEPAGE="http://quassel-irc.org/"
+SRC_URI="http://quassel-irc.org/pub/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="dbus debug kde monolithic +oxygen phonon +server +ssl webkit +X"
+
+LANGS="cs da de fr hu nb_NO ru sl tr"
+for l in ${LANGS}; do
+ IUSE="${IUSE} linguas_${l}"
+done
+
+RDEPEND="
+ dbus? ( x11-libs/qt-dbus:4 )
+ monolithic? (
+ dev-db/sqlite[threadsafe]
+ x11-libs/qt-sql:4[sqlite]
+ x11-libs/qt-script:4
+ x11-libs/qt-gui:4
+ kde? ( >=kde-base/kdelibs-4.1 )
+ phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
+ webkit? ( x11-libs/qt-webkit:4 )
+ )
+ !monolithic? (
+ server? (
+ dev-db/sqlite[threadsafe]
+ x11-libs/qt-sql:4[sqlite]
+ x11-libs/qt-script:4
+ )
+ X? (
+ x11-libs/qt-gui:4
+ kde? ( >=kde-base/kdelibs-4.1 )
+ phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
+ webkit? ( x11-libs/qt-webkit:4 )
+ )
+ )
+ ssl? ( x11-libs/qt-core:4[ssl] )
+ "
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog README"
+
+pkg_setup() {
+ if ! use monolithic && ! use server && ! use X ; then
+ eerror "You have to build at least one of the monolithic client (USE=monolithic),"
+ eerror "the quasselclient (USE=X) or the quasselcore (USE=server)."
+ die "monolithic, server and X flag unset."
+ fi
+}
+
+src_configure() {
+ local MY_LANGUAGES=""
+ for i in ${LINGUAS}; do
+ MY_LANGUAGES="${i},${MY_LANGUAGES}"
+ done
+
+ local mycmakeargs="
+ $(cmake-utils_use_want X QTCLIENT)
+ $(cmake-utils_use_want server CORE)
+ $(cmake-utils_use_want monolithic MONO)
+ $(cmake-utils_use_with webkit WEBKIT)
+ $(cmake-utils_use_with phonon PHONON)
+ $(cmake-utils_use_with kde KDE)
+ $(cmake-utils_use_with dbus DBUS)
+ $(cmake-utils_use_with ssl OPENSSL)
+ $(cmake-utils_use_with oxygen OXYGEN)
+ -DEMBED_DATA=OFF
+ -DLINGUAS=${MY_LANGUAGES}
+ "
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use server ; then
+ newinitd "${FILESDIR}"/quasselcore-2.init quasselcore || die "newinitd failed"
+ newconfd "${FILESDIR}"/quasselcore-2.conf quasselcore || die "newconfd failed"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/quassel.logrotate" quassel
+
+ insinto /usr/share/doc/${PF}
+ doins "${S}"/scripts/manageusers.py || die "installing manageusers.py failed"
+ fi
+}
+
+pkg_postinst() {
+ if use server ; then
+ ewarn
+ ewarn "In order to use the quassel init script you must set the"
+ ewarn "QUASSEL_USER variable in ${ROOT%/}/etc/conf.d/quasselcore to your username."
+ ewarn "Note: This is the user who runs the quasselcore and is independent"
+ ewarn "from the users you set up in the quasselclient."
+ elog
+ elog "Adding more than one user or changing username/password is not"
+ elog "possible via the quasselclient yet. If you need to do these things"
+ elog "you have to use the manageusers.py script, which has been installed in"
+ elog "${ROOT%/}/usr/share/doc/${PF}".
+ elog "http://bugs.quassel-irc.org/wiki/quassel-irc/Manage_core_users provides"
+ elog "some information on using the script."
+ elog "To be sure nothing bad will happen you need to stop the quasselcore"
+ elog "before adding more users."
+ fi
+
+ if ( use server || use monolithic ) && use ssl ; then
+ elog
+ elog "Information on how to enable SSL support for client/core connections"
+ elog "is available at http://bugs.quassel-irc.org/wiki/quassel-irc."
+ fi
+}
diff --git a/net-irc/quassel/quassel-0.4.3.ebuild b/net-irc/quassel/quassel-0.4.3.ebuild
index 8972badc0fde..98124e14346b 100644
--- a/net-irc/quassel/quassel-0.4.3.ebuild
+++ b/net-irc/quassel/quassel-0.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.4.3.ebuild,v 1.1 2009/08/26 14:35:21 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.4.3.ebuild,v 1.2 2009/08/26 18:06:01 scarabeus Exp $
EAPI="2"
@@ -13,7 +13,7 @@ SRC_URI="http://quassel-irc.org/pub/${P}.tar.bz2"
LICENSE="GPL-3"
KEYWORDS="~amd64 ~x86"
SLOT="0"
-IUSE="dbus debug kde monolithic +oxygen phonon +server +ssl webkit +X"
+IUSE="dbus debug monolithic +oxygen phonon +server +ssl webkit +X"
LANGS="cs da de fr hu nb_NO ru sl tr"
for l in ${LANGS}; do
@@ -27,7 +27,6 @@ RDEPEND="
x11-libs/qt-sql:4[sqlite]
x11-libs/qt-script:4
x11-libs/qt-gui:4
- kde? ( >=kde-base/kdelibs-4.1 )
phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
webkit? ( x11-libs/qt-webkit:4 )
)
@@ -39,7 +38,6 @@ RDEPEND="
)
X? (
x11-libs/qt-gui:4
- kde? ( >=kde-base/kdelibs-4.1 )
phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
webkit? ( x11-libs/qt-webkit:4 )
)
@@ -65,12 +63,12 @@ src_configure() {
done
local mycmakeargs="
+ -DWITH_KDE=OFF
$(cmake-utils_use_want X QTCLIENT)
$(cmake-utils_use_want server CORE)
$(cmake-utils_use_want monolithic MONO)
$(cmake-utils_use_with webkit WEBKIT)
$(cmake-utils_use_with phonon PHONON)
- $(cmake-utils_use_with kde KDE)
$(cmake-utils_use_with dbus DBUS)
$(cmake-utils_use_with ssl OPENSSL)
$(cmake-utils_use_with oxygen OXYGEN)
diff --git a/net-irc/quassel/quassel-0.5_rc1.ebuild b/net-irc/quassel/quassel-0.5_rc1.ebuild
new file mode 100644
index 000000000000..464a3a2815b0
--- /dev/null
+++ b/net-irc/quassel/quassel-0.5_rc1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.5_rc1.ebuild,v 1.1 2009/08/26 18:06:01 scarabeus Exp $
+
+EAPI="2"
+
+MY_P="${P/_/-}"
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Qt4/KDE4 IRC client suppporting a remote daemon for 24/7 connectivity."
+HOMEPAGE="http://quassel-irc.org/"
+SRC_URI="http://quassel-irc.org/pub/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="dbus debug kde monolithic +oxygen phonon postgres +server +ssl webkit +X"
+
+LANGS="cs da de fr hu it nb_NO ru sl tr"
+for l in ${LANGS}; do
+ IUSE="${IUSE} linguas_${l}"
+done
+
+RDEPEND="
+ dbus? ( x11-libs/qt-dbus:4 )
+ monolithic? (
+ !postgres? ( x11-libs/qt-sql:4[sqlite] dev-db/sqlite[threadsafe] )
+ postgres? ( x11-libs/qt-sql:4[postgres] >=virtual/postgresql-base-8.3 )
+ x11-libs/qt-script:4
+ x11-libs/qt-gui:4
+ kde? ( >=kde-base/kdelibs-4.1 )
+ phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
+ webkit? ( x11-libs/qt-webkit:4 )
+ )
+ !monolithic? (
+ server? (
+ !postgres? ( x11-libs/qt-sql:4[sqlite] dev-db/sqlite[threadsafe] )
+ postgres? ( x11-libs/qt-sql:4[postgres] )
+ x11-libs/qt-script:4
+ )
+ X? (
+ x11-libs/qt-gui:4
+ kde? ( >=kde-base/kdelibs-4.1 )
+ phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
+ webkit? ( x11-libs/qt-webkit:4 )
+ )
+ )
+ ssl? ( x11-libs/qt-core:4[ssl] )
+ "
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog README"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if ! use monolithic && ! use server && ! use X ; then
+ eerror "You have to build at least one of the monolithic client (USE=monolithic),"
+ eerror "the quasselclient (USE=X) or the quasselcore (USE=server)."
+ die "monolithic, server and X flag unset."
+ fi
+}
+
+src_configure() {
+ local my_langs
+ for i in ${LINGUAS}; do
+ my_langs="${i},${my_langs}"
+ done
+
+ local mycmakeargs="
+ $(cmake-utils_use_want X QTCLIENT)
+ $(cmake-utils_use_want server CORE)
+ $(cmake-utils_use_want monolithic MONO)
+ $(cmake-utils_use_with webkit WEBKIT)
+ $(cmake-utils_use_with phonon PHONON)
+ $(cmake-utils_use_with kde KDE)
+ $(cmake-utils_use_with dbus DBUS)
+ $(cmake-utils_use_with ssl OPENSSL)
+ $(cmake-utils_use_with oxygen OXYGEN)
+ -DEMBED_DATA=OFF
+ -DLINGUAS=${my_langs}
+ "
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use server ; then
+ newinitd "${FILESDIR}"/quasselcore-2.init quasselcore || die "newinitd failed"
+ newconfd "${FILESDIR}"/quasselcore-2.conf quasselcore || die "newconfd failed"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/quassel.logrotate" quassel
+ fi
+}
+
+pkg_postinst() {
+ if use server ; then
+ ewarn
+ ewarn "In order to use the quassel init script you must set the"
+ ewarn "QUASSEL_USER variable in ${ROOT%/}/etc/conf.d/quasselcore to your username."
+ ewarn "Note: This is the user who runs the quasselcore and is independent"
+ ewarn "from the users you set up in the quasselclient."
+ fi
+
+ if ( use server || use monolithic ) && use ssl ; then
+ elog
+ elog "Information on how to enable SSL support for client/core connections"
+ elog "is available at http://bugs.quassel-irc.org/wiki/quassel-irc."
+ fi
+}