summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-01 14:38:57 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-01 14:38:57 +0000
commit90941625fdbcb86a0432ac487ec2f938b3c565a1 (patch)
treef5f29b0f3128d049aaafa2a1a69f14ed7f704867 /net-irc/quassel
parentAdd poppler.eclass. (diff)
downloadgentoo-2-90941625fdbcb86a0432ac487ec2f938b3c565a1.tar.gz
gentoo-2-90941625fdbcb86a0432ac487ec2f938b3c565a1.tar.bz2
gentoo-2-90941625fdbcb86a0432ac487ec2f938b3c565a1.zip
Removing old
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/quassel')
-rw-r--r--net-irc/quassel/ChangeLog6
-rw-r--r--net-irc/quassel/quassel-0.3.0.3.ebuild125
-rw-r--r--net-irc/quassel/quassel-0.3.1-r2.ebuild123
-rw-r--r--net-irc/quassel/quassel-0.3.1-r4.ebuild119
4 files changed, 5 insertions, 368 deletions
diff --git a/net-irc/quassel/ChangeLog b/net-irc/quassel/ChangeLog
index fa441719ccad..c8266b7c4ce4 100644
--- a/net-irc/quassel/ChangeLog
+++ b/net-irc/quassel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/quassel
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.48 2009/03/31 16:10:29 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.49 2009/04/01 14:38:57 patrick Exp $
+
+ 01 Apr 2009; Patrick Lauer <patrick@gentoo.org> -quassel-0.3.0.3.ebuild,
+ -quassel-0.3.1-r2.ebuild, -quassel-0.3.1-r4.ebuild:
+ Removing old
*quassel-0.4.1 (31 Mar 2009)
diff --git a/net-irc/quassel/quassel-0.3.0.3.ebuild b/net-irc/quassel/quassel-0.3.0.3.ebuild
deleted file mode 100644
index f3105112ab27..000000000000
--- a/net-irc/quassel/quassel-0.3.0.3.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.3.0.3.ebuild,v 1.3 2009/01/25 14:02:30 armin76 Exp $
-
-EAPI=1
-
-inherit cmake-utils eutils
-
-MY_P="${P/_/-}"
-
-DESCRIPTION="Core/client IRC client."
-HOMEPAGE="http://quassel-irc.org/"
-SRC_URI="http://quassel-irc.org/pub/${MY_P}.tar.bz2"
-
-LICENSE="GPL-3"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="+dbus debug +server +ssl +X"
-
-LANGS="nb_NO da de fr"
-for l in ${LANGS}; do
- IUSE="${IUSE} linguas_${l}"
-done
-
-RDEPEND="x11-libs/qt-core:4
- server? (
- x11-libs/qt-sql:4
- x11-libs/qt-script:4
- )
- X? ( x11-libs/qt-gui:4 )
- dbus? ( x11-libs/qt-dbus )
- ssl? ( dev-libs/openssl )"
-DEPEND="${RDEPEND}
- >=dev-util/cmake-2.4.7"
-
-DOCS="AUTHORS ChangeLog README README.Qtopia"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- if ! use server && ! use X ; then
- eerror "You have to build one or both of quassel client or server."
- die "Both server and X USE flags unset."
- fi
-
- if use server && ! built_with_use x11-libs/qt-sql sqlite ; then
- eerror "Please rebuild x11-libs/qt-sql:4 with sqlite USE flag enabled."
- die "Missing sqlite support in x11-libs/qt-sql:4"
- fi
-
- if use ssl && ! built_with_use x11-libs/qt-core ssl ; then
- eerror "Please rebuild x11-libs/qt-core:4 with ssl USE flag enabled."
- die "Missing ssl support in x11-libs/qt-core:4"
- fi
-}
-
-src_compile() {
-# Comment this out and invoke _common_configure_code, cmake and cmake-utils_src_make
-# manually until cmake-utils.eclass supports space separated strings as arguments for cmake
-# options. Until now multiple languages are not passed to -DLINGUAS and only the first
-# language is considered.
-#
-# local mycmakeargs=(
-# "$(cmake-utils_use_want server CORE)"
-# "$(cmake-utils_use_want X QTCLIENT)"
-# "$(cmake-utils_use_with dbus DBUS)"
-# "$(cmake-utils_use_with ssl OPENSSL)"
-# "-DLINGUAS=\"${LINGUAS}\""
-# '-DWANT_MONO=OFF' )
-#
-# cmake-utils_src_compile
-
- _common_configure_code
-
- cmake -C "${TMPDIR}/gentoo_common_config.cmake" \
- $(cmake-utils_use_want server CORE) $(cmake-utils_use_want X QTCLIENT) \
- $(cmake-utils_use_with dbus DBUS) $(cmake-utils_use_with ssl OPENSSL) \
- -DLINGUAS="${LINGUAS}" -DWANT_MONO=OFF \
- "${S}" || die "Cmake failed"
-
- cmake-utils_src_make
-}
-
-src_install() {
- cmake-utils_src_install
-
- # Only install the icons if the X client was installed
- if use X ; then
- insinto /usr/share/icons/hicolor
- # avoid the connected/ directory, get only the ${size}x${size}
- doins -r "${S}"/src/icons/quassel/*x* || die "installing quassel icons failed"
- fi
-
- if use server ; then
- newinitd "${FILESDIR}"/quasselcore.init quasselcore || die "newinitd failed"
- newconfd "${FILESDIR}"/quasselcore.conf quasselcore || die "newconfd failed"
-
- insinto /usr/share/doc/${PF}
- doins "${S}"/scripts/manageusers.py || die "installing manageusers.py failed"
- fi
-}
-
-pkg_postinst() {
- if use server ; then
- ewarn
- ewarn "In order to use the quassel init script you must set the"
- ewarn "QUASSEL_USER variable in /etc/conf.d/quasselcore to your username."
- ewarn "Note: This is the user who runs the quasselcore and is independent"
- ewarn "from the users you set up in the quasselclient."
- elog
- elog "Adding more than one user or changing username/password is not"
- elog "possible via the quasselclient yet. If you need to do these things"
- elog "you have to use the manageusers.py script, which has been installed in"
- elog "/usr/share/doc/${PF}".
- elog "Please make sure that the quasselcore is stopped before adding more users."
- fi
-
- if use server && use ssl ; then
- elog
- elog "To enable SSL support for client/core connections the quasselcore needs"
- elog "a PEM certificate which needs to be stored in ~/.quassel/quasselCert.pem."
- elog "To create the certificate use the following command:"
- elog "openssl req -x509 -nodes -days 365 -newkey rsa:1024 -keyout ~/.quassel/quasselCert.pem -out ~/.quassel/quasselCert.pem"
- fi
-}
diff --git a/net-irc/quassel/quassel-0.3.1-r2.ebuild b/net-irc/quassel/quassel-0.3.1-r2.ebuild
deleted file mode 100644
index 034d77833b5c..000000000000
--- a/net-irc/quassel/quassel-0.3.1-r2.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.3.1-r2.ebuild,v 1.3 2009/02/19 11:48:54 scarabeus Exp $
-
-EAPI=1
-
-inherit cmake-utils eutils
-
-MY_P="${P/_/-}"
-
-DESCRIPTION="Core/client IRC client."
-HOMEPAGE="http://quassel-irc.org/"
-SRC_URI="http://quassel-irc.org/pub/${MY_P}.tar.bz2"
-
-LICENSE="GPL-3"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="+dbus debug +server +ssl +X"
-
-LANGS="nb_NO da de fr ru"
-for l in ${LANGS}; do
- IUSE="${IUSE} linguas_${l}"
-done
-
-RDEPEND="x11-libs/qt-core:4
- server? (
- x11-libs/qt-sql:4
- x11-libs/qt-script:4
- )
- X? (
- x11-libs/qt-gui:4
- x11-libs/qt-webkit:4 )
- dbus? ( x11-libs/qt-dbus:4 )
- ssl? ( dev-libs/openssl )"
-DEPEND="${RDEPEND}
- >=dev-util/cmake-2.6"
-
-DOCS="AUTHORS ChangeLog README"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- if ! use server && ! use X ; then
- eerror "You have to build one or both of quassel client or server."
- die "Both server and X USE flags unset."
- fi
-
- if use server && ! built_with_use x11-libs/qt-sql sqlite ; then
- eerror "Please rebuild x11-libs/qt-sql:4 with sqlite USE flag enabled."
- die "Missing sqlite support in x11-libs/qt-sql:4"
- fi
-
- if use ssl && ! built_with_use x11-libs/qt-core ssl ; then
- eerror "Please rebuild x11-libs/qt-core:4 with ssl USE flag enabled."
- die "Missing ssl support in x11-libs/qt-core:4"
- fi
-}
-
-src_compile() {
-# Comment this out and invoke _common_configure_code, cmake and cmake-utils_src_make
-# manually until cmake-utils.eclass supports space separated strings as arguments for cmake
-# options. Until now multiple languages are not passed to -DLINGUAS and only the first
-# language is considered.
-#
-# local mycmakeargs=(
-# "$(cmake-utils_use_want server CORE)"
-# "$(cmake-utils_use_want X QTCLIENT)"
-# "$(cmake-utils_use_with X WEBKIT)"
-# "$(cmake-utils_use_with dbus DBUS)"
-# "$(cmake-utils_use_with ssl OPENSSL)"
-# "-DLINGUAS=\"${LINGUAS}\""
-# '-DOXYGEN_ICONS=Builtin'
-# '-DQUASSEL_ICONS=Builtin'
-# '-DWANT_MONO=OFF' )
-#
-# cmake-utils_src_compile
-
- _common_configure_code
-
- cmake -C "${TMPDIR}/gentoo_common_config.cmake" \
- $(cmake-utils_use_want server CORE) $(cmake-utils_use_want X QTCLIENT) \
- $(cmake-utils_use_with X WEBKIT) $(cmake-utils_use_with dbus DBUS) \
- $(cmake-utils_use_with ssl OPENSSL) -DLINGUAS="${LINGUAS}" \
- -DOXYGEN_ICONS=Builtin -DQUASSEL_ICONS=Builtin -DWANT_MONO=OFF \
- "${S}" || die "Cmake failed"
-
- cmake-utils_src_make
-}
-
-src_install() {
- cmake-utils_src_install
- if use server ; then
- newinitd "${FILESDIR}"/quasselcore.init quasselcore || die "newinitd failed"
- newconfd "${FILESDIR}"/quasselcore.conf quasselcore || die "newconfd failed"
-
- insinto /usr/share/doc/${PF}
- doins "${S}"/scripts/manageusers.py || die "installing manageusers.py failed"
- fi
-}
-
-pkg_postinst() {
- if use server ; then
- ewarn
- ewarn "In order to use the quassel init script you must set the"
- ewarn "QUASSEL_USER variable in /etc/conf.d/quasselcore to your username."
- ewarn "Note: This is the user who runs the quasselcore and is independent"
- ewarn "from the users you set up in the quasselclient."
- elog
- elog "Adding more than one user or changing username/password is not"
- elog "possible via the quasselclient yet. If you need to do these things"
- elog "you have to use the manageusers.py script, which has been installed in"
- elog "/usr/share/doc/${PF}".
- elog "Please make sure that the quasselcore is stopped before adding more users."
- fi
-
- if use server && use ssl ; then
- elog
- elog "To enable SSL support for client/core connections the quasselcore needs"
- elog "a PEM certificate which needs to be stored in ~/.quassel/quasselCert.pem."
- elog "To create the certificate use the following command:"
- elog "openssl req -x509 -nodes -days 365 -newkey rsa:1024 -keyout ~/.quassel/quasselCert.pem -out ~/.quassel/quasselCert.pem"
- fi
-}
diff --git a/net-irc/quassel/quassel-0.3.1-r4.ebuild b/net-irc/quassel/quassel-0.3.1-r4.ebuild
deleted file mode 100644
index 0221fb17bc3e..000000000000
--- a/net-irc/quassel/quassel-0.3.1-r4.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.3.1-r4.ebuild,v 1.1 2009/01/21 08:39:39 jokey Exp $
-
-EAPI="2"
-
-inherit cmake-utils eutils
-
-DESCRIPTION="Qt4/KDE4 IRC client suppporting a remote daemon for 24/7 connectivity."
-HOMEPAGE="http://quassel-irc.org/"
-SRC_URI="http://quassel-irc.org/pub/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="dbus debug monolithic +server +ssl +X"
-
-LANGS="nb_NO da de fr ru"
-for l in ${LANGS}; do
- IUSE="${IUSE} linguas_${l}"
-done
-
-RDEPEND="
- x11-libs/qt-core:4
- dbus? ( x11-libs/qt-dbus:4 )
- monolithic? (
- x11-libs/qt-sql:4[sqlite]
- x11-libs/qt-script:4
- x11-libs/qt-gui:4
- x11-libs/qt-webkit:4
- )
- !monolithic? (
- server? (
- x11-libs/qt-sql:4[sqlite]
- x11-libs/qt-script:4
- )
- X? (
- x11-libs/qt-gui:4
- x11-libs/qt-webkit:4
- )
- )
- ssl? (
- dev-libs/openssl
- x11-libs/qt-core:4[ssl]
- )
- "
-DEPEND="${RDEPEND}
- >=dev-util/cmake-2.6"
-
-DOCS="AUTHORS ChangeLog README"
-
-pkg_setup() {
- if ! use monolithic && ! use server && ! use X ; then
- eerror "You have to build at least one of the monolithic client (USE=monolithic),"
- eerror "the quasselclient (USE=X) or the quasselcore (USE=server)."
- die "monolithic, server and X flag unset."
- fi
-}
-
-src_configure() {
-# Comment this out and invoke _common_configure_code and cmake manually until cmake-utils.eclass
-# supports space separated strings as arguments for cmake options or quassel changes the
-# separator. Until now multiple languages are not passed to -DLINGUAS and only the first
-# language is considered.
- local mycmakeargs="$(cmake-utils_use_want server CORE)
- $(cmake-utils_use_want X QTCLIENT)
- $(cmake-utils_use_want monolithic MONO)
- $(cmake-utils_use_with X WEBKIT)
- $(cmake-utils_use_with dbus DBUS)
- $(cmake-utils_use_with ssl OPENSSL)
- -DOXYGEN_ICONS=Builtin
- -DQUASSEL_ICONS=Builtin"
-
- _common_configure_code
-
- mkdir -p "${WORKDIR}"/${PN}_build
- pushd "${WORKDIR}"/${PN}_build > /dev/null
-
- cmake -C "${TMPDIR}/gentoo_common_config.cmake" \
- ${mycmakeargs} \
- -DLINGUAS="${LINGUAS}" \
- "${S}" || die "Cmake failed"
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use server ; then
- newinitd "${FILESDIR}"/quasselcore.init quasselcore || die "newinitd failed"
- newconfd "${FILESDIR}"/quasselcore.conf quasselcore || die "newconfd failed"
-
- insinto /usr/share/doc/${PF}
- doins "${S}"/scripts/manageusers.py || die "installing manageusers.py failed"
- fi
-}
-
-pkg_postinst() {
- if use server ; then
- ewarn
- ewarn "In order to use the quassel init script you must set the"
- ewarn "QUASSEL_USER variable in /etc/conf.d/quasselcore to your username."
- ewarn "Note: This is the user who runs the quasselcore and is independent"
- ewarn "from the users you set up in the quasselclient."
- elog
- elog "Adding more than one user or changing username/password is not"
- elog "possible via the quasselclient yet. If you need to do these things"
- elog "you have to use the manageusers.py script, which has been installed in"
- elog "/usr/share/doc/${PF}".
- elog "Please make sure that the quasselcore is stopped before adding more users."
- fi
-
- if ( use server || use monolithic ) && use ssl ; then
- elog
- elog "To enable SSL support for client/core connections the quasselcore needs"
- elog "a PEM certificate which needs to be stored in ~/.quassel/quasselCert.pem."
- elog "To create the certificate use the following command:"
- elog "openssl req -x509 -nodes -days 365 -newkey rsa:1024 -keyout ~/.quassel/quasselCert.pem -out ~/.quassel/quasselCert.pem"
- fi
-}