summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2009-09-04 20:06:38 +0000
committerDaniel Pielmeier <billie@gentoo.org>2009-09-04 20:06:38 +0000
commit95e5416fd5515dcb6a0b67e8236bca2d165d6278 (patch)
treeb9d2832647511f2187d7f5790515b52503044f92 /net-irc/quassel
parentRemove old (diff)
downloadgentoo-2-95e5416fd5515dcb6a0b67e8236bca2d165d6278.tar.gz
gentoo-2-95e5416fd5515dcb6a0b67e8236bca2d165d6278.tar.bz2
gentoo-2-95e5416fd5515dcb6a0b67e8236bca2d165d6278.zip
Fix building with USE="-ssl" bug #283303. Remove old.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-irc/quassel')
-rw-r--r--net-irc/quassel/ChangeLog6
-rw-r--r--net-irc/quassel/files/quassel-0.5_rc1-identity.cpp.patch13
-rw-r--r--net-irc/quassel/quassel-0.4.1.ebuild122
-rw-r--r--net-irc/quassel/quassel-0.5_rc1.ebuild6
4 files changed, 23 insertions, 124 deletions
diff --git a/net-irc/quassel/ChangeLog b/net-irc/quassel/ChangeLog
index 7deaa97cd1a8..cbd5d5c8c165 100644
--- a/net-irc/quassel/ChangeLog
+++ b/net-irc/quassel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/quassel
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.54 2009/08/26 18:06:01 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.55 2009/09/04 20:06:38 billie Exp $
+
+ 04 Sep 2009; Pielmeier Daniel <billie@gentoo.org> -quassel-0.4.1.ebuild,
+ quassel-0.5_rc1.ebuild, +files/quassel-0.5_rc1-identity.cpp.patch:
+ Fix building with USE="-ssl" bug #283303. Remove old.
*quassel-0.4.3-r50 (26 Aug 2009)
diff --git a/net-irc/quassel/files/quassel-0.5_rc1-identity.cpp.patch b/net-irc/quassel/files/quassel-0.5_rc1-identity.cpp.patch
new file mode 100644
index 000000000000..b6b2fcbbfe75
--- /dev/null
+++ b/net-irc/quassel/files/quassel-0.5_rc1-identity.cpp.patch
@@ -0,0 +1,13 @@
+X-Git-Url: http://git.quassel-irc.org/?p=quassel.git;a=blobdiff_plain;f=src%2Fcommon%2Fidentity.cpp;h=275afcc6dfd3634413ba7fcb65e7f758a22763ad;hp=728cff128564d0ca918daece76312d946ebf6d8f;hb=5ec74a7b8f20e9e3f48cf286e0944f1855a271c3;hpb=d9db3175f4d977a4c809b2981a5a60ee00bb69b4
+
+diff --git a/src/common/identity.cpp b/src/common/identity.cpp
+index 728cff1..275afcc 100644
+--- a/src/common/identity.cpp
++++ b/src/common/identity.cpp
+@@ -315,4 +315,6 @@ QDataStream &operator>>(QDataStream &in, Identity &id) {
+ return in;
+ }
+
++#ifdef HAVE_SSL
+ INIT_SYNCABLE_OBJECT(CertManager)
++#endif // HAVE_SSL
diff --git a/net-irc/quassel/quassel-0.4.1.ebuild b/net-irc/quassel/quassel-0.4.1.ebuild
deleted file mode 100644
index d6617c624d94..000000000000
--- a/net-irc/quassel/quassel-0.4.1.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.4.1.ebuild,v 1.1 2009/03/31 16:10:29 patrick Exp $
-
-EAPI="2"
-
-inherit cmake-utils eutils
-
-DESCRIPTION="Qt4/KDE4 IRC client suppporting a remote daemon for 24/7 connectivity."
-HOMEPAGE="http://quassel-irc.org/"
-SRC_URI="http://quassel-irc.org/pub/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="dbus debug kde monolithic +oxygen phonon +server +ssl webkit +X"
-
-LANGS="cs da de fr hu nb_NO ru sl tr"
-for l in ${LANGS}; do
- IUSE="${IUSE} linguas_${l}"
-done
-
-RDEPEND="
- dbus? ( x11-libs/qt-dbus:4 )
- monolithic? (
- dev-db/sqlite[threadsafe]
- x11-libs/qt-sql:4[sqlite]
- x11-libs/qt-script:4
- x11-libs/qt-gui:4
- kde? ( >=kde-base/kdelibs-4.1 )
- phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
- webkit? ( x11-libs/qt-webkit:4 )
- )
- !monolithic? (
- server? (
- dev-db/sqlite[threadsafe]
- x11-libs/qt-sql:4[sqlite]
- x11-libs/qt-script:4
- )
- X? (
- x11-libs/qt-gui:4
- kde? ( >=kde-base/kdelibs-4.1 )
- phonon? ( || ( media-sound/phonon x11-libs/qt-phonon ) )
- webkit? ( x11-libs/qt-webkit:4 )
- )
- )
- ssl? ( x11-libs/qt-core:4[ssl] )
- "
-DEPEND="${RDEPEND}"
-
-DOCS="AUTHORS ChangeLog README"
-
-pkg_setup() {
- if ! use monolithic && ! use server && ! use X ; then
- eerror "You have to build at least one of the monolithic client (USE=monolithic),"
- eerror "the quasselclient (USE=X) or the quasselcore (USE=server)."
- die "monolithic, server and X flag unset."
- fi
-}
-
-src_configure() {
- local MY_LANGUAGES=""
- for i in ${LINGUAS}; do
- MY_LANGUAGES="${i},${MY_LANGUAGES}"
- done
-
- local mycmakeargs="
- $(cmake-utils_use_want X QTCLIENT)
- $(cmake-utils_use_want server CORE)
- $(cmake-utils_use_want monolithic MONO)
- $(cmake-utils_use_with webkit WEBKIT)
- $(cmake-utils_use_with phonon PHONON)
- $(cmake-utils_use_with kde KDE)
- $(cmake-utils_use_with dbus DBUS)
- $(cmake-utils_use_with ssl OPENSSL)
- $(cmake-utils_use_with oxygen OXYGEN)
- -DEMBED_DATA=OFF
- -DLINGUAS=${MY_LANGUAGES}
- "
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use server ; then
- newinitd "${FILESDIR}"/quasselcore-2.init quasselcore || die "newinitd failed"
- newconfd "${FILESDIR}"/quasselcore-2.conf quasselcore || die "newconfd failed"
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}/quassel.logrotate" quassel
-
- insinto /usr/share/doc/${PF}
- doins "${S}"/scripts/manageusers.py || die "installing manageusers.py failed"
- fi
-}
-
-pkg_postinst() {
- if use server ; then
- ewarn
- ewarn "In order to use the quassel init script you must set the"
- ewarn "QUASSEL_USER variable in ${ROOT%/}/etc/conf.d/quasselcore to your username."
- ewarn "Note: This is the user who runs the quasselcore and is independent"
- ewarn "from the users you set up in the quasselclient."
- elog
- elog "Adding more than one user or changing username/password is not"
- elog "possible via the quasselclient yet. If you need to do these things"
- elog "you have to use the manageusers.py script, which has been installed in"
- elog "${ROOT%/}/usr/share/doc/${PF}".
- elog "http://bugs.quassel-irc.org/wiki/quassel-irc/Manage_core_users provides"
- elog "some information on using the script."
- elog "To be sure nothing bad will happen you need to stop the quasselcore"
- elog "before adding more users."
- fi
-
- if ( use server || use monolithic ) && use ssl ; then
- elog
- elog "Information on how to enable SSL support for client/core connections"
- elog "is available at http://bugs.quassel-irc.org/wiki/quassel-irc."
- fi
-}
diff --git a/net-irc/quassel/quassel-0.5_rc1.ebuild b/net-irc/quassel/quassel-0.5_rc1.ebuild
index 464a3a2815b0..9ea805b11d56 100644
--- a/net-irc/quassel/quassel-0.5_rc1.ebuild
+++ b/net-irc/quassel/quassel-0.5_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.5_rc1.ebuild,v 1.1 2009/08/26 18:06:01 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.5_rc1.ebuild,v 1.2 2009/09/04 20:06:38 billie Exp $
EAPI="2"
@@ -62,6 +62,10 @@ pkg_setup() {
fi
}
+src_prepare() {
+ epatch "$FILESDIR/${P}-identity.cpp.patch"
+}
+
src_configure() {
local my_langs
for i in ${LINGUAS}; do