summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-04-24 13:35:41 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-04-24 13:35:41 +0000
commitb1fb5ec689a233a4ff72a6d1803e534649c7afbc (patch)
tree181c2e30e834c8443828eaf78a85f1949d24d722 /net-irc/rbot
parentPunt overshadowed version. (diff)
downloadgentoo-2-b1fb5ec689a233a4ff72a6d1803e534649c7afbc.tar.gz
gentoo-2-b1fb5ec689a233a4ff72a6d1803e534649c7afbc.tar.bz2
gentoo-2-b1fb5ec689a233a4ff72a6d1803e534649c7afbc.zip
Use hunspell as default (much better solution than dict-based spellcheck) -> dropping hunspell useflag. Remove ispell as whole as it is way worse than aspell.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/rbot')
-rw-r--r--net-irc/rbot/ChangeLog8
-rw-r--r--net-irc/rbot/rbot-0.9.15.ebuild13
-rw-r--r--net-irc/rbot/rbot-9999-r10.ebuild15
3 files changed, 16 insertions, 20 deletions
diff --git a/net-irc/rbot/ChangeLog b/net-irc/rbot/ChangeLog
index 4552e509cc67..f1d640ca9433 100644
--- a/net-irc/rbot/ChangeLog
+++ b/net-irc/rbot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/rbot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/ChangeLog,v 1.50 2012/04/18 19:05:07 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/ChangeLog,v 1.51 2012/04/24 13:35:41 scarabeus Exp $
+
+ 24 Apr 2012; Tomáš Chvátal <scarabeus@gentoo.org> rbot-0.9.15.ebuild,
+ rbot-9999-r10.ebuild:
+ Use hunspell as default (much better solution than dict-based spellcheck) ->
+ dropping hunspell useflag. Remove ispell as whole as it is way worse than
+ aspell.
18 Apr 2012; Raúl Porcel <armin76@gentoo.org> rbot-0.9.10-r1.ebuild,
rbot-0.9.15.ebuild:
diff --git a/net-irc/rbot/rbot-0.9.15.ebuild b/net-irc/rbot/rbot-0.9.15.ebuild
index 06a57244c928..a4dbbb1d505d 100644
--- a/net-irc/rbot/rbot-0.9.15.ebuild
+++ b/net-irc/rbot/rbot-0.9.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-0.9.15.ebuild,v 1.5 2012/04/18 19:05:07 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-0.9.15.ebuild,v 1.6 2012/04/24 13:35:41 scarabeus Exp $
EAPI="2"
# ruby19 needs ruby-gettext on 19 first
@@ -16,7 +16,7 @@ LICENSE="GPL-2 as-is"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86 ~x86-fbsd"
IUSE="spell aspell timezone translator shorturl nls dict figlet
- fortune cal host toilet hunspell"
+ fortune cal host toilet"
ILINGUAS="zh_CN zh_TW ru nl de fi fr it ja"
for lang in $ILINGUAS; do
@@ -26,10 +26,7 @@ done
RDEPEND="
spell? (
aspell? ( app-text/aspell )
- !aspell? (
- hunspell? ( app-text/hunspell )
- !hunspell? ( app-text/ispell )
- )
+ !aspell? ( app-text/hunspell )
)
figlet? ( app-misc/figlet )
toilet? ( app-misc/toilet )
@@ -73,14 +70,12 @@ all_ruby_compile() {
|| rbot_conf "$2" /bin/false
}
- local spell_program="/usr/bin/ispell"
+ local spell_program="/usr/bin/hunspell -i"
if use !spell; then
disable_rbot_plugin spell
spell_program="/bin/false"
elif use aspell; then
spell_program="/usr/bin/ispell-aspell"
- elif use hunspell; then
- spell_program="/usr/bin/hunspell -i"
fi
rbot_conf spell.program "${spell_program}"
diff --git a/net-irc/rbot/rbot-9999-r10.ebuild b/net-irc/rbot/rbot-9999-r10.ebuild
index 2db75cbbf940..373e78ac7c96 100644
--- a/net-irc/rbot/rbot-9999-r10.ebuild
+++ b/net-irc/rbot/rbot-9999-r10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-9999-r10.ebuild,v 1.6 2011/09/21 08:54:22 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-9999-r10.ebuild,v 1.7 2012/04/24 13:35:41 scarabeus Exp $
inherit ruby eutils
@@ -13,7 +13,7 @@ LICENSE="GPL-2 as-is"
SLOT="0"
KEYWORDS=""
IUSE="spell aspell timezone translator shorturl nls dict figlet
- fortune cal host toilet hunspell"
+ fortune cal host toilet"
ILINGUAS="zh_CN zh_TW ru nl de fr it ja"
for lang in $ILINGUAS; do
@@ -25,10 +25,7 @@ RDEPEND=">=dev-lang/ruby-1.8
timezone? ( dev-ruby/tzinfo )
spell? (
aspell? ( app-text/aspell )
- !aspell? (
- hunspell? ( app-text/hunspell )
- !hunspell? ( app-text/ispell )
- )
+ !aspell? ( app-text/hunspell )
)
translator? ( dev-ruby/mechanize )
shorturl? ( dev-ruby/shorturl )
@@ -87,14 +84,12 @@ src_compile() {
|| rbot_conf "$2" /bin/false
}
- local spell_program="/usr/bin/ispell"
+ local spell_program="/usr/bin/hunspell -i"
if use !spell; then
disable_rbot_plugin spell
spell_program="/bin/false"
elif use aspell; then
spell_program="/usr/bin/ispell-aspell"
- elif use hunspell; then
- spell_program="/usr/bin/hunspell -i"
fi
rbot_conf spell.program "${spell_program}"