summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2012-01-03 03:52:07 +0000
committerNathan Phillip Brink <binki@gentoo.org>2012-01-03 03:52:07 +0000
commita814c7e83fafa00decbf58e4bd77a0332b8f7a3c (patch)
tree16ef0c4c96216275476d8bf66b023a50e4db36bc /net-irc/scrollz/scrollz-2.2.ebuild
parentUpdate the multicast patch in 3.0.9 to the one that was accepted by net-dev a... (diff)
downloadgentoo-2-a814c7e83fafa00decbf58e4bd77a0332b8f7a3c.tar.gz
gentoo-2-a814c7e83fafa00decbf58e4bd77a0332b8f7a3c.tar.bz2
gentoo-2-a814c7e83fafa00decbf58e4bd77a0332b8f7a3c.zip
Use ${CHOST}-gcc instead of gcc when compiling (fixes bug #397441 by ago). Don't use einstall() (fixes bug #397445 by ago). Add patches for parallel make install and respecting CPPFLAGS.
(Portage version: 2.2.0_alpha82-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/scrollz/scrollz-2.2.ebuild')
-rw-r--r--net-irc/scrollz/scrollz-2.2.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/net-irc/scrollz/scrollz-2.2.ebuild b/net-irc/scrollz/scrollz-2.2.ebuild
index fd0f1ae4f689..532568e07329 100644
--- a/net-irc/scrollz/scrollz-2.2.ebuild
+++ b/net-irc/scrollz/scrollz-2.2.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/scrollz/scrollz-2.2.ebuild,v 1.1 2011/06/30 17:12:32 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/scrollz/scrollz-2.2.ebuild,v 1.2 2012/01/03 03:52:07 binki Exp $
EAPI=4
+inherit eutils toolchain-funcs
+
MY_P=ScrollZ-${PV}
DESCRIPTION="Advanced IRC client based on ircII"
@@ -28,6 +30,11 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cppflags.patch
+ epatch "${FILESDIR}"/${P}-make-install.patch
+}
+
src_configure() {
local _myssl
@@ -39,6 +46,7 @@ src_configure() {
fi
fi
+ tc-export CC #397441, ancient autoconf
econf \
--with-default-server=irc.gentoo.org \
$(use_enable socks5) \
@@ -49,9 +57,10 @@ src_configure() {
}
src_install() {
- einstall \
- sharedir="${ED}/usr/share" \
- mandir="${ED}/usr/share/man/man1"
+ emake \
+ DESTDIR="${D}" \
+ mandir="${EPREFIX}/usr/share/man/man1" \
+ install
dodoc ChangeLog* NEWS README* todo
}