summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-07-02 19:27:32 +0000
committerMike Frysinger <vapier@gentoo.org>2003-07-02 19:27:32 +0000
commitfcb1fc4d3e77c29b5a57c08c1d01560026da4993 (patch)
tree229c2603e5525c88de2e25a4b07e0b1a20df4e01 /net-irc/unrealircd/unrealircd-3.1.5.1.ebuild
parentMarked stable on hppa. (diff)
downloadgentoo-2-fcb1fc4d3e77c29b5a57c08c1d01560026da4993.tar.gz
gentoo-2-fcb1fc4d3e77c29b5a57c08c1d01560026da4993.tar.bz2
gentoo-2-fcb1fc4d3e77c29b5a57c08c1d01560026da4993.zip
fix for #23825
Diffstat (limited to 'net-irc/unrealircd/unrealircd-3.1.5.1.ebuild')
-rw-r--r--net-irc/unrealircd/unrealircd-3.1.5.1.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/net-irc/unrealircd/unrealircd-3.1.5.1.ebuild b/net-irc/unrealircd/unrealircd-3.1.5.1.ebuild
index ee16f757bcd1..3599643b36bc 100644
--- a/net-irc/unrealircd/unrealircd-3.1.5.1.ebuild
+++ b/net-irc/unrealircd/unrealircd-3.1.5.1.ebuild
@@ -1,28 +1,27 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.1.5.1.ebuild,v 1.3 2003/03/25 22:47:03 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.1.5.1.ebuild,v 1.4 2003/07/02 19:26:51 vapier Exp $
-IUSE="ssl"
-
-MY_P="Unreal${PV}"
-
-S=${WORKDIR}/${MY_P}
+MY_P=Unreal${PV}-Valek
DESCRIPTION="aimed to be an advanced, not an easy IRCd"
HOMEPAGE="http://www.unrealircd.com/"
-SRC_URI="http://www.gower.net/unrealircd/${MY_P}-Valek.tar.gz
- ftp://unreal.secure-tech.net/${MY_P}-Valek.tar.gz"
+SRC_URI="http://www.gower.net/unrealircd/${MY_P}.tar.gz
+ ftp://unreal.secure-tech.net/${MY_P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86"
+KEYWORDS="x86"
+IUSE="ssl"
DEPEND="ssl? ( dev-libs/openssl )"
+S=${WORKDIR}/Unreal${PV}
src_unpack() {
unpack ${A} && cd ${S}
rm -f .CHANGES.NEW .RELEASE.NOTES
- epatch ${FILESDIR}/${P}-Config.patch
+ epatch ${FILESDIR}/${PV}-Config.patch
+ epatch ${FILESDIR}/${PV}-new-glibc-res.patch
cp Config{,.orig}
sed -e "s:GENTOO_CFLAGS:${CFLAGS}:" \
@@ -31,7 +30,8 @@ src_unpack() {
src_compile() {
./Config || die "configure failed"
- make || die "compiling failed"
+ make RES="res_init.o res_comp.o res_mkquery.o" \
+ || die "compiling failed"
}
src_install() {