summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-12 16:34:41 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-12 16:34:41 +0000
commitb320c3c65c73af8c27276d7c480d49458c5cb7be (patch)
treebaecaaad98272c10ebbef5ee150d158de5478fdf /net-irc/unrealircd
parentfix description, by Nick Bowler <nbowler@draconx.ca>, bug #304049 (diff)
downloadgentoo-2-b320c3c65c73af8c27276d7c480d49458c5cb7be.tar.gz
gentoo-2-b320c3c65c73af8c27276d7c480d49458c5cb7be.tar.bz2
gentoo-2-b320c3c65c73af8c27276d7c480d49458c5cb7be.zip
Revision bump wrt security #323691.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/unrealircd')
-rw-r--r--net-irc/unrealircd/ChangeLog10
-rw-r--r--net-irc/unrealircd/unrealircd-3.2.8.1-r1.ebuild164
2 files changed, 172 insertions, 2 deletions
diff --git a/net-irc/unrealircd/ChangeLog b/net-irc/unrealircd/ChangeLog
index a0cd086b2e6a..cb4d422d144e 100644
--- a/net-irc/unrealircd/ChangeLog
+++ b/net-irc/unrealircd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/unrealircd
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/ChangeLog,v 1.78 2009/12/22 01:01:06 vostorga Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/ChangeLog,v 1.79 2010/06/12 16:34:41 ssuominen Exp $
+
+*unrealircd-3.2.8.1-r1 (12 Jun 2010)
+
+ 12 Jun 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +unrealircd-3.2.8.1-r1.ebuild:
+ Revision bump wrt security #323691.
22 Dec 2009; Víctor Ostorga <vostorga@gentoo.org> files/unrealircd.rc:
Fixing stop sequence in init script, patch thanks to Lars Wendler
diff --git a/net-irc/unrealircd/unrealircd-3.2.8.1-r1.ebuild b/net-irc/unrealircd/unrealircd-3.2.8.1-r1.ebuild
new file mode 100644
index 000000000000..fc6edf528dc7
--- /dev/null
+++ b/net-irc/unrealircd/unrealircd-3.2.8.1-r1.ebuild
@@ -0,0 +1,164 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2.8.1-r1.ebuild,v 1.1 2010/06/12 16:34:41 ssuominen Exp $
+
+EAPI="2"
+
+inherit eutils autotools ssl-cert versionator multilib
+
+MY_P=Unreal${PV}
+
+DESCRIPTION="aimed to be an advanced (not easy) IRCd"
+HOMEPAGE="http://www.unrealircd.com/"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${MY_P}-no_trojan.tar.gz"
+#SRC_URI="http://unrealircd.icedslash.com/${MY_P}.tar.gz
+# http://unreal.brueggisite.de/${MY_P}.tar.gz
+# http://www.blurryfox.com/unreal/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="curl +hub ipv6 +operoverride +spoof operoverride-verify +prefixaq
+showlistmodes shunnotices ssl topicisnuhost +usermod zlib"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ curl? ( net-misc/curl )
+ dev-libs/tre
+ >=net-dns/c-ares-1.5.3"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/Unreal$(get_version_component_range 1-2)"
+
+pkg_setup() {
+ enewuser unrealircd
+}
+
+src_prepare() {
+ #QA check against bundled pkgs
+ rm extras/*.gz
+
+ sed -i \
+ -e "s:ircd\.pid:/var/run/unrealircd/ircd.pid:" \
+ -e "s:ircd\.log:/var/log/unrealircd/ircd.log:" \
+ -e "s:debug\.log:/var/log/unrealircd/debug.log:" \
+ -e "s:ircd\.tune:/var/lib/unrealircd/ircd.tune:" \
+ include/config.h \
+ || die "sed failed"
+
+ # http://bugs.unrealircd.org/view.php?id=3842
+ epatch "${FILESDIR}"/unrealircd-system-tre.patch || die "epatch failed"
+
+ epatch "${FILESDIR}"/unrealircd-system-cares.patch || die "epatch failed"
+
+ mv autoconf/configure.in ./ || die
+ mv autoconf/aclocal.m4 ./acinclude.m4 || die
+ #can't call eautoreconf because aclocal's source files aren't even in unearlircd's svn!
+ eaclocal
+ eautoconf
+}
+
+src_configure() {
+ local myconf=""
+ use curl && myconf="${myconf} --enable-libcurl=/usr"
+ use ipv6 && myconf="${myconf} --enable-inet6"
+ use zlib && myconf="${myconf} --enable-ziplinks"
+ use hub && myconf="${myconf} --enable-hub"
+ use ssl && myconf="${myconf} --enable-ssl"
+ use prefixaq && myconf="${myconf} --enable-prefixaq"
+ use spoof && myconf="${myconf} --enable-nospoof"
+ use showlistmodes && myconf="${myconf} --with-showlistmodes"
+ use topicisnuhost && myconf="${myconf} --with-topicisnuhost"
+ use shunnotices && myconf="${myconf} --with-shunnotices"
+ use operoverride || myconf="${myconf} --with-no-operoverride"
+ use operoverride-verify && myconf="${myconf} --with-operoverride-verify"
+ use usermod || myconf="${myconf} --with-disableusermod"
+
+ econf \
+ --with-listen=5 \
+ --with-dpath="${D}"/etc/unrealircd \
+ --with-spath=/usr/bin/unrealircd \
+ --with-nick-history=2000 \
+ --with-sendq=3000000 \
+ --with-bufferpool=18 \
+ --with-hostname=$(hostname -f) \
+ --with-permissions=0600 \
+ --with-fd-setsize=1024 \
+ --with-system-cares \
+ --with-system-tre \
+ --enable-dynamic-linking \
+ ${myconf}
+
+ # Fix upstream poor autofoo
+ sed -i \
+ -e "s:${D}::g" \
+ include/setup.h \
+ ircdcron/ircdchk \
+ || die
+}
+
+src_compile() {
+ emake MAKE=make IRCDDIR=/etc/unrealircd || die "emake failed"
+}
+
+src_install() {
+ keepdir /var/{lib,log,run}/unrealircd
+
+ newbin src/ircd unrealircd || die
+
+ exeinto /usr/$(get_libdir)/unrealircd/modules
+ doexe src/modules/*.so || die
+
+ dodir /etc/unrealircd
+ dosym /var/lib/unrealircd /etc/unrealircd/tmp || die
+
+ insinto /etc/unrealircd
+ doins {badwords.*,help,spamfilter,dccallow}.conf || die
+ newins doc/example.conf unrealircd.conf || die
+
+ insinto /etc/unrealircd/aliases
+ doins aliases/*.conf || die
+ insinto /etc/unrealircd/networks
+ doins networks/*.network || die
+
+ sed -i \
+ -e s:src/modules:/usr/$(get_libdir)/unrealircd/modules: \
+ -e s:ircd\\.log:/var/log/unrealircd/ircd.log: \
+ "${D}"/etc/unrealircd/unrealircd.conf \
+ || die
+
+ dodoc \
+ Changes Donation Unreal.nfo networks/makenet \
+ ircdcron/{ircd.cron,ircdchk} \
+ || die "dodoc failed"
+ dohtml doc/*.html || die
+
+ newinitd "${FILESDIR}"/unrealircd.rc unrealircd || die
+ newconfd "${FILESDIR}"/unrealircd.confd unrealircd
+
+ fperms 700 /etc/unrealircd || die
+ chown -R unrealircd "${D}"/{etc,var/{lib,log,run}}/unrealircd ||die
+}
+
+pkg_postinst() {
+ # Move docert call from scr_install() to install_cert in pkg_postinst for
+ # bug #201682
+ if use ssl ; then
+ if [[ ! -f "${ROOT}"/etc/unrealircd/server.cert.key ]]; then
+ install_cert /etc/unrealircd/server.cert || die
+ chown unrealircd "${ROOT}"/etc/unrealircd/server.cert.* || die
+ ln -snf server.cert.key "${ROOT}"/etc/unrealircd/server.key.pem || die
+ fi
+ fi
+
+ elog
+ elog "UnrealIRCd will not run until you've set up /etc/unrealircd/unrealircd.conf"
+ elog
+ elog "You can find example cron scripts here:"
+ elog " /usr/share/doc/${PF}/ircd.cron.gz"
+ elog " /usr/share/doc/${PF}/ircdchk.gz"
+ elog
+ elog "You can also use /etc/init.d/unrealircd to start at boot"
+ elog
+}