summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-11-04 07:18:35 +0000
committerSven Wegener <swegener@gentoo.org>2005-11-04 07:18:35 +0000
commitb693f61893540c7e74e3ebf7f31420a2582a370c (patch)
tree8a451f5e416423d018fdf0508636cb3b7fe734d5 /net-irc/xchat
parentStable on x86; bug #109667 (diff)
downloadgentoo-2-b693f61893540c7e74e3ebf7f31420a2582a370c.tar.gz
gentoo-2-b693f61893540c7e74e3ebf7f31420a2582a370c.tar.bz2
gentoo-2-b693f61893540c7e74e3ebf7f31420a2582a370c.zip
Pull in a patch from upstream to fix text frontend building.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'net-irc/xchat')
-rw-r--r--net-irc/xchat/ChangeLog6
-rw-r--r--net-irc/xchat/files/xc260-fix-fetext.diff67
-rw-r--r--net-irc/xchat/xchat-2.6.0.ebuild6
3 files changed, 76 insertions, 3 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 80504c4e40be..fc834fbc5d0d 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/xchat
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.178 2005/11/03 07:20:07 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.179 2005/11/04 07:18:35 swegener Exp $
+
+ 04 Nov 2005; Sven Wegener <swegener@gentoo.org>
+ +files/xc260-fix-fetext.diff, xchat-2.6.0.ebuild:
+ Pull in a patch from upstream to fix text frontend building.
*xchat-2.6.0 (03 Nov 2005)
diff --git a/net-irc/xchat/files/xc260-fix-fetext.diff b/net-irc/xchat/files/xc260-fix-fetext.diff
new file mode 100644
index 000000000000..5322ab7f457e
--- /dev/null
+++ b/net-irc/xchat/files/xc260-fix-fetext.diff
@@ -0,0 +1,67 @@
+#
+# Fix for building xchat 2.6.0 with ./configure --enable-textfe
+#
+--- xchat-2.6.0/src/fe-text/fe-text.c 28 Sep 2005 07:49:46 -0000 1.26
++++ xchat-2.6.0p1/src/fe-text/fe-text.c 4 Nov 2005 03:19:46 -0000
+@@ -109,12 +109,6 @@
+ fe_print_text (sess, buf);
+
+ fe_print_text (sess, "\n\nCompiled in Features\0032:\017 "
+-#ifdef USE_PERL
+- "Perl "
+-#endif
+-#ifdef USE_PYTHON
+- "Python "
+-#endif
+ #ifdef USE_PLUGIN
+ "Plugin "
+ #endif
+@@ -124,9 +118,6 @@
+ #ifdef USE_OPENSSL
+ "OpenSSL "
+ #endif
+-#ifdef SOCKS
+- "Socks5 "
+-#endif
+ #ifdef USE_IPV6
+ "IPv6"
+ #endif
+@@ -406,7 +397,7 @@
+ return 0;
+ }
+ }
+- return 1;
++ return -1;
+ }
+
+ void
+@@ -557,7 +548,7 @@
+ }
+
+ void
+-fe_message (char *msg, int wait)
++fe_message (char *msg, int flags)
+ {
+ puts (msg);
+ }
+@@ -565,7 +556,7 @@
+ void
+ fe_close_window (struct session *sess)
+ {
+- kill_session_callback (sess);
++ session_free (sess);
+ done = TRUE;
+ }
+
+@@ -803,6 +794,11 @@
+ {
+ return -1;
+ }
++void *
++fe_gui_info_ptr (session *sess, int info_type)
++{
++ return NULL;
++}
+ void fe_confirm (const char *message, void (*yesproc)(void *), void (*noproc)(void *), void *ud)
+ {
+ }
diff --git a/net-irc/xchat/xchat-2.6.0.ebuild b/net-irc/xchat/xchat-2.6.0.ebuild
index 4bb917d93986..922fe107e1b8 100644
--- a/net-irc/xchat/xchat-2.6.0.ebuild
+++ b/net-irc/xchat/xchat-2.6.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.6.0.ebuild,v 1.3 2005/11/04 03:51:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.6.0.ebuild,v 1.4 2005/11/04 07:18:35 swegener Exp $
-inherit versionator
+inherit eutils versionator
DESCRIPTION="Graphical IRC client"
SRC_URI="http://www.xchat.org/files/source/$(get_version_component_range 1-2)/${P}.tar.bz2
@@ -37,6 +37,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/xc260-fix-fetext.diff
+
# use libdir/xchat/plugins as the plugin directory
if [ $(get_libdir) != "lib" ] ; then
sed -i -e 's:${prefix}/lib/xchat:${libdir}/xchat:' \