summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2012-01-08 18:20:08 +0000
committerAlex Alexander <wired@gentoo.org>2012-01-08 18:20:08 +0000
commitbb95cfd130e2766462df7b6d20115656504a980a (patch)
tree9804e62bf8658e04dfb74be1f500860014523c69 /net-irc/znc
parentVersion bump to next upstream production release. (diff)
downloadgentoo-2-bb95cfd130e2766462df7b6d20115656504a980a.tar.gz
gentoo-2-bb95cfd130e2766462df7b6d20115656504a980a.tar.bz2
gentoo-2-bb95cfd130e2766462df7b6d20115656504a980a.zip
security: bouncedcc dos fix - bug #398159
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/znc')
-rw-r--r--net-irc/znc/ChangeLog10
-rw-r--r--net-irc/znc/files/znc-0.202-bouncedcc-dos-fix.patch27
-rw-r--r--net-irc/znc/znc-0.202-r1.ebuild (renamed from net-irc/znc/znc-0.202.ebuild)9
3 files changed, 42 insertions, 4 deletions
diff --git a/net-irc/znc/ChangeLog b/net-irc/znc/ChangeLog
index 34addfecce5e..97727ea9fbf0 100644
--- a/net-irc/znc/ChangeLog
+++ b/net-irc/znc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/znc
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.53 2011/10/30 22:35:45 wired Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.54 2012/01/08 18:20:08 wired Exp $
+
+*znc-0.202-r1 (08 Jan 2012)
+
+ 08 Jan 2012; Alex Alexander <wired@gentoo.org> -znc-0.202.ebuild,
+ +znc-0.202-r1.ebuild, +files/znc-0.202-bouncedcc-dos-fix.patch:
+ security: bouncedcc dos fix - bug #398159
30 Oct 2011; Alex Alexander <wired@gentoo.org> -znc-0.096.ebuild,
-znc-0.096-r1.ebuild, -znc-0.098.ebuild, -znc-0.200.ebuild, znc-0.202.ebuild,
diff --git a/net-irc/znc/files/znc-0.202-bouncedcc-dos-fix.patch b/net-irc/znc/files/znc-0.202-bouncedcc-dos-fix.patch
new file mode 100644
index 000000000000..090932e927a5
--- /dev/null
+++ b/net-irc/znc/files/znc-0.202-bouncedcc-dos-fix.patch
@@ -0,0 +1,27 @@
+# Fix crash in bouncedcc module.
+# It happens when DCC RESUME is received.
+# Affected ZNC versions: 0.200, 0.202.
+
+https://bugs.gentoo.org/show_bug.cgi?id=398159
+
+diff -Naur znc-0.202.orig/modules/bouncedcc.cpp znc-0.202/modules/bouncedcc.cpp
+--- znc-0.202.orig/modules/bouncedcc.cpp 2011-09-21 22:20:19.000000000 +0200
++++ znc-0.202/modules/bouncedcc.cpp 2012-01-07 14:47:20.436704782 +0100
+@@ -238,7 +238,7 @@
+ CDCCBounce* pSock = (CDCCBounce*) *it;
+
+ if (pSock->GetLocalPort() == uResumePort) {
+- m_pUser->PutUser(":" + Nick.GetNickMask() + " PRIVMSG " + m_pClient->GetNick() + " :\001DCC " + sType + " " + sFile + " " + CString(pSock->GetUserPort()) + " " + sMessage.Token(4) + "\001");
++ m_pUser->PutUser(":" + Nick.GetNickMask() + " PRIVMSG " + m_pUser->GetNick() + " :\001DCC " + sType + " " + sFile + " " + CString(pSock->GetUserPort()) + " " + sMessage.Token(4) + "\001");
+ }
+ }
+ } else if (sType.Equals("ACCEPT")) {
+@@ -248,7 +248,7 @@
+ CDCCBounce* pSock = (CDCCBounce*) *it;
+
+ if (pSock->GetUserPort() == sMessage.Token(3).ToUShort()) {
+- m_pUser->PutUser(":" + Nick.GetNickMask() + " PRIVMSG " + m_pClient->GetNick() + " :\001DCC " + sType + " " + sFile + " " + CString(pSock->GetLocalPort()) + " " + sMessage.Token(4) + "\001");
++ m_pUser->PutUser(":" + Nick.GetNickMask() + " PRIVMSG " + m_pUser->GetNick() + " :\001DCC " + sType + " " + sFile + " " + CString(pSock->GetLocalPort()) + " " + sMessage.Token(4) + "\001");
+ }
+ }
+ }
diff --git a/net-irc/znc/znc-0.202.ebuild b/net-irc/znc/znc-0.202-r1.ebuild
index b51651f749e1..8f86a208d7f3 100644
--- a/net-irc/znc/znc-0.202.ebuild
+++ b/net-irc/znc/znc-0.202-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.202.ebuild,v 1.2 2011/10/30 22:35:45 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.202-r1.ebuild,v 1.1 2012/01/08 18:20:08 wired Exp $
EAPI=2
@@ -40,6 +40,11 @@ pkg_setup() {
fi
}
+src_prepare() {
+ # security fix, bug #398159
+ epatch "${FILESDIR}"/"${P}"-bouncedcc-dos-fix.patch
+}
+
src_configure() {
econf \
$(use_enable ares c-ares) \