summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-03 03:34:50 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-03 03:34:50 +0000
commit07e01092e6b5200311633e913d77fcc58e201fa3 (patch)
tree80bf884747740384d9c24da053493b39a9098f1e /net-irc
parentcleanup (diff)
downloadgentoo-2-07e01092e6b5200311633e913d77fcc58e201fa3.tar.gz
gentoo-2-07e01092e6b5200311633e913d77fcc58e201fa3.tar.bz2
gentoo-2-07e01092e6b5200311633e913d77fcc58e201fa3.zip
cleanups
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/kvirc/kvirc-3.0.0_beta1-r1.ebuild42
-rw-r--r--net-irc/kvirc/kvirc-3.0.0_beta2-r1.ebuild48
2 files changed, 38 insertions, 52 deletions
diff --git a/net-irc/kvirc/kvirc-3.0.0_beta1-r1.ebuild b/net-irc/kvirc/kvirc-3.0.0_beta1-r1.ebuild
index cc80cce07fd4..bf1d0aa4f3a5 100644
--- a/net-irc/kvirc/kvirc-3.0.0_beta1-r1.ebuild
+++ b/net-irc/kvirc/kvirc-3.0.0_beta1-r1.ebuild
@@ -1,28 +1,27 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-3.0.0_beta1-r1.ebuild,v 1.1 2003/05/22 07:52:33 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-3.0.0_beta1-r1.ebuild,v 1.2 2003/08/03 03:34:50 vapier Exp $
-IUSE="kde esd ipv6"
inherit kde-base
MYP=${P//_/-}
MYPV=${PV//_/-}
S=${WORKDIR}/${MYP}
DESCRIPTION="An advanced IRC Client"
+HOMEPAGE="http://www.kvirc.net/"
SRC_URI="ftp://ftp.kvirc.net/kvirc/${MYPV}/source/${MYP}.tar.gz"
-HOMEPAGE="http://www.kvirc.net"
-SLOT="3"
LICENSE="kvirc"
+SLOT="3"
KEYWORDS="x86"
+IUSE="kde esd ipv6"
use kde && need-kde 3 || need-qt 3
-
newdepend "esd? ( media-sound/esound )"
# ssl? ( dev-libs/openssl )"
use kde || newdepend "arts? ( kde-base/arts )"
-[ -n "$DEBUG" ] && myconf="$myconf --with-debug-symbols"
+[ `use debug` ] && myconf="$myconf --with-debug-symbols"
#The assembly seems to be less than stable
#[ "$ARCH" == "x86" ] && myconf="$myconf --with-ix86-asm"
@@ -46,28 +45,21 @@ use esd && myconf="$myconf --with-esd-support" \
myconf="$myconf --with-aa-fonts"
src_compile() {
+ use kde && kde_src_compile myconf
- use kde && kde_src_compile myconf
+ # always install into /usr regardless of kde support
+ # kvirc doesn't have a kde-like installed file structure anyway
+ myconf="$myconf --prefix=/usr -v"
- # always install into /usr regardless of kde support
- # kvirc doesn't have a kde-like installed file structure anyway
- myconf="$myconf --prefix=/usr -v"
-
- # make sure we disable kde support as the configure script can auto-enable
- # it when it isn't wanted
- use kde || export KDEDIR=""
-
- kde_src_compile configure make
+ # make sure we disable kde support as the configure script can auto-enable
+ # it when it isn't wanted
+ use kde || export KDEDIR=""
+ kde_src_compile configure make
}
-src_install () {
-
- make install DESTDIR=${D} || die
- make docs DESTDIR=${D} || die
-
- dodoc ChangeLog INSTALL README TODO
-
+src_install() {
+ make install DESTDIR=${D} || die
+ make docs DESTDIR=${D} || die
+ dodoc ChangeLog INSTALL README TODO
}
-
-
diff --git a/net-irc/kvirc/kvirc-3.0.0_beta2-r1.ebuild b/net-irc/kvirc/kvirc-3.0.0_beta2-r1.ebuild
index 05828fc2cc4d..5b32dad6ee9f 100644
--- a/net-irc/kvirc/kvirc-3.0.0_beta2-r1.ebuild
+++ b/net-irc/kvirc/kvirc-3.0.0_beta2-r1.ebuild
@@ -1,19 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-3.0.0_beta2-r1.ebuild,v 1.1 2003/05/22 07:52:33 pauldv Exp $
-IUSE="kde esd ipv6 ssl"
+# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-3.0.0_beta2-r1.ebuild,v 1.2 2003/08/03 03:34:50 vapier Exp $
+
inherit kde-base
MYP=${P//_/-}
MYPV=${PV//_/-}
S=${WORKDIR}/${MYP}
DESCRIPTION="An advanced IRC Client"
+HOMEPAGE="http://www.kvirc.net/"
SRC_URI="ftp://ftp.kvirc.net/kvirc/${MYPV}/source/${MYP}.tar.gz"
-HOMEPAGE="http://www.kvirc.net"
-SLOT="3"
LICENSE="kvirc"
+SLOT="3"
KEYWORDS="~x86"
+IUSE="kde esd ipv6 ssl debug"
use kde && need-kde 3 || need-qt 3
@@ -22,7 +23,7 @@ newdepend "esd? ( media-sound/esound )
oss? ( media-libs/audiofile )"
use kde || newdepend "arts? ( kde-base/arts )"
-[ -n "$DEBUG" ] && myconf="$myconf --with-debug-symbols"
+[ `use debug` ] && myconf="$myconf --with-debug-symbols"
#disabling as the assembly is less than stable
#[ "$ARCH" == "x86" ] && myconf="$myconf --with-ix86-asm"
@@ -46,31 +47,24 @@ use ssl || myconf="$myconf --without-ssl-support"
myconf="$myconf --with-aa-fonts"
src_compile() {
+ use kde && kde_src_compile myconf
- use kde && kde_src_compile myconf
+ # always install into /usr regardless of kde support
+ # kvirc doesn't have a kde-like installed file structure anyway
+ myconf="$myconf --prefix=/usr -v"
- # always install into /usr regardless of kde support
- # kvirc doesn't have a kde-like installed file structure anyway
- myconf="$myconf --prefix=/usr -v"
-
- # make sure we disable kde support as the configure script can auto-enable
- # it when it isn't wanted
- use kde || export KDEDIR=""
-
- need-automake 1.5
- need-autoconf 2.5
-
- kde_src_compile configure make
+ # make sure we disable kde support as the configure script can auto-enable
+ # it when it isn't wanted
+ use kde || export KDEDIR=""
-}
+ need-automake 1.5
+ need-autoconf 2.5
-src_install () {
-
- make install DESTDIR=${D} || die
- make docs DESTDIR=${D} || die
-
- dodoc ChangeLog INSTALL README TODO
-
+ kde_src_compile configure make
}
-
+src_install() {
+ make install DESTDIR=${D} || die
+ make docs DESTDIR=${D} || die
+ dodoc ChangeLog INSTALL README TODO
+}