summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2006-10-22 12:09:47 +0000
committerSven Wegener <swegener@gentoo.org>2006-10-22 12:09:47 +0000
commit1f01b6383dea3ae39fb080b74d7961b6b2b143a4 (patch)
tree3a78de9f98b8ff640062470043a79444dfdb3e58 /net-irc
parentarm stable (diff)
downloadgentoo-2-1f01b6383dea3ae39fb080b74d7961b6b2b143a4.tar.gz
gentoo-2-1f01b6383dea3ae39fb080b74d7961b6b2b143a4.tar.bz2
gentoo-2-1f01b6383dea3ae39fb080b74d7961b6b2b143a4.zip
Version bump.
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/atheme/ChangeLog9
-rw-r--r--net-irc/atheme/atheme-0.2.2.ebuild4
-rw-r--r--net-irc/atheme/atheme-1.2.1.ebuild84
-rw-r--r--net-irc/atheme/files/atheme-1.2.1-postgresl.patch99
-rw-r--r--net-irc/atheme/files/digest-atheme-1.2.13
5 files changed, 196 insertions, 3 deletions
diff --git a/net-irc/atheme/ChangeLog b/net-irc/atheme/ChangeLog
index 4d04eddb185a..0f7bc5953781 100644
--- a/net-irc/atheme/ChangeLog
+++ b/net-irc/atheme/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/atheme
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme/ChangeLog,v 1.3 2006/04/11 21:09:53 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme/ChangeLog,v 1.4 2006/10/22 12:09:47 swegener Exp $
+
+*atheme-1.2.1 (22 Oct 2006)
+
+ 22 Oct 2006; Sven Wegener <swegener@gentoo.org>
+ +files/atheme-1.2.1-postgresl.patch, atheme-0.2.2.ebuild,
+ +atheme-1.2.1.ebuild:
+ Version bump.
11 Apr 2006; Sven Wegener <swegener@gentoo.org> +files/atheme.initd,
atheme-0.2.2.ebuild:
diff --git a/net-irc/atheme/atheme-0.2.2.ebuild b/net-irc/atheme/atheme-0.2.2.ebuild
index dbe1318fd377..1f46c1b00963 100644
--- a/net-irc/atheme/atheme-0.2.2.ebuild
+++ b/net-irc/atheme/atheme-0.2.2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme/atheme-0.2.2.ebuild,v 1.3 2006/04/11 21:09:53 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme/atheme-0.2.2.ebuild,v 1.4 2006/10/22 12:09:47 swegener Exp $
inherit eutils autotools
DESCRIPTION="A portable, secure set of open source, and modular IRC services"
HOMEPAGE="http://atheme.org/"
-SRC_URI="mirror://gentoo/${P}.tgz"
+SRC_URI="http://www.atheme.org/releases/${P}.tgz"
LICENSE="BSD"
SLOT="0"
diff --git a/net-irc/atheme/atheme-1.2.1.ebuild b/net-irc/atheme/atheme-1.2.1.ebuild
new file mode 100644
index 000000000000..8872e0c2b8ae
--- /dev/null
+++ b/net-irc/atheme/atheme-1.2.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme/atheme-1.2.1.ebuild,v 1.1 2006/10/22 12:09:47 swegener Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="A portable, secure set of open source, and modular IRC services"
+HOMEPAGE="http://atheme.org/"
+SRC_URI="http://www.atheme.org/releases/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~sparc ~x86"
+IUSE="largenet postgres"
+
+RDEPEND="postgres? ( dev-db/postgresql )"
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.59"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/atheme-1.2.1-postgresl.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --prefix=/var/lib/atheme \
+ $(use_enable postgresql) \
+ $(use_with largenet large-net) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make prefix="${D}"/var/lib/atheme install || die "make install failed"
+
+ dodir /usr/{lib,share}/atheme /etc
+ keepdir /var/lib/atheme/var
+ fowners atheme:atheme /var/lib/atheme/var
+ fperms 750 /var/lib/atheme/var
+
+ local dir
+ for dir in backend crypto modules protocol
+ do
+ mv "${D}"/var/lib/atheme/${dir} "${D}"/usr/lib/atheme
+ dosym /usr/lib/atheme/${dir} /var/lib/atheme/${dir}
+ done
+
+ mv "${D}"/var/lib/atheme/help "${D}"/usr/share/atheme
+ dosym /usr/share/atheme/help /var/lib/atheme/help
+
+ mv "${D}"/var/lib/atheme/etc "${D}"/etc/atheme
+ cp "${D}"/etc/atheme/example.conf "${D}"/etc/atheme/atheme.conf
+ fowners root:atheme /etc/atheme/atheme.conf
+ fperms 640 /etc/atheme/atheme.conf
+ dosym /etc/atheme /var/lib/atheme/etc
+
+ dobin "${D}"/var/lib/atheme/bin/atheme || die "dobin failed"
+
+ dodoc \
+ ChangeLog INSTALL README \
+ doc/{example_module.c,LICENSE,SQL,RELEASE} \
+ || die "dodoc failed"
+
+ newinitd "${FILESDIR}"/atheme.initd atheme
+
+ # And remove stuff we don't need
+ rm -rf "${D}"/var/lib/atheme/{bin,doc}
+}
+
+pkg_setup() {
+ enewgroup atheme
+ enewuser atheme -1 -1 /var/lib/atheme atheme
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Don't forget to edit /etc/atheme/atheme.conf!"
+ einfo
+}
diff --git a/net-irc/atheme/files/atheme-1.2.1-postgresl.patch b/net-irc/atheme/files/atheme-1.2.1-postgresl.patch
new file mode 100644
index 000000000000..a5ffdcb3d249
--- /dev/null
+++ b/net-irc/atheme/files/atheme-1.2.1-postgresl.patch
@@ -0,0 +1,99 @@
+diff -Nur atheme-1.2.1.orig/configure.ac atheme-1.2.1/configure.ac
+--- atheme-1.2.1.orig/configure.ac 2006-07-10 13:23:14.000000000 +0000
++++ atheme-1.2.1/configure.ac 2006-10-22 11:52:40.281188612 +0000
+@@ -196,43 +196,61 @@
+
+ POSTGRESQL="yes"
+
+-AC_MSG_CHECKING(for PostgreSQL include directory)
+-if test -d /usr/include/pgsql ; then
+- pg_inc_dir="/usr/include/pgsql"
+-elif test -f /usr/local/include/libpq-fe.h ; then
+-# kludge for freebsd ports, found on liveharmony boxes. --nenolod
+- pg_inc_dir="/usr/local/include"
+- LDFLAGS="-L/usr/local/lib"
+-elif test -d /usr/include/postgresql ; then
+- pg_inc_dir="/usr/include/postgresql"
+-elif test -d /usr/local/psql/include ; then
+- pg_inc_dir="/usr/local/psql/include"
+-elif test -d /usr/local/include/postgresql ; then
+- pg_inc_dir="/usr/local/include/postgresql"
+-elif test -d /usr/local/pgsql/include ; then
+- pg_inc_dir="/usr/local/pgsql/include"
+-elif test -d /usr/local/include/psql ; then
+- pg_inc_dir="/usr/local/include/psql"
+-elif test -d /opt/psql/include ; then
+- pg_inc_dir="/opt/psql/include"
+-else
+- pg_inc_dir="no"
+- PQLIB=""
+- POSTGRESQL="no"
+-fi
++AC_ARG_ENABLE(postgresql,
++AC_HELP_STRING([--enable-postgresql], [Enables PostgreSQL backend support.]),
++[
++ case "$enableval" in
++ yes|no)
++ POSTGRESQL="$enableval"
++ ;;
++ *)
++ AC_MSG_ERROR([Invalid argument to --enable-postgresql (expecting either 'yes' or 'no')])
++ ;;
++ esac
++])
++
++AC_MSG_CHECKING([whether to enable PostgreSQL backend support])
++AC_MSG_RESULT($POSTGRESQL)
++
++if test "x$POSTGRESQL" = xyes; then
++ AC_MSG_CHECKING(for PostgreSQL include directory)
++ if test -d /usr/include/pgsql ; then
++ pg_inc_dir="/usr/include/pgsql"
++ elif test -f /usr/local/include/libpq-fe.h ; then
++ # kludge for freebsd ports, found on liveharmony boxes. --nenolod
++ pg_inc_dir="/usr/local/include"
++ LDFLAGS="-L/usr/local/lib"
++ elif test -d /usr/include/postgresql ; then
++ pg_inc_dir="/usr/include/postgresql"
++ elif test -d /usr/local/psql/include ; then
++ pg_inc_dir="/usr/local/psql/include"
++ elif test -d /usr/local/include/postgresql ; then
++ pg_inc_dir="/usr/local/include/postgresql"
++ elif test -d /usr/local/pgsql/include ; then
++ pg_inc_dir="/usr/local/pgsql/include"
++ elif test -d /usr/local/include/psql ; then
++ pg_inc_dir="/usr/local/include/psql"
++ elif test -d /opt/psql/include ; then
++ pg_inc_dir="/opt/psql/include"
++ else
++ pg_inc_dir="no"
++ PQLIB=""
++ POSTGRESQL="no"
++ fi
+
+-POSTGRESQL_C=""
++ POSTGRESQL_C=""
+
+-AC_MSG_RESULT($pg_inc_dir)
++ AC_MSG_RESULT($pg_inc_dir)
+
+-if test "$pg_inc_dir" != "no"; then
+- AC_CHECK_HEADER($pg_inc_dir/libpq-fe.h, [
+- PGINC="-I$pg_inc_dir"
+- AC_CHECK_LIB(pq, PQconnectdb, [PQLIB="-lpq"
+- POSTGRESQL_C="postgresql.c"])
+- ])
+-else
+- POSTGRESQL="no"
++ if test "$pg_inc_dir" != "no"; then
++ AC_CHECK_HEADER($pg_inc_dir/libpq-fe.h, [
++ PGINC="-I$pg_inc_dir"
++ AC_CHECK_LIB(pq, PQconnectdb, [PQLIB="-lpq"
++ POSTGRESQL_C="postgresql.c"])
++ ])
++ else
++ POSTGRESQL="no"
++ fi
+ fi
+
+ AC_SUBST(POSTGRESQL_C)
diff --git a/net-irc/atheme/files/digest-atheme-1.2.1 b/net-irc/atheme/files/digest-atheme-1.2.1
new file mode 100644
index 000000000000..a63f719bc24d
--- /dev/null
+++ b/net-irc/atheme/files/digest-atheme-1.2.1
@@ -0,0 +1,3 @@
+MD5 10d71f11dd86f27866cf6a66f110124c atheme-1.2.1.tgz 725341
+RMD160 8a5fe685b79fcf6c800bd7a59b3c21cc29118a99 atheme-1.2.1.tgz 725341
+SHA256 e1eb162e0ce0be8d4f6a45c0210b8a9b5165789d80bb8c9c57ae01d8f781590f atheme-1.2.1.tgz 725341