summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2014-09-03 01:36:35 +0000
committerNathan Phillip Brink <binki@gentoo.org>2014-09-03 01:36:35 +0000
commit22527784724fdeb1cd5de7c87081158b267b958a (patch)
tree26b284aea5d2fa03faf2c0d8cfe8566c02b8a89c /net-irc
parentVersion bump. (diff)
downloadgentoo-2-22527784724fdeb1cd5de7c87081158b267b958a.tar.gz
gentoo-2-22527784724fdeb1cd5de7c87081158b267b958a.tar.bz2
gentoo-2-22527784724fdeb1cd5de7c87081158b267b958a.zip
Bump to epic5-1.1.10 and eradicate einstall() for bug #521590.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 743A52E86BA81050)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/epic5/ChangeLog10
-rw-r--r--net-irc/epic5/epic5-1.1.10.ebuild80
-rw-r--r--net-irc/epic5/files/epic5-1.1.10-ruby-automagic-as-needed.patch134
-rw-r--r--net-irc/epic5/files/epic5-1.1.10-tcl-automagic-as-needed.patch116
-rw-r--r--net-irc/epic5/files/epic5-1.1.10-without-localdir.patch66
5 files changed, 405 insertions, 1 deletions
diff --git a/net-irc/epic5/ChangeLog b/net-irc/epic5/ChangeLog
index 1f5feebef70f..bb50fcfe3e2f 100644
--- a/net-irc/epic5/ChangeLog
+++ b/net-irc/epic5/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-irc/epic5
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/epic5/ChangeLog,v 1.21 2014/03/25 08:03:27 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic5/ChangeLog,v 1.22 2014/09/03 01:36:35 binki Exp $
+
+*epic5-1.1.10 (03 Sep 2014)
+
+ 03 Sep 2014; Nathan Phillip Brink <binki@gentoo.org> +epic5-1.1.10.ebuild,
+ +files/epic5-1.1.10-ruby-automagic-as-needed.patch,
+ +files/epic5-1.1.10-tcl-automagic-as-needed.patch,
+ +files/epic5-1.1.10-without-localdir.patch:
+ Bump to epic5-1.1.10 and eradicate einstall() for bug #521590.
*epic5-1.1.7 (25 Mar 2014)
diff --git a/net-irc/epic5/epic5-1.1.10.ebuild b/net-irc/epic5/epic5-1.1.10.ebuild
new file mode 100644
index 000000000000..b112bcb961da
--- /dev/null
+++ b/net-irc/epic5/epic5-1.1.10.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic5/epic5-1.1.10.ebuild,v 1.1 2014/09/03 01:36:35 binki Exp $
+
+EAPI=4
+
+USE_RUBY="ruby19"
+RUBY_OPTIONAL=yes
+inherit autotools eutils multilib ruby-ng toolchain-funcs
+
+DESCRIPTION="Epic5 IRC Client"
+SRC_URI="ftp://ftp.epicsol.org/pub/epic/EPIC5-PRODUCTION/${P}.tar.bz2"
+HOMEPAGE="http://epicsol.org/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="archive ipv6 perl tcl ruby socks5 valgrind"
+
+RDEPEND="virtual/libiconv
+ >=dev-libs/openssl-0.9.8e-r3
+ >=sys-libs/ncurses-5.6-r2
+ archive? ( app-arch/libarchive )
+ perl? ( >=dev-lang/perl-5.8.8-r2 )
+ tcl? ( dev-lang/tcl )
+ socks5? ( net-proxy/dante )
+ ruby? ( $(ruby_implementations_depend) )"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )"
+REQUIRED_USE="ruby? ( $(ruby_get_use_targets) )"
+
+S=${WORKDIR}/${P}
+
+pkg_setup() {
+ # bug #489608, bug #497080
+ use ruby && ruby-ng_pkg_setup
+}
+
+# Don't use ruby-ng's separated sources support:
+src_unpack() {
+ default
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.2-libarchive-automagic.patch \
+ "${FILESDIR}"/${P}-ruby-automagic-as-needed.patch \
+ "${FILESDIR}"/${P}-tcl-automagic-as-needed.patch \
+ "${FILESDIR}"/${PN}-1.1.2-perl-automagic-as-needed.patch \
+ "${FILESDIR}"/${P}-without-localdir.patch
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ --libexecdir="${EPREFIX}"/usr/lib/misc \
+ $(use_with archive libarchive) \
+ $(use_with ipv6) \
+ $(use_with perl) \
+ $(use_with ruby ruby "$(ruby_implementation_command ${USE_RUBY})") \
+ $(use_with socks5) \
+ $(use_with tcl tcl "${EPREFIX}"/usr/$(get_libdir)/tclConfig.sh) \
+ $(use_with valgrind valgrind)
+}
+
+src_compile() {
+ # parallel build failure
+ emake -j1
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+ dodoc BUG_FORM COPYRIGHT EPIC4-USERS-README README KNOWNBUGS VOTES
+
+ cd "${S}"/doc || die
+ docinto doc
+ dodoc \
+ *.txt colors EPIC* IRCII_VERSIONS missing \
+ nicknames outputhelp README.SSL SILLINESS TS4
+}
diff --git a/net-irc/epic5/files/epic5-1.1.10-ruby-automagic-as-needed.patch b/net-irc/epic5/files/epic5-1.1.10-ruby-automagic-as-needed.patch
new file mode 100644
index 000000000000..ba277ca8f60b
--- /dev/null
+++ b/net-irc/epic5/files/epic5-1.1.10-ruby-automagic-as-needed.patch
@@ -0,0 +1,134 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: Fix up linking against libruby when using
+ LDFLAGS=-Wl,--as-needed. Also allow ruby to be a non-automagic
+ dependency.
+
+--- a/configure.in Tue Mar 25 07:39:34 2014 +0000
++++ b/configure.in Tue Mar 25 07:55:14 2014 +0000
+@@ -1168,34 +1168,28 @@
+ dnl
+ dnl Ruby support?
+ dnl
+-AC_ARG_WITH(ruby,
+-[ --with-ruby[=PATH_TO_RUBY_EXE] Compile with ruby support.],
+-[
+- rubyexe=$withval
+-],
+- rubyexe=yes
+-)
+-
+-if test "x$rubyexe" = "xyes"; then
+- for i in ruby ruby20 ruby19 ruby18 ruby2.0 ruby1.9.1 ruby1.9 ruby1.8; do
+- $i -h 2>&1 >/dev/null && rubyexe=$i && break
+- done
+- if test "x$rubyexe" = "xyes"; then
+- rubyexe=no
+- fi
+-fi
++AC_ARG_WITH([ruby],
++ [AS_HELP_STRING([--with-ruby[=PATH_TO_RUBY_EXE]], [Compile with ruby support.])],
++ [], [with_ruby=maybe])
+
+-if test "x$rubyexe" = "xno"; then
++with_ruby_errormsg="--with-ruby was specified but I could not locate ruby. Please try specifying --with-ruby=/path/to/ruby or --without-ruby."
++AC_MSG_CHECKING([whether to support Ruby])
++if test "x$with_ruby" = "xno" ; then
+ AC_MSG_CHECKING(whether to support Ruby)
+ AC_MSG_RESULT(no)
+ else
+- AC_CHECK_PROG(RUBYPROG, $rubyexe, "yes", "no")
+- AC_MSG_CHECKING(whether to support Ruby)
+- if test $RUBYPROG != "yes" ; then
+- AC_MSG_RESULT(no)
++ AC_MSG_RESULT(yes)
++ AS_IF([test "x$with_ruby" = "xyes" -o "x$with_ruby" = "xmaybe"],
++ [rubyexe=ruby],
++ [rubyexe="$with_ruby"])
++ dnl Support --with-ruby being passed a full path instead of just an executable name.
++ AS_IF([test -x "$rubyexe"],
++ [RUBYPROG=yes],
++ [AC_CHECK_PROG([RUBYPROG], [$rubyexe], [yes], [no])])
++ if test "x$RUBYPROG" = xno ; then
++ AS_IF([test "x$with_ruby" != "xmaybe"],
++ [AC_MSG_ERROR([$with_ruby_errormsg])])
+ else
+- AC_MSG_RESULT(yes)
+-
+ dnl ----
+ dnl Look first for Ruby 1.9
+ incdir=`$rubyexe -rrbconfig -e 'puts RbConfig::CONFIG[["rubyhdrdir"]]'`
+@@ -1208,15 +1205,15 @@
+
+ rubylibs=`$rubyexe -rrbconfig -e 'puts RbConfig::CONFIG[["LIBRUBYARG"]]'`
+ extralibs=`$rubyexe -rrbconfig -e 'puts RbConfig::CONFIG[["LIBS"]]'`
+- RUBYLDFLAGS="$rubylibs $extralibs"
++ RUBYLIBS="$rubylibs $extralibs"
+ RUBYDOTOH="ruby.o"
+
+ AC_MSG_CHECKING(whether embedded ruby works the way I expect)
+ have_embedded_ruby="no"
+ old_CFLAGS="$CFLAGS"
+- old_LDFLAGS="$LDFLAGS"
++ old_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $RUBYCFLAGS"
+- LDFLAGS="$LDFLAGS $RUBYLDFLAGS"
++ LIBS="$LIBS $RUBYLIBS"
+ AC_TRY_LINK([
+ #include <ruby.h>
+ VALUE epic_echo (VALUE module, VALUE string)
+@@ -1241,9 +1238,9 @@
+ AC_MSG_RESULT(no)
+ AC_MSG_CHECKING(whether ruby requires -pthread to link)
+ RUBYCFLAGS="$RUBYCFLAGS -pthread"
+- RUBYLDFLAGS="$RUBYLDFLAGS -pthread"
+- CFLAGS="$CFLAGS $RUBYCFLAGS"
+- LDFLAGS="$LDFLAGS $RUBYLDFLAGS"
++ RUBYLIBS="$RUBYLIBS -pthread"
++ CFLAGS="$old_CFLAGS $RUBYCFLAGS"
++ LIBS="$old_LIBS $RUBYLIBS"
+
+ AC_TRY_LINK([
+ #include <ruby.h>
+@@ -1268,17 +1265,19 @@
+ fi
+
+ CFLAGS="$old_CFLAGS"
+- LDFLAGS="$old_LDFLAGS"
++ LIBS="$old_LIBS"
+ if test $have_embedded_ruby = "yes" ; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_RUBY)
+ AC_DEFINE(RUBYCFLAGS)
+- AC_DEFINE(RUBYLDFLAGS)
++ AC_DEFINE(RUBYLIBS)
+ else
++ AS_IF([test "x$with_ruby" != "xmaybe"],
++ [AC_MSG_ERROR([$with_ruby_errormsg])])
+ RUBYDOTOH=""
+ HAVE_RUBY=""
+ RUBYCFLAGS=""
+- RUBYLDFLAGS=""
++ RUBYLIBS=""
+ AC_MSG_RESULT(no, sorry)
+ fi
+ fi
+@@ -1376,7 +1375,7 @@
+ AC_SUBST(LDFLAGS)
+ AC_SUBST(RUBYDOTOH)
+ AC_SUBST(RUBYCFLAGS)
+-AC_SUBST(RUBYLDFLAGS)
++AC_SUBST(RUBYLIBS)
+ AC_SUBST(TCLDOTOH)
+ AC_SUBST(TCLCFLAGS)
+ AC_SUBST(TCLLDFLAGS)
+--- a/source/Makefile.in Tue Mar 25 07:39:34 2014 +0000
++++ b/source/Makefile.in Tue Mar 25 07:55:14 2014 +0000
+@@ -38,7 +38,7 @@
+ epic5: $(OBJECTS)
+ sh info.c.sh
+ $(CC) $(CFLAGS) $(INCLUDES) -c info.c
+- $(CC) $(CFLAGS) $(LDFLAGS) -o epic5 $(OBJECTS) info.o @PERLLDFLAGS@ @TCLLDFLAGS@ @RUBYLDFLAGS@ $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o epic5 $(OBJECTS) info.o @PERLLDFLAGS@ @TCLLDFLAGS@ @RUBYLIBS@ $(LIBS)
+ $(RM) info.c info.o
+ clean::
+ $(RM) epic5 $(OBJECTS)
diff --git a/net-irc/epic5/files/epic5-1.1.10-tcl-automagic-as-needed.patch b/net-irc/epic5/files/epic5-1.1.10-tcl-automagic-as-needed.patch
new file mode 100644
index 000000000000..5b5b932b06bc
--- /dev/null
+++ b/net-irc/epic5/files/epic5-1.1.10-tcl-automagic-as-needed.patch
@@ -0,0 +1,116 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: Make dependence on TCL not be automagic (so that --with-tcl
+ errors out if TCL can't be found and not specifying --with-tcl
+ does the normal automagic behavior). Support
+ LDFLAGS=-Wl,--as-needed by using LIBS instead of LDFLAGS for
+ -ltcl as appropriate.
+
+--- a/configure.in
++++ b/configure.in
+@@ -1122,43 +1122,41 @@
+ dnl
+ dnl Tcl support?
+ dnl
+-AC_ARG_WITH(tcl,
+-[ --with-tcl[=PATH_TO_tclConfig.sh] Compile with tcl support.],
+-[
+- tclconfig=$withval
+-],
+- tclconfig="yes"
+-)
+-
+-if test "x$tclconfig" = "xyes" ; then
+- for i in /usr/lib $localdir/lib $localdir/lib/tcl8.4 ; do
+- if test -r $i/tclConfig.sh ; then
+- tclconfig=$i/tclConfig.sh
+- break;
+- fi
+- done
+-fi
++AC_ARG_WITH([tcl], [AS_HELP_STRING([--with-tcl[=PATH_TO_tclConfig.sh]], [Compile with tcl support.])],
++ [], [with_tcl=maybe])
+
+ AC_MSG_CHECKING(whether to support TCL)
+-if test "x$tclconfig" = "xno"; then
++if test "x$with_tcl" = "xno"; then
+ AC_MSG_RESULT(no)
+ else
+- if test ! -r $tclconfig ; then
++ with_tcl_errormsg="You specified --with-tcl=$with_tcl but I could not find TCL. Please specify --with-tcl=/path/to/tclConfig.sh or remove --with-tcl from ./configure's commandline."
++ if test "x$with_tcl" = "xmaybe" -o "x$with_tcl" = "xyes"; then
++ for i in /usr/lib /usr/local/lib /usr/local/lib/tcl8.4 ; do
++ if test -r "$i"/tclConfig.sh ; then
++ tclconfig="$i"/tclConfig.sh
++ break;
++ fi
++ done
++ else
++ tclconfig="$with_tcl"
++ fi
++ if test ! -r "$tclconfig" ; then
++ dnl Avoid being automagic unless if the user wants us to be.
++ AS_IF([test "x$with_tcl" != "xmaybe"],
++ [AC_MSG_ERROR([$with_tcl_errormsg])])
+ AC_MSG_RESULT(no)
+ else
+ AC_MSG_RESULT(yes)
+- TCLCFLAGS=`(. $tclconfig && echo $TCL_INCLUDE_SPEC)`
+- TCLLDFLAGS1=`(. $tclconfig && echo $TCL_LIB_SPEC)`
+- TCLLDFLAGS2=`(. $tclconfig && echo $TCL_LIBS)`
+- TCLLDFLAGS=$(eval echo "$TCLLDFLAGS1 $TCLLDFLAGS2")
++ TCLCFLAGS=`(. "$tclconfig" && echo $TCL_INCLUDE_SPEC)`
++ TCLLIBS=`(. "$tclconfig" && echo $TCL_LIB_SPEC $TCL_LIBS)`
+ TCLDOTOH="tcl.o"
+
+ AC_MSG_CHECKING(whether embedded tcl works the way I expect)
+ have_embedded_tcl="no"
+ old_CFLAGS="$CFLAGS"
+- old_LDFLAGS="$LDFLAGS"
++ old_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $TCLCFLAGS"
+- LDFLAGS="$LDFLAGS $TCLLDFLAGS"
++ LIBS="$LIBS $TCLLIBS"
+ AC_TRY_LINK([
+ #include <tcl.h>
+ Tcl_Interp *my_tcl;
+@@ -1175,14 +1173,16 @@
+ ], have_embedded_tcl="yes")
+
+ CFLAGS="$old_CFLAGS"
+- LDFLAGS="$old_LDFLAGS"
++ LIBS="$old_LIBS"
+ if test $have_embedded_tcl = "yes" ; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_TCL)
+ AC_DEFINE(TCLCFLAGS)
+- AC_DEFINE(TCLLDFLAGS)
++ AC_DEFINE(TCLLIBS)
+ else
+- AC_MSG_RESULT(no, sorry)
++ AS_IF([test "$with_tcl" != "xmaybe"],
++ [AC_MSG_ERROR([$with_tcl_errormsg])])
++ AC_MSG_RESULT(no, sorry)
+ fi
+ fi
+ fi
+@@ -1383,7 +1383,7 @@
+ AC_SUBST(RUBYLIBS)
+ AC_SUBST(TCLDOTOH)
+ AC_SUBST(TCLCFLAGS)
+-AC_SUBST(TCLLDFLAGS)
++AC_SUBST(TCLLIBS)
+ AC_SUBST(PERLDOTOH)
+ AC_SUBST(PERLCFLAGS)
+ AC_SUBST(PERLLDFLAGS)
+
+--- a/source/Makefile.in
++++ b/source/Makefile.in
+@@ -38,7 +38,7 @@
+ epic5: $(OBJECTS)
+ sh info.c.sh
+ $(CC) $(CFLAGS) $(INCLUDES) -c info.c
+- $(CC) $(CFLAGS) $(LDFLAGS) -o epic5 $(OBJECTS) info.o @PERLLDFLAGS@ @TCLLDFLAGS@ @RUBYLIBS@ $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o epic5 $(OBJECTS) info.o @PERLLDFLAGS@ @TCLLIBS@ @RUBYLIBS@ $(LIBS)
+ $(RM) info.c info.o
+ clean::
+ $(RM) epic5 $(OBJECTS)
diff --git a/net-irc/epic5/files/epic5-1.1.10-without-localdir.patch b/net-irc/epic5/files/epic5-1.1.10-without-localdir.patch
new file mode 100644
index 000000000000..4caccad764a8
--- /dev/null
+++ b/net-irc/epic5/files/epic5-1.1.10-without-localdir.patch
@@ -0,0 +1,66 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: Drop some automatic probing of /usr/local and /opt and etc., Gentoo users know to use CPPFLAGS/CFLAGS/LDFLAGS.
+Date: 2014-08-30
+
+--- a/configure.in
++++ b/configure.in
+@@ -33,58 +33,6 @@
+ AC_AIX
+
+ dnl ----------------------------------------------------------
+-AC_MSG_CHECKING([for an extra library directory])
+-AC_ARG_WITH([localdir],
+-[ --with-localdir=/usr/local An extra directory to look for stuff.],[
+- if test "x$withval" = "x" ; then
+- if test -d /usr/local/lib ; then
+- withval="/usr/local"
+- elif test -d /usr/pkg/lib ; then
+- withval="/usr/pkg"
+- elif test -d /opt/lib ; then
+- withval="/opt"
+- else
+- with_extra_libdir="no"
+- fi
+- elif test -d "$withval" ; then
+- with_extra_libdir="yes"
+- else
+- with_extra_libdir="no"
+- fi
+-
+- if test "x$withval" != "x" ; then
+- LIBS="-L$withval/lib $LIBS"
+- CFLAGS="-I$withval/include/ $CFLAGS"
+- localdir=$withdir
+- with_extra_libdir="yes"
+- else
+- with_extra_libdir="no"
+- fi
+-],[
+- if test "x$withval" = "x" ; then
+- if test -d /usr/local/lib ; then
+- withval="/usr/local"
+- elif test -d /usr/pkg/lib ; then
+- withval="/usr/pkg"
+- elif test -d /opt/lib ; then
+- withval="/opt"
+- else
+- with_extra_libdir="no"
+- fi
+- fi
+-
+- if test "x$withval" != "x" ; then
+- LIBS="-L$withval/lib $LIBS"
+- CFLAGS="-I$withval/include/ $CFLAGS"
+- localdir=$withdir
+- with_extra_libdir="yes"
+- else
+- with_extra_libdir="no"
+- fi
+-])
+-AC_MSG_RESULT([$with_extra_libdir, $withval])
+-
+-dnl ----------------------------------------------------------
+ dnl ----------------------------------------------------------
+ dnl
+ dnl System specific checks
+