summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-04-26 01:27:08 +0000
committerTravis Tilley <lv@gentoo.org>2004-04-26 01:27:08 +0000
commit3bd9bfe5475c92f3011391c5aa4677256e03c2f1 (patch)
tree1fc4c8bc22bfa5643d71f43d01cd2f1e473e8647 /net-irc
parentAdd die following econf for bug 48950 (Manifest recommit) (diff)
downloadgentoo-2-3bd9bfe5475c92f3011391c5aa4677256e03c2f1.tar.gz
gentoo-2-3bd9bfe5475c92f3011391c5aa4677256e03c2f1.tar.bz2
gentoo-2-3bd9bfe5475c92f3011391c5aa4677256e03c2f1.zip
ported to amd64 and added amd64 keyword
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/bitchx/ChangeLog6
-rw-r--r--net-irc/bitchx/bitchx-1.1.ebuild6
-rw-r--r--net-irc/bitchx/files/BitchX-64bit.patch22
3 files changed, 31 insertions, 3 deletions
diff --git a/net-irc/bitchx/ChangeLog b/net-irc/bitchx/ChangeLog
index 58bd831edd33..432681d6914c 100644
--- a/net-irc/bitchx/ChangeLog
+++ b/net-irc/bitchx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/bitchx
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/ChangeLog,v 1.39 2004/04/15 23:30:34 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/ChangeLog,v 1.40 2004/04/26 01:27:08 lv Exp $
+
+ 25 Apr 2004; Travis Tilley <lv@gentoo.org> +files/BitchX-64bit.patch,
+ bitchx-1.1.ebuild:
+ ported to amd64
15 Apr 2004; Jason Wever <weeve@gentoo.org> bitchx-1.1.ebuild:
Stable on sparc.
diff --git a/net-irc/bitchx/bitchx-1.1.ebuild b/net-irc/bitchx/bitchx-1.1.ebuild
index 625ef8cbc14b..a6c572ee42e4 100644
--- a/net-irc/bitchx/bitchx-1.1.ebuild
+++ b/net-irc/bitchx/bitchx-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/bitchx-1.1.ebuild,v 1.4 2004/04/15 23:30:34 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bitchx/bitchx-1.1.ebuild,v 1.5 2004/04/26 01:27:08 lv Exp $
inherit flag-o-matic eutils
@@ -12,7 +12,7 @@ SRC_URI="ftp://ftp.bitchx.com/pub/BitchX/source/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~ppc sparc hppa ~alpha"
+KEYWORDS="x86 ~ppc sparc hppa ~alpha amd64"
IUSE="ssl esd gnome xmms ipv6 gtk cjk"
DEPEND=">=sys-libs/ncurses-5.1
@@ -32,12 +32,14 @@ src_unpack() {
use cjk && epatch ${FILESDIR}/${PV}/${P}-cjk.patch
epatch ${FILESDIR}/${PV}/${P}-hebrew.patch
epatch ${FILESDIR}/${PV}/${P}-freenode.patch
+ use amd64 && epatch ${FILESDIR}/BitchX-64bit.patch
}
src_compile() {
# BitchX needs to be merged with -fPIC on alpha/hppa boxes #10932
[ "${ARCH}" == "alpha" ] && append-flags "-fPIC"
[ "${ARCH}" == "hppa" ] && append-flags "-fPIC"
+ [ "${ARCH}" == "amd64" ] && append-flags "-fPIC"
replace-flags -O[3-9] -O2
local myconf
diff --git a/net-irc/bitchx/files/BitchX-64bit.patch b/net-irc/bitchx/files/BitchX-64bit.patch
new file mode 100644
index 000000000000..369f2baafbfc
--- /dev/null
+++ b/net-irc/bitchx/files/BitchX-64bit.patch
@@ -0,0 +1,22 @@
+--- BitchX/include/modval.h.64bit 2003-02-10 12:55:46.000000000 +0100
++++ BitchX/include/modval.h 2003-02-10 12:56:08.000000000 +0100
+@@ -318,7 +318,7 @@
+ #define show_window(x) ((void) (global[SHOW_WINDOW]((Window *)x)))
+ #define get_status_by_refnum(x, y) ((char *) (global[GET_STATUS_BY_REFNUM]((unsigned int)x, (unsigned int)y)))
+ #define get_visible_by_refnum(x) ((int) (global[GET_VISIBLE_BY_REFNUM]((char *)x)))
+-#define get_window_by_desc(x) ((Window *) (global[GET_WINDOW_BY_DESC]((unsigned int)x)))
++#define get_window_by_desc(x) ((Window *) (global[GET_WINDOW_BY_DESC]((unsigned long)x)))
+ #define get_window_by_refnum(x) ((Window *) (global[GET_WINDOW_BY_REFNUM]((unsigned int)x)))
+ #define get_window_by_name(x) ((Window *) (global[GET_WINDOW_BY_NAME]((char *)x)))
+ #define next_window(x, y) ((void) (global[FUNC_NEXT_WINDOW]((char)x, (char *)y)))
+--- BitchX/include/module.h.64bit 2003-02-10 12:48:32.000000000 +0100
++++ BitchX/include/module.h 2003-02-10 12:48:43.000000000 +0100
+@@ -15,7 +15,7 @@
+
+ #include "struct.h"
+
+-typedef int (*Function_ptr)();
++typedef long (*Function_ptr)();
+
+ #ifdef WANT_DLL
+ #ifdef HPUX