summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-02-07 19:20:24 +0000
committerPacho Ramos <pacho@gentoo.org>2011-02-07 19:20:24 +0000
commit3d8f49d1d844b40b7538e47f8ae2880c5a2f5f7b (patch)
tree88987326887e52ebafe29f9ac09212005cc9587d /net-irc
parentAbort if sys-devel/prelink is installed wrt #353814. (diff)
downloadgentoo-2-3d8f49d1d844b40b7538e47f8ae2880c5a2f5f7b.tar.gz
gentoo-2-3d8f49d1d844b40b7538e47f8ae2880c5a2f5f7b.tar.bz2
gentoo-2-3d8f49d1d844b40b7538e47f8ae2880c5a2f5f7b.zip
Version bump with bugfixes, improve python handling and add gnome to metadata as talked between us since empathy relies on this.
(Portage version: 2.1.9.36/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/telepathy-idle/ChangeLog10
-rw-r--r--net-irc/telepathy-idle/telepathy-idle-0.1.7.ebuild39
2 files changed, 47 insertions, 2 deletions
diff --git a/net-irc/telepathy-idle/ChangeLog b/net-irc/telepathy-idle/ChangeLog
index 589345c45053..c58be7e88b54 100644
--- a/net-irc/telepathy-idle/ChangeLog
+++ b/net-irc/telepathy-idle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/telepathy-idle
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/telepathy-idle/ChangeLog,v 1.20 2010/09/29 17:38:53 pacho Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/telepathy-idle/ChangeLog,v 1.21 2011/02/07 19:20:24 pacho Exp $
+
+*telepathy-idle-0.1.7 (07 Feb 2011)
+
+ 07 Feb 2011; Pacho Ramos <pacho@gentoo.org> +telepathy-idle-0.1.7.ebuild:
+ Version bump with bugfixes, improve python handling and add gnome to metadata
+ as talked between us since empathy relies on this.
*telepathy-idle-0.1.6 (29 Sep 2010)
diff --git a/net-irc/telepathy-idle/telepathy-idle-0.1.7.ebuild b/net-irc/telepathy-idle/telepathy-idle-0.1.7.ebuild
new file mode 100644
index 000000000000..5755e46b2e2d
--- /dev/null
+++ b/net-irc/telepathy-idle/telepathy-idle-0.1.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/telepathy-idle/telepathy-idle-0.1.7.ebuild,v 1.1 2011/02/07 19:20:24 pacho Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit python
+
+DESCRIPTION="Full-featured IRC connection manager for Telepathy."
+HOMEPAGE="http://telepathy.freedesktop.org/wiki/Components"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="dev-libs/dbus-glib
+ >=dev-libs/glib-2.8.6:2
+ >=dev-libs/openssl-0.9.7
+ >=net-libs/telepathy-glib-0.11.3
+ sys-apps/dbus"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ test? ( dev-python/twisted-words )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS || die
+}