summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2010-04-06 22:06:41 +0000
committerLars Wendler <polynomial-c@gentoo.org>2010-04-06 22:06:41 +0000
commit632e0357a18a766cdd8959126d3762250dc85d71 (patch)
treed7a3f0a3b77ba15df5fa3acf4c9dbe17635a637e /net-irc
parentamd64 stable, bug #313585 (diff)
downloadgentoo-2-632e0357a18a766cdd8959126d3762250dc85d71.tar.gz
gentoo-2-632e0357a18a766cdd8959126d3762250dc85d71.tar.bz2
gentoo-2-632e0357a18a766cdd8959126d3762250dc85d71.zip
Converted ebuild to EAPI2. Fixed bug #286146 and #294636.
Dropped arm mips x86-fbsd keywords because of new ntlm dependency. (Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog13
-rw-r--r--net-irc/xchat/files/xchat-2.8.6-automagic-ntlm-configure-fix.patch34
-rw-r--r--net-irc/xchat/files/xchat-2.8.6-fix-button-underlines.patch12
-rw-r--r--net-irc/xchat/metadata.xml1
-rw-r--r--net-irc/xchat/xchat-2.8.6-r3.ebuild106
5 files changed, 164 insertions, 2 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index e209aa1a194d..97549f04fb2a 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-irc/xchat
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.277 2009/09/07 13:36:02 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.278 2010/04/06 22:06:41 polynomial-c Exp $
+
+*xchat-2.8.6-r3 (06 Apr 2010)
+
+ 06 Apr 2010; <polynomial-c@gentoo.org> +xchat-2.8.6-r3.ebuild,
+ +files/xchat-2.8.6-automagic-ntlm-configure-fix.patch,
+ +files/xchat-2.8.6-fix-button-underlines.patch:
+ Revbump. Converted ebuild to EAPI2. Fixed bug #286146 (thanks Evgen Boppi
+ for report and patch) and bug #294636 (reported by Joost Ruis).
+ Please CC me on bugreports regarding this revision.
07 Sep 2009; Raúl Porcel <armin76@gentoo.org> xchat-2.8.6-r1.ebuild,
xchat-2.8.6-r2.ebuild:
diff --git a/net-irc/xchat/files/xchat-2.8.6-automagic-ntlm-configure-fix.patch b/net-irc/xchat/files/xchat-2.8.6-automagic-ntlm-configure-fix.patch
new file mode 100644
index 000000000000..eee0a24d5c4f
--- /dev/null
+++ b/net-irc/xchat/files/xchat-2.8.6-automagic-ntlm-configure-fix.patch
@@ -0,0 +1,34 @@
+# https://sourceforge.net/tracker/?func=detail&aid=2982884&group_id=239&atid=100239
+
+--- xchat-2.8.6/configure.in
++++ xchat-2.8.6/configure.in
+@@ -143,6 +143,10 @@
+ [ --enable-spell=type enable spelling type: none static libsexy gtkspell],
+ spell=$enableval, spell=libsexy)
+
++AC_ARG_ENABLE(ntlm,
++[ --enable-ntlm enable Microsoft's NTLM auth (libntlm) library support],
++ ntlm=$enableval, ntlm=yes)
++
+ dnl *********************************************************************
+ dnl ** GLIB *************************************************************
+ dnl *********************************************************************
+@@ -548,11 +552,13 @@
+ dnl ** MS PROXY *********************************************************
+ dnl *********************************************************************
+
+-have_ntlm="no"
+-AC_CHECK_LIB(ntlm, ntlm_smb_encrypt, have_ntlm=yes)
+-if test "$have_ntlm" = yes; then
+- LIBS="$LIBS -lntlm"
+- AC_DEFINE(USE_MSPROXY)
++if test "x$ntlm" = "xyes" ; then
++ have_ntlm="no"
++ AC_CHECK_LIB(ntlm, ntlm_smb_encrypt, have_ntlm=yes)
++ if test "$have_ntlm" = yes; then
++ LIBS="$LIBS -lntlm"
++ AC_DEFINE(USE_MSPROXY)
++ fi
+ fi
+
+ dnl *********************************************************************
diff --git a/net-irc/xchat/files/xchat-2.8.6-fix-button-underlines.patch b/net-irc/xchat/files/xchat-2.8.6-fix-button-underlines.patch
new file mode 100644
index 000000000000..29f509324455
--- /dev/null
+++ b/net-irc/xchat/files/xchat-2.8.6-fix-button-underlines.patch
@@ -0,0 +1,12 @@
+# http://xchat.svn.sourceforge.net/viewvc/xchat/src/fe-gtk/gtkutil.c?r1=1138&r2=1362
+
+--- xchat-2.8.6/src/fe-gtk/gtkutil.c
++++ xchat-2.8.6/src/fe-gtk/gtkutil.c
+@@ -376,6 +376,7 @@ gtkutil_button (GtkWidget *box, char *st
+ {
+ gtk_button_set_label (GTK_BUTTON (wid), labeltext);
+ gtk_button_set_image (GTK_BUTTON (wid), gtk_image_new_from_stock (stock, GTK_ICON_SIZE_MENU));
++ gtk_button_set_use_underline (GTK_BUTTON (wid), TRUE);
+ if (box)
+ gtk_container_add (GTK_CONTAINER (box), wid);
+ }
diff --git a/net-irc/xchat/metadata.xml b/net-irc/xchat/metadata.xml
index 93f7814fa6ea..810cd1b4f490 100644
--- a/net-irc/xchat/metadata.xml
+++ b/net-irc/xchat/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>net-irc</herd>
<use>
+<flag name='ntlm'>Enable NTLM authentication</flag>
<flag name='xchatdccserver'>Enables support for the /dccserver command via a patch</flag>
<flag name='xchatnogtk'>Disables building the GTK front end to XChat</flag>
</use>
diff --git a/net-irc/xchat/xchat-2.8.6-r3.ebuild b/net-irc/xchat/xchat-2.8.6-r3.ebuild
new file mode 100644
index 000000000000..aaec016e13d9
--- /dev/null
+++ b/net-irc/xchat/xchat-2.8.6-r3.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.6-r3.ebuild,v 1.1 2010/04/06 22:06:41 polynomial-c Exp $
+
+EAPI=2
+
+inherit eutils versionator gnome2 autotools
+
+DESCRIPTION="Graphical IRC client"
+SRC_URI="http://www.xchat.org/files/source/$(get_version_component_range 1-2)/${P}.tar.bz2
+ mirror://sourceforge/${PN}/${P}.tar.bz2
+ xchatdccserver? ( mirror://gentoo/${PN}-dccserver-0.6.patch.bz2 )"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dbus ipv6 libnotify mmx nls ntlm perl python spell ssl tcl xchatnogtk xchatdccserver xft"
+
+RDEPEND=">=dev-libs/glib-2.6.0
+ !xchatnogtk? ( >=x11-libs/gtk+-2.10.0 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ python? ( >=dev-lang/python-2.2 )
+ tcl? ( dev-lang/tcl )
+ dbus? ( >=dev-libs/dbus-glib-0.71 )
+ spell? ( app-text/gtkspell )
+ libnotify? ( x11-libs/libnotify )
+ ntlm? ( net-libs/libntlm )
+ !<net-irc/xchat-gnome-0.9"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ # Added for to fix a sparc seg fault issue by Jason Wever <weeve@gentoo.org>
+ if [[ ${ARCH} = sparc ]] ; then
+ replace-flags "-O[3-9]" "-O2"
+ fi
+}
+
+src_prepare() {
+ use xchatdccserver && epatch "${DISTDIR}"/xchat-dccserver-0.6.patch.bz2
+
+ # use libdir/xchat/plugins as the plugin directory
+ if [ $(get_libdir) != "lib" ] ; then
+ sed -i -e 's:${prefix}/lib/xchat:${libdir}/xchat:' \
+ "${S}"/configure{,.in} || die
+ fi
+
+ epatch "${FILESDIR}"/xc286-smallfixes.diff
+ epatch "${FILESDIR}"/${P}-shm-pixmaps.patch
+ # bug #286146
+ epatch "${FILESDIR}"/${P}-fix-button-underlines.patch
+ # bug #294636
+ epatch "${FILESDIR}"/${P}-automagic-ntlm-configure-fix.patch
+
+ # don't disable deprecated gtk+ symbols, it's not forwards compatible, bug 234458
+ sed -i -e '/define GTK_DISABLE_DEPRECATED/d' src/fe-gtk/*.c
+
+ eautoreconf
+}
+
+src_configure() {
+ # xchat's configure script uses sys.path to find library path
+ # instead of python-config (#25943)
+ unset PYTHONPATH
+
+ econf \
+ --enable-shm \
+ $(use_enable dbus) \
+ $(use_enable ipv6) \
+ $(use_enable mmx) \
+ $(use_enable nls) \
+ $(use_enable ntlm) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable spell spell gtkspell) \
+ $(use_enable ssl openssl) \
+ $(use_enable tcl) \
+ $(use_enable !xchatnogtk gtkfe) \
+ $(use_enable xft)
+}
+
+src_install() {
+ USE_DESTDIR=1 gnome2_src_install || die "make install failed"
+
+ # install plugin development header
+ insinto /usr/include/xchat
+ doins src/common/xchat-plugin.h || die "doins failed"
+
+ dodoc ChangeLog README* || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "XChat binary has been renamed from xchat-2 to xchat."
+ elog
+
+ if has_version net-irc/xchat-systray
+ then
+ elog "XChat now includes it's own systray icon, you may want to remove net-irc/xchat-systray."
+ elog
+ fi
+}