summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-15 10:14:17 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-15 10:14:17 +0000
commit69cd04162c1e7f8e44c7253c7933c08b79b4b326 (patch)
tree576a51d80f58aef4c4b01628cb7e3bf03f228012 /net-irc
parentAdd patch from upstream to fix playlist encoding problems. (diff)
downloadgentoo-2-69cd04162c1e7f8e44c7253c7933c08b79b4b326.tar.gz
gentoo-2-69cd04162c1e7f8e44c7253c7933c08b79b4b326.tar.bz2
gentoo-2-69cd04162c1e7f8e44c7253c7933c08b79b4b326.zip
Version bump.
(Portage version: 2.1.1)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/rbot/ChangeLog8
-rw-r--r--net-irc/rbot/files/digest-rbot-0.9.103
-rw-r--r--net-irc/rbot/rbot-0.9.10.ebuild36
3 files changed, 46 insertions, 1 deletions
diff --git a/net-irc/rbot/ChangeLog b/net-irc/rbot/ChangeLog
index 662b1abbc159..cfa55794a727 100644
--- a/net-irc/rbot/ChangeLog
+++ b/net-irc/rbot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/rbot
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/ChangeLog,v 1.15 2006/07/31 23:16:31 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/ChangeLog,v 1.16 2006/09/15 10:14:17 flameeyes Exp $
+
+*rbot-0.9.10 (15 Sep 2006)
+
+ 15 Sep 2006; Diego Pettenò <flameeyes@gentoo.org> -rbot-0.9.9.ebuild,
+ -rbot-0.9.10_pre20060801.ebuild, +rbot-0.9.10.ebuild:
+ Version bump.
*rbot-0.9.10_pre20060801 (31 Jul 2006)
diff --git a/net-irc/rbot/files/digest-rbot-0.9.10 b/net-irc/rbot/files/digest-rbot-0.9.10
new file mode 100644
index 000000000000..8c161c9d85d7
--- /dev/null
+++ b/net-irc/rbot/files/digest-rbot-0.9.10
@@ -0,0 +1,3 @@
+MD5 886cc08498daa67ef275ca64d0a4ca70 rbot-0.9.10.tgz 385108
+RMD160 34b4240b1117c3f4a9e6a5c34f6e8435b0dfe56d rbot-0.9.10.tgz 385108
+SHA256 4429b2338fe008b763c811beffb0c23bdd457bb831aad1ca9df3272ae9ba909a rbot-0.9.10.tgz 385108
diff --git a/net-irc/rbot/rbot-0.9.10.ebuild b/net-irc/rbot/rbot-0.9.10.ebuild
new file mode 100644
index 000000000000..1f43b834ee4c
--- /dev/null
+++ b/net-irc/rbot/rbot-0.9.10.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/rbot/rbot-0.9.10.ebuild,v 1.1 2006/09/15 10:14:17 flameeyes Exp $
+
+inherit ruby
+
+DESCRIPTION="rbot is a ruby IRC bot"
+HOMEPAGE="http://www.linuxbrit.co.uk/rbot/"
+
+if [[ ${PV} != *_pre* ]]; then
+ SRC_URI="http://www.linuxbrit.co.uk/downloads/${P}.tgz"
+else
+ SRC_URI="mirror://gentoo/${P}.tgz"
+ S="${WORKDIR}/${PN}-${PV%%_*}"
+fi
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="spell"
+
+RDEPEND=">=virtual/ruby-1.8
+ dev-ruby/ruby-bdb
+ spell? ( app-text/ispell )"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ ruby_src_install
+ sed -i -e "s:${D}:/:" "${D}"/usr/lib/ruby/site_ruby/*/rbot/pkgconfig.rb
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Default configuration file location has changed from /etc/rbot to ~/.rbot"
+ einfo
+}