summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-04 21:14:24 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-04 21:14:24 +0000
commit71b8b2685d256b415bec383f82e3837864f19a6a (patch)
treeff7896ba653da66740ef1792a74c75fbd5cbd7db /net-irc
parentDelete older ebuilds. (diff)
downloadgentoo-2-71b8b2685d256b415bec383f82e3837864f19a6a.tar.gz
gentoo-2-71b8b2685d256b415bec383f82e3837864f19a6a.tar.bz2
gentoo-2-71b8b2685d256b415bec383f82e3837864f19a6a.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/supybot-plugins/ChangeLog8
-rw-r--r--net-irc/supybot-plugins/supybot-plugins-20060723-r2.ebuild57
2 files changed, 37 insertions, 28 deletions
diff --git a/net-irc/supybot-plugins/ChangeLog b/net-irc/supybot-plugins/ChangeLog
index 444a8d97166a..fcaace9face1 100644
--- a/net-irc/supybot-plugins/ChangeLog
+++ b/net-irc/supybot-plugins/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/supybot-plugins
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot-plugins/ChangeLog,v 1.4 2009/09/22 00:02:21 neurogeek Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot-plugins/ChangeLog,v 1.5 2010/04/04 21:14:24 arfrever Exp $
+
+ 04 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ supybot-plugins-20060723-r2.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
*supybot-plugins-20060723-r2 (22 Sep 2009)
diff --git a/net-irc/supybot-plugins/supybot-plugins-20060723-r2.ebuild b/net-irc/supybot-plugins/supybot-plugins-20060723-r2.ebuild
index c33120013514..b8f0b5d692e7 100644
--- a/net-irc/supybot-plugins/supybot-plugins-20060723-r2.ebuild
+++ b/net-irc/supybot-plugins/supybot-plugins-20060723-r2.ebuild
@@ -1,12 +1,15 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot-plugins/supybot-plugins-20060723-r2.ebuild,v 1.1 2009/09/22 00:02:21 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/supybot-plugins/supybot-plugins-20060723-r2.ebuild,v 1.2 2010/04/04 21:14:24 arfrever Exp $
-EAPI="2"
-inherit eutils python multilib
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
-MY_PNAME="Supybot-plugins"
-MY_P="${MY_PNAME}-${PV}"
+inherit eutils python
+
+MY_PN="Supybot-plugins"
+MY_P="${MY_PN}-${PV}"
DESCRIPTION="Official set of extra plugins for Supybot"
HOMEPAGE="http://supybot.com"
@@ -14,42 +17,44 @@ SRC_URI="mirror://sourceforge/supybot/${MY_P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=""
RDEPEND=">=net-irc/supybot-0.83.4
>=dev-python/twisted-conch-8.1.0
>=dev-python/twisted-web-1.0"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
src_prepare(){
epatch "${FILESDIR}/${PN}_credentials.patch"
}
src_install() {
- cd "${WORKDIR}"/${MY_P}
- python_version
- PLUGIN_BASE="/usr/$(get_libdir)/python${PYVER}/site-packages/supybot/plugins"
- for plugin in *; do
- case $plugin in
- BadWords|Dunno|Success)
- # These plugins are part of supybot-0.83.4 now, so skip them
- # here.
- continue
- ;;
- *)
- ;;
- esac
- insinto ${PLUGIN_BASE}/${plugin}
- doins $plugin/* || die "Install failed"
- done
+ installation() {
+ for plugin in *; do
+ case ${plugin} in
+ BadWords|Dunno|Success)
+ # These plugins are part of supybot-0.83.4 now, so skip them here.
+ continue
+ ;;
+ *)
+ ;;
+ esac
+
+ insinto $(python_get_sitedir)/supybot/plugins/${plugin}
+ doins ${plugin}/*
+ done
+ }
+ python_execute_function installation
}
pkg_postinst() {
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/supybot/plugins
+ python_mod_optimize supybot/plugins
}
pkg_postrm() {
- python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/supybot/plugins
+ python_mod_cleanup supybot/plugins
}