summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-06-20 02:30:19 +0000
committerSven Wegener <swegener@gentoo.org>2004-06-20 02:30:19 +0000
commit74fb0232bb6cb16d8dd084dc6ea596b3b30a9f5f (patch)
treee2c81912f80f977b23b449baaee8900081d9d04d /net-irc
parentsparc stable (Manifest recommit) (diff)
downloadgentoo-2-74fb0232bb6cb16d8dd084dc6ea596b3b30a9f5f.tar.gz
gentoo-2-74fb0232bb6cb16d8dd084dc6ea596b3b30a9f5f.tar.bz2
gentoo-2-74fb0232bb6cb16d8dd084dc6ea596b3b30a9f5f.zip
Initial import, ebuild based on net-irc/epic4
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/epic5/ChangeLog11
-rw-r--r--net-irc/epic5/Manifest4
-rw-r--r--net-irc/epic5/epic5-0.0.2.ebuild60
-rw-r--r--net-irc/epic5/files/0.0.2-segfault-fix.patch11
-rw-r--r--net-irc/epic5/files/digest-epic5-0.0.21
-rw-r--r--net-irc/epic5/files/epic-defaultserver.patch12
-rw-r--r--net-irc/epic5/metadata.xml5
7 files changed, 104 insertions, 0 deletions
diff --git a/net-irc/epic5/ChangeLog b/net-irc/epic5/ChangeLog
new file mode 100644
index 000000000000..c67de15f7c66
--- /dev/null
+++ b/net-irc/epic5/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-irc/epic5
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic5/ChangeLog,v 1.1 2004/06/20 02:30:19 swegener Exp $
+
+*epic5-0.0.2 (20 Jun 2004)
+
+ 20 Jun 2004; Sven Wegener <swegener@gentoo.org> +metadata.xml,
+ +files/0.0.2-segfault-fix.patch, +files/epic-defaultserver.patch,
+ +epic5-0.0.2.ebuild:
+ Initial import, ebuild based on net-irc/epic4
+
diff --git a/net-irc/epic5/Manifest b/net-irc/epic5/Manifest
new file mode 100644
index 000000000000..553bee5e543d
--- /dev/null
+++ b/net-irc/epic5/Manifest
@@ -0,0 +1,4 @@
+MD5 69cf0b49889785312c28a067de2ad6b2 epic5-0.0.2.ebuild 1928
+MD5 a0a06abf43f925f0472c026573bf622f files/epic-defaultserver.patch 620
+MD5 cbc7070ed83fbc5bd12ecea5821f6e74 files/digest-epic5-0.0.2 64
+MD5 1d5075abb862c8b98c2b16df96e37407 files/local 21043
diff --git a/net-irc/epic5/epic5-0.0.2.ebuild b/net-irc/epic5/epic5-0.0.2.ebuild
new file mode 100644
index 000000000000..f6487708443d
--- /dev/null
+++ b/net-irc/epic5/epic5-0.0.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic5/epic5-0.0.2.ebuild,v 1.1 2004/06/20 02:30:19 swegener Exp $
+
+inherit eutils
+
+
+DESCRIPTION="Epic5 IRC Client"
+SRC_URI="ftp://ftp.epicsol.org/pub/epic/EPIC5-ALPHA/${P}.tar.bz2"
+HOMEPAGE="http://epicsol.org/"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+IUSE="ipv6 perl ssl tcltk socks5"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( >=dev-libs/openssl-0.9.5 )
+ tcltk? ( dev-lang/tcl )
+ socks5? ( net-misc/dante )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/epic-defaultserver.patch
+ epatch ${FILESDIR}/${PV}-segfault-fix.patch
+
+ sed -i \
+ -e 's:/include/tcl$ver:/include:' \
+ -e 's:-lsocks5:-lsocks:' \
+ configure
+}
+
+src_compile() {
+ econf \
+ --libexecdir=/usr/lib/misc \
+ `use_with ipv6` \
+ `use_with perl` \
+ `use_with ssl` \
+ `use_with tcltk tcl` \
+ `use_with socks5` \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ einstall \
+ sharedir=${D}/usr/share \
+ libexecdir=${D}/usr/lib/misc || die "einstall failed"
+
+ dosym epic5-${PV} /usr/bin/epic5
+
+ dodoc BUG_FORM COPYRIGHT README KNOWNBUGS VOTES
+
+ cd doc
+ docinto doc
+ dodoc *.txt colors EPIC* IRCII_VERSIONS local_vars missing new-load
+ dodoc nicknames outputhelp SILLINESS TS4
+}
diff --git a/net-irc/epic5/files/0.0.2-segfault-fix.patch b/net-irc/epic5/files/0.0.2-segfault-fix.patch
new file mode 100644
index 000000000000..390857391561
--- /dev/null
+++ b/net-irc/epic5/files/0.0.2-segfault-fix.patch
@@ -0,0 +1,11 @@
+--- source/screen.c.orig 2004-06-20 03:56:13.636821920 +0200
++++ source/screen.c 2004-06-20 03:56:17.696204800 +0200
+@@ -1819,7 +1819,7 @@
+ * Otherwise, we just use /set continued_line,
+ * whatever it is.
+ */
+- else if ((!cont || !*cont) && *cont_ptr)
++ else if ((!cont || !*cont) && cont_ptr)
+ cont = LOCAL_COPY(cont_ptr);
+
+ cont_free = cont = normalize_string(cont, 0);
diff --git a/net-irc/epic5/files/digest-epic5-0.0.2 b/net-irc/epic5/files/digest-epic5-0.0.2
new file mode 100644
index 000000000000..d86eafff2815
--- /dev/null
+++ b/net-irc/epic5/files/digest-epic5-0.0.2
@@ -0,0 +1 @@
+MD5 08b7160260b84a1380463403117a02d8 epic5-0.0.2.tar.bz2 620530
diff --git a/net-irc/epic5/files/epic-defaultserver.patch b/net-irc/epic5/files/epic-defaultserver.patch
new file mode 100644
index 000000000000..d44123244fd9
--- /dev/null
+++ b/net-irc/epic5/files/epic-defaultserver.patch
@@ -0,0 +1,12 @@
+diff -Naur epic4-1.1.14.orig/include/config.h epic4-1.1.14/include/config.h
+--- epic4-1.1.14.orig/include/config.h 2003-10-28 05:53:57.000000000 +0000
++++ epic4-1.1.14/include/config.h 2004-01-03 13:49:53.083473288 +0000
+@@ -42,7 +42,7 @@
+ * the client will NOT compile and work properly! Use the default here if
+ * you dont have other servers to use.
+ */
+-#define DEFAULT_SERVER "localhost irc.efnet.net irc.undernet.org irc.dal.net"
++#define DEFAULT_SERVER "irc.freenode.net irc.efnet.net irc.undernet.org irc.dal.net"
+
+ /*
+ * The left and right brace characters ('{', '}') are special characters in
diff --git a/net-irc/epic5/metadata.xml b/net-irc/epic5/metadata.xml
new file mode 100644
index 000000000000..6ef15e900f17
--- /dev/null
+++ b/net-irc/epic5/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-irc</herd>
+</pkgmetadata>