summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Bormolini <lordjoe@gentoo.org>2001-10-30 02:22:37 +0000
committerJoe Bormolini <lordjoe@gentoo.org>2001-10-30 02:22:37 +0000
commit78f0b3e2c264332fa579698f984ce05c4a650044 (patch)
treea7e2a6842c889d7308cd6cde994e9cf0137ee00a /net-irc
parentAdded --with-innodb again after testing (diff)
downloadgentoo-2-78f0b3e2c264332fa579698f984ce05c4a650044.tar.gz
gentoo-2-78f0b3e2c264332fa579698f984ce05c4a650044.tar.bz2
gentoo-2-78f0b3e2c264332fa579698f984ce05c4a650044.zip
new version
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/files/digest-xchat-1.8.51
-rw-r--r--net-irc/xchat/xchat-1.8.5.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-irc/xchat/files/digest-xchat-1.8.5 b/net-irc/xchat/files/digest-xchat-1.8.5
new file mode 100644
index 000000000000..22e835d59fdc
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-1.8.5
@@ -0,0 +1 @@
+MD5 d5533374c2b81a28227c5a56793addfb xchat-1.8.5.tar.bz2 664576
diff --git a/net-irc/xchat/xchat-1.8.5.ebuild b/net-irc/xchat/xchat-1.8.5.ebuild
new file mode 100644
index 000000000000..d294f3236c2f
--- /dev/null
+++ b/net-irc/xchat/xchat-1.8.5.ebuild
@@ -0,0 +1,58 @@
+# Copyrigth 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>, Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.8.5.ebuild,v 1.1 2001/10/30 02:22:37 lordjoe Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="xchat irc client"
+SRC_URI="http://www.xchat.org/files/source/1.8/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+DEPEND=">=x11-libs/gtk+-1.2.10-r4
+ perl? ( sys-devel/perl )
+ python? ( >=dev-lang/python-2.0-r4 )
+ nls? ( >=sys-devel/gettext-0.10.38 )
+ gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1
+ >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+RDEPEND=">=x11-libs/gtk+-1.2.10-r4
+ gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1
+ >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+src_compile() {
+ local myopts myflags
+
+ #use gnome && myopts="--enable-gnome --enable-panel"
+ use gnome || myopts="--enable-gtkfe --disable-gnome \
+ --disable-gdk-pixbuf --disable-zvt"
+ use ssl && myopts="$myopts --enable-openssl"
+ use perl || myopts="$myopts --disable-perl"
+ use python && myflags="`python-config --libs` -lm"
+ use python || myopts="$myopts --disable-python"
+ use nls || myopts="$myopts --disable-nls"
+ use mmx && myopts="$myopts --enable-mmx"
+
+ CFLAGS="$CFLAGS -I/usr/include/orbit-1.0"
+
+ ./configure --prefix=/usr --host=${CHOST} ${myopts} --enable-ipv6 || die
+
+ if [ "$myflags" ] ; then
+ for i in src/fe-gtk src/fe-text
+ do
+ if [ -e $i/Makefile ] ; then
+ cp $i/Makefile $i/Makefile.orig
+ sed -e "s:-lpython2.0:$myflags:" \
+ $i/Makefile.orig > $i/Makefile
+ fi
+ done
+ fi
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+ dodoc AUTHORS COPYING ChangeLog README
+}