summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-08-25 21:02:22 +0000
committerSven Wegener <swegener@gentoo.org>2005-08-25 21:02:22 +0000
commit8ffa6eb15a9fd8bc9496660161ec65df9bac8d77 (patch)
treee905a1676bb57c3cf3b0bdc681ba24480956ce75 /net-irc
parentAdded support for the ssl USE flag, bug #103699. (diff)
downloadgentoo-2-8ffa6eb15a9fd8bc9496660161ec65df9bac8d77.tar.gz
gentoo-2-8ffa6eb15a9fd8bc9496660161ec65df9bac8d77.tar.bz2
gentoo-2-8ffa6eb15a9fd8bc9496660161ec65df9bac8d77.zip
Added support for the vanilla USE flag.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/eggdrop/ChangeLog5
-rw-r--r--net-irc/eggdrop/eggdrop-1.6.17-r2.ebuild46
2 files changed, 33 insertions, 18 deletions
diff --git a/net-irc/eggdrop/ChangeLog b/net-irc/eggdrop/ChangeLog
index b1931299b70e..a591aaf0f2e9 100644
--- a/net-irc/eggdrop/ChangeLog
+++ b/net-irc/eggdrop/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-irc/eggdrop
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/eggdrop/ChangeLog,v 1.45 2005/08/25 19:06:39 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/eggdrop/ChangeLog,v 1.46 2005/08/25 21:02:22 swegener Exp $
+
+ 25 Aug 2005; Sven Wegener <swegener@gentoo.org> eggdrop-1.6.17-r2.ebuild:
+ Added support for the vanilla USE flag.
25 Aug 2005; Aron Griffis <agriffis@gentoo.org> eggdrop-1.6.17-r2.ebuild:
stable on ia64
diff --git a/net-irc/eggdrop/eggdrop-1.6.17-r2.ebuild b/net-irc/eggdrop/eggdrop-1.6.17-r2.ebuild
index 2f445506a9e0..b9e4bb5f2b67 100644
--- a/net-irc/eggdrop/eggdrop-1.6.17-r2.ebuild
+++ b/net-irc/eggdrop/eggdrop-1.6.17-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/eggdrop/eggdrop-1.6.17-r2.ebuild,v 1.8 2005/08/25 19:06:39 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/eggdrop/eggdrop-1.6.17-r2.ebuild,v 1.9 2005/08/25 21:02:22 swegener Exp $
inherit eutils
@@ -15,18 +15,28 @@ SRC_URI="ftp://ftp.eggheads.org/pub/eggdrop/source/1.6/${MY_P}.tar.gz
KEYWORDS="alpha ~amd64 ia64 ~mips ppc sparc x86"
LICENSE="GPL-2"
SLOT="0"
-IUSE="debug static mysql postgres ssl"
+IUSE="debug static mysql postgres ssl vanilla"
DEPEND="dev-lang/tcl
- mysql? ( dev-db/mysql )
- postgres? ( dev-db/postgresql )
- ssl? ( dev-libs/openssl )"
+ !vanilla? (
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )
+ ssl? ( dev-libs/openssl )
+ )"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}"/${MY_P}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
+
+ if use vanilla
+ then
+ einfo "Excluding patches that install additional modules, this effectively"
+ einfo "disables the mysql, postgres and ssl USE flags."
+ echo
+ rm "${WORKDIR}"/patch/[12345678]*.patch
+ fi
EPATCH_SUFFIX="patch" epatch || die "epatch failed"
}
@@ -37,7 +47,7 @@ src_compile() {
use mysql || ( echo mysql ; echo mystats ) >>disabled_modules
use postgres || echo pgstats >>disabled_modules
- econf $(use_with ssl) || die "./configure failed"
+ econf $(use_with ssl) || die "econf failed"
make config || die "module config failed"
@@ -57,24 +67,27 @@ src_compile() {
src_install() {
local a b
- make DEST=${D}/opt/eggdrop install || die "make install failed"
+ make DEST="${D}"/opt/eggdrop install || die "make install failed"
for a in doc/*
do
[ -f ${a} ] && dodoc ${a}
done
- cd ${S}/src/mod
+ cd "${S}"/src/mod
for a in *.mod
do
for b in README UPDATES INSTALL TODO CONTENTS
do
- [ -f ${a}/${b} ] && newdoc ${a}/${b} ${b}.${a}
+ [[ -f ${a}/${b} ]] && newdoc ${a}/${b} ${b}.${a}
done
done
- cd ${S}
- dodoc \
+ cd "${S}"
+
+ dodoc text/motd.*
+
+ use vanilla || dodoc \
src/mod/botnetop.mod/botnetop.conf \
src/mod/gseen.mod/gseen.conf \
src/mod/mc_greet.mod/mc_greet.conf \
@@ -82,12 +95,11 @@ src_install() {
src/mod/away.mod/away.doc \
src/mod/rcon.mod/matchbot.tcl \
src/mod/mystats.mod/tools/mystats.{conf,sql} \
- src/mod/pgstats.mod/tools/{pgstats.conf,setup.sql} \
- text/motd.*
+ src/mod/pgstats.mod/tools/{pgstats.conf,setup.sql}
- dohtml ${S}/doc/html/*.html
+ dohtml doc/html/*.html
- dobin ${FILESDIR}/eggdrop-installer
+ dobin "${FILESDIR}"/eggdrop-installer
doman doc/man1/eggdrop.1
}