summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDawid Węgliński <cla@gentoo.org>2008-04-20 11:46:17 +0000
committerDawid Węgliński <cla@gentoo.org>2008-04-20 11:46:17 +0000
commit989f6c44232817f4b529f554c51fbd804938db32 (patch)
treeaeee9d69f68457c91fdf31aaf6138f492db7f699 /net-irc
parentVersion bump (diff)
downloadgentoo-2-989f6c44232817f4b529f554c51fbd804938db32.tar.gz
gentoo-2-989f6c44232817f4b529f554c51fbd804938db32.tar.bz2
gentoo-2-989f6c44232817f4b529f554c51fbd804938db32.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/znc/ChangeLog7
-rw-r--r--net-irc/znc/znc-0.054.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/net-irc/znc/ChangeLog b/net-irc/znc/ChangeLog
index 9e12421eb69e..d6eb75f4f33f 100644
--- a/net-irc/znc/ChangeLog
+++ b/net-irc/znc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/znc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.10 2008/01/21 11:06:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.11 2008/04/20 11:46:17 cla Exp $
+
+*znc-0.054 (20 Apr 2008)
+
+ 20 Apr 2008; Dawid Węgliński <cla@gentoo.org> +znc-0.054.ebuild:
+ Version bump
21 Jan 2008; Raúl Porcel <armin76@gentoo.org> -znc-0.050.ebuild:
old
diff --git a/net-irc/znc/znc-0.054.ebuild b/net-irc/znc/znc-0.054.ebuild
new file mode 100644
index 000000000000..8e5595fb484e
--- /dev/null
+++ b/net-irc/znc/znc-0.054.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.054.ebuild,v 1.1 2008/04/20 11:46:17 cla Exp $
+
+inherit autotools
+
+DESCRIPTION="An advanced IRC Bouncer"
+HOMEPAGE="http://znc.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ipv6 nomodules perl ssl"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.7d )
+ perl? ( dev-lang/perl )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable !nomodules modules) \
+ $(use_enable perl) \
+ $(use_enable ssl openssl) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed."
+ dodoc AUTHORS znc.conf || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "Run 'znc --makeconf' as the user you want to run ZNC as"
+ elog "to make a configuration file"
+ elog
+}